summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-02-28 18:31:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-02-28 18:31:06 +0000
commitadcba639bd53641cf29900525f5942c9e186caea (patch)
treef7f2e105e11ff756a12d0681d3564c3f2d82958f /app-emulation/qemu
parentzaphfc fixes by Stefan "stkn" Knoblich, closes bug #406189 by Ogelpre. These ... (diff)
downloadgentoo-2-adcba639bd53641cf29900525f5942c9e186caea.tar.gz
gentoo-2-adcba639bd53641cf29900525f5942c9e186caea.tar.bz2
gentoo-2-adcba639bd53641cf29900525f5942c9e186caea.zip
Switch to upstream's '--disable-debug-info' to avoid OOM bug #355861.
(Portage version: 2.2.0_alpha89_p3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog5
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index a4734d9c97ad..241c9ac3a6fb 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.104 2012/02/25 21:03:08 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.105 2012/02/28 18:31:06 slyfox Exp $
+
+ 28 Feb 2012; Sergei Trofimovich <slyfox@gentoo.org> qemu-9999.ebuild:
+ Switch to upstream's '--disable-debug-info' to avoid OOM bug #355861.
25 Feb 2012; Doug Goldstein <cardoe@gentoo.org> qemu-1.0-r3.ebuild:
When building with USE=static, zlib needs to be built with USE=static-libs.
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 27bdd582aa51..13f248e2013d 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.15 2012/01/29 12:18:34 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.16 2012/02/28 18:31:06 slyfox Exp $
EAPI=4
@@ -132,11 +132,6 @@ src_prepare() {
# prevent docs to get automatically installed
sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
- # drop '-g' by default as it tends to eat
- # A LOT (~2GB) of ram for each job #355861
- sed -e 's/CFLAGS="-g $CFLAGS"/CFLAGS="$CFLAGS"/g' \
- -i configure || die
-
# Fix underlinking.
# Fault reproducer: USE=nss QEMU_SOFTMMU_TARGETS=lm32 QEMU_USER_TARGETS=
sed -i 's/opengl_libs="-lGL"/opengl_libs="-lGL -lX11"/' configure || die
@@ -171,6 +166,10 @@ src_configure() {
# Fix QA issues. QEMU needs executable heaps and we need to mark it as such
conf_opts="${conf_opts} --extra-ldflags=-Wl,-z,execheap"
+ # drop '-g' by default as it tends to eat
+ # A LOT (~2GB) of ram for each job #355861
+ conf_opts="${conf_opts} --disable-debug-info"
+
# Add support for static builds
use static && conf_opts="${conf_opts} --static"