summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-10 23:46:39 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-10 23:46:39 +0000
commita5bc3d3db0df18b77a1933632762dcaef49c19d0 (patch)
tree0fe4dab1332045fd083e30da7bdc493d3f0ed058 /app-emulation/qemu-kvm
parentVersion bump, remove old. (diff)
downloadgentoo-2-a5bc3d3db0df18b77a1933632762dcaef49c19d0.tar.gz
gentoo-2-a5bc3d3db0df18b77a1933632762dcaef49c19d0.tar.bz2
gentoo-2-a5bc3d3db0df18b77a1933632762dcaef49c19d0.zip
Fix 'virtfs' USE flag to correctly depend on sys-libs/libcap and not depend on kernel features which aren't necessary on the host. Add USE flag for libcap-ng usage called 'caps'. bug #425476
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu-kvm')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog7
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild12
2 files changed, 12 insertions, 7 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 33e9f9903bb0..3cc12410f732 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.132 2012/07/10 18:36:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.133 2012/07/10 23:46:39 cardoe Exp $
+
+ 10 Jul 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.1.0.ebuild:
+ Fix 'virtfs' USE flag to correctly depend on sys-libs/libcap and not depend
+ on kernel features which aren't necessary on the host. Add USE flag for
+ libcap-ng usage called 'cap'. bug #425476
10 Jul 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.1.0.ebuild,
metadata.xml:
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
index a22602b0b7c4..4b1ed55d4d3d 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild,v 1.10 2012/07/10 18:36:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.1.0.ebuild,v 1.11 2012/07/10 23:46:39 cardoe Exp $
EAPI="4"
@@ -25,7 +25,7 @@ HOMEPAGE="http://www.linux-kvm.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+aio alsa bluetooth brltty +curl debug doc fdt kernel_linux \
+IUSE="+aio alsa bluetooth brltty +caps +curl debug doc fdt kernel_linux \
kernel_FreeBSD ncurses opengl pulseaudio python rbd sasl sdl \
smartcard spice static tci tls usbredir vde +vhost-net virtfs xattr xen xfs"
@@ -54,6 +54,7 @@ REQUIRED_USE="static? ( !alsa !pulseaudio )
x86? ( qemu_softmmu_targets_x86_64 )
virtfs? ( xattr )"
+# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
RDEPEND="
!app-emulation/kqemu
!app-emulation/qemu
@@ -70,6 +71,7 @@ RDEPEND="
alsa? ( >=media-libs/alsa-lib-1.0.13 )
bluetooth? ( net-wireless/bluez )
brltty? ( app-accessibility/brltty )
+ caps? ( sys-libs/libcap-ng )
curl? ( >=net-misc/curl-7.15.4 )
fdt? ( >=sys-apps/dtc-1.2.0 )
kernel_linux? ( >=sys-apps/util-linux-2.16.0 )
@@ -91,6 +93,7 @@ RDEPEND="
tls? ( net-libs/gnutls )
usbredir? ( sys-apps/usbredir )
vde? ( net-misc/vde )
+ virtfs? ( sys-libs/libcap )
xattr? ( sys-apps/attr )
xen? ( app-emulation/xen-tools )
xfs? ( sys-fs/xfsprogs )"
@@ -157,10 +160,6 @@ pkg_pretend() {
use python && CONFIG_CHECK+=" ~DEBUG_FS"
ERROR_DEBUG_FS="debugFS support required for kvm_stat"
- if use virtfs; then
- CONFIG_CHECK+=" ~NET_9P ~NET_9P_VIRTIO ~9P_FS ~9P_FS_POSIX_ACL"
- fi
-
# Now do the actual checks setup above
check_extra_config
fi
@@ -250,6 +249,7 @@ src_configure() {
$(use_enable aio linux-aio) \
$(use_enable bluetooth bluez) \
$(use_enable brltty brlapi) \
+ $(use_enable caps cap-ng) \
$(use_enable curl) \
$(use_enable debug debug-info) \
$(use_enable debug debug-mon) \