summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-12 23:00:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-12 23:00:09 +0000
commit5a95fc9a5bb24788e3ddae43b20aea4dc5caa3d7 (patch)
treea4c920dbf1fb9abe6da341fdbd9895566798d91f /app-emulation/point2play
parentUpdate to a newer Netrw snapshot to fix problems with vim7-specific code bein... (diff)
downloadgentoo-2-5a95fc9a5bb24788e3ddae43b20aea4dc5caa3d7.tar.gz
gentoo-2-5a95fc9a5bb24788e3ddae43b20aea4dc5caa3d7.tar.bz2
gentoo-2-5a95fc9a5bb24788e3ddae43b20aea4dc5caa3d7.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog7
-rw-r--r--app-emulation/point2play/files/digest-point2play-2.0.31
-rw-r--r--app-emulation/point2play/point2play-2.0.3.ebuild47
3 files changed, 54 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 4a2730c87f7f..b9eb26fd0b8b 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/point2play
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.21 2005/07/22 00:03:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.22 2005/08/12 23:00:09 vapier Exp $
+
+*point2play-2.0.3 (12 Aug 2005)
+
+ 12 Aug 2005; Mike Frysinger <vapier@gentoo.org> +point2play-2.0.3.ebuild:
+ Version bump.
22 Jul 2005; Mike Frysinger <vapier@gentoo.org> point2play-2.0.2.ebuild:
Add support for Emerald club members #99618 by Paul Varner.
diff --git a/app-emulation/point2play/files/digest-point2play-2.0.3 b/app-emulation/point2play/files/digest-point2play-2.0.3
new file mode 100644
index 000000000000..bec53310df6c
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-2.0.3
@@ -0,0 +1 @@
+MD5 306a6a454e0f106c80012edb91c9854c point2play-small-2.0.3.tgz 1293081
diff --git a/app-emulation/point2play/point2play-2.0.3.ebuild b/app-emulation/point2play/point2play-2.0.3.ebuild
new file mode 100644
index 000000000000..24703c9804c4
--- /dev/null
+++ b/app-emulation/point2play/point2play-2.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-2.0.3.ebuild,v 1.1 2005/08/12 23:00:09 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="!emerald? ( ${MY_P}.tgz )"
+ #emerald? ( ${MY_P}_emerald.tgz )"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE="" #emerald"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ amd64? ( >=app-emulation/emul-linux-x86-soundlibs-2.1 )"
+ #>=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive:"
+ use emerald \
+ && einfo " ${MY_P}_emerald.tgz" \
+ || einfo " ${MY_P}.tgz"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.3.2-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr "${D}"/ || die "mv usr"
+ # remove duplicated desktop files
+ rm -r "${D}"/usr/share/gnome
+}