summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-13 12:18:46 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-13 12:18:46 +0000
commita73ce91f9513bd33183ad9daf0927620ca45f8d3 (patch)
treec7830c8da45bc361f889ce9dd94799cd0b9e83e0 /app-emulation/playonlinux
parentRemove old version. (diff)
downloadgentoo-2-a73ce91f9513bd33183ad9daf0927620ca45f8d3.tar.gz
gentoo-2-a73ce91f9513bd33183ad9daf0927620ca45f8d3.tar.bz2
gentoo-2-a73ce91f9513bd33183ad9daf0927620ca45f8d3.zip
version bump to 3.6, bug 277469
(Portage version: 13805-svn/cvs/Linux i686)
Diffstat (limited to 'app-emulation/playonlinux')
-rw-r--r--app-emulation/playonlinux/ChangeLog7
-rw-r--r--app-emulation/playonlinux/playonlinux-3.6.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
index 2d03b7b51ff5..905686c16f35 100644
--- a/app-emulation/playonlinux/ChangeLog
+++ b/app-emulation/playonlinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/playonlinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.3 2009/06/13 10:16:23 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.4 2009/07/13 12:18:46 volkmar Exp $
+
+*playonlinux-3.6 (13 Jul 2009)
+
+ 13 Jul 2009; Mounir Lamouri <volkmar@gentoo.org> +playonlinux-3.6.ebuild:
+ Version bump to 3.6. Fix bug 277469
13 Jun 2009; Torsten Veller <tove@gentoo.org> playonlinux-3.5.ebuild:
Add missing die: "..." -> die "..."
diff --git a/app-emulation/playonlinux/playonlinux-3.6.ebuild b/app-emulation/playonlinux/playonlinux-3.6.ebuild
new file mode 100644
index 000000000000..88825bb622a9
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-3.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.6.ebuild,v 1.1 2009/07/13 12:18:46 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils python games
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows(tm) games and softwares"
+HOMEPAGE="http://playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ app-arch/cabextract
+ app-arch/unzip
+ dev-python/wxpython:2.8
+ media-gfx/imagemagick
+ x11-terms/xterm"
+
+S=${WORKDIR}/${PN}
+
+# TODO:
+# Having a real install script and let playonlinux use standard filesystem
+# architecture to prevent having everything installed into GAMES_DATADIR
+# It will let using LANGUAGES easily
+
+src_prepare() {
+ einfo "Removing temporary files..."
+ rm -f $(find . -name *.pyc) || die "rm -f doesn't die"
+ rm -f $(find . -name *~) || die "rm -f doesn't die"
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r themes lang lib etc || die "doins failed"
+
+ # bash/ install
+ exeinto "${GAMES_DATADIR}/${PN}/bash"
+ doexe bash/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/bash/terminals"
+ doexe bash/terminals/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/bash/expert"
+ doexe bash/expert/* || die "doexe failed"
+
+ # python/ install
+ exeinto "${GAMES_DATADIR}/${PN}/python"
+ doexe python/* || die "doexe failed"
+ # sub dir without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}/python"
+ doins -r python/lib || die "doins failed"
+
+ # daemon/ install
+ exeinto "${GAMES_DATADIR}/${PN}/daemon"
+ doexe daemon/* || die "doexe failed"
+
+ # main executable files
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe ${PN}{,-pkg,-daemon} || die "doexe failed"
+
+ # making a script to run app from ${GAMES_BINDIR}
+ echo "#!/bin/bash" > ${PN}_launcher
+ echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN}" >> ${PN}_launcher
+ newgamesbin playonlinux_launcher playonlinux || die "newgamesbin failed"
+
+ dodoc CHANGELOG || die "dodoc failed"
+
+ doicon etc/${PN}.png || die "doicon failed"
+ domenu etc/${MY_PN}.desktop || die "domenu failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ python_mod_optimize "${ROOT}${GAMES_DATADIR}/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}${GAMES_DATADIR}/${PN}"
+
+ ewarn "Installed softwares and games with playonlinux have not been removed."
+ ewarn "To remove them, you can re-install playonlinux and remove them using it"
+ ewarn "or do it manually."
+}