summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-23 19:17:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-23 19:17:16 +0000
commit9dc73973f3e8fcebba495c96c453d15791afc5e9 (patch)
tree37933a1ea8e305f8a00b113090c4308bd249c542 /app-emulation/phpvirtualbox
parentRemove old. (diff)
downloadgentoo-2-9dc73973f3e8fcebba495c96c453d15791afc5e9.tar.gz
gentoo-2-9dc73973f3e8fcebba495c96c453d15791afc5e9.tar.bz2
gentoo-2-9dc73973f3e8fcebba495c96c453d15791afc5e9.zip
Version bump
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'app-emulation/phpvirtualbox')
-rw-r--r--app-emulation/phpvirtualbox/ChangeLog8
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.2.3b.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/app-emulation/phpvirtualbox/ChangeLog b/app-emulation/phpvirtualbox/ChangeLog
index fd140487c64c..1968c9fe1981 100644
--- a/app-emulation/phpvirtualbox/ChangeLog
+++ b/app-emulation/phpvirtualbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/phpvirtualbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.6 2012/10/10 20:15:35 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.7 2012/10/23 19:17:16 hwoarang Exp $
+
+*phpvirtualbox-4.2.3b (23 Oct 2012)
+
+ 23 Oct 2012; Markos Chandras <hwoarang@gentoo.org>
+ +phpvirtualbox-4.2.3b.ebuild:
+ Version bump
*phpvirtualbox-4.1.11 (10 Oct 2012)
*phpvirtualbox-4.2.1 (10 Oct 2012)
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.2.3b.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.2.3b.ebuild
new file mode 100644
index 000000000000..cf1dce068c2d
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.2.3b.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.2.3b.ebuild,v 1.1 2012/10/23 19:17:16 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator eutils webapp depend.php
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="http://phpvirtualbox.googlecode.com"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+need_php_httpd
+
+src_install() {
+ webapp_src_preinst
+
+ cd ${MY_P}
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt || die
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Local or remote virtualbox hosts must be compiled with"
+ elog "'vboxwebsrv' useflag and the respective init script"
+ elog "must be running to use this interface"
+ elog " /etc/init.d/vboxwebsrv start"
+ elog
+ elog "To enable the automatic startup mode feature uncomment the"
+ elog "following line in the config.php file:"
+ elog " var \$startStopConfig = true;"
+ elog
+ elog "You should also add the /etc/init.d/vboxinit script to the"
+ elog "default runlevel on the virtualbox host:"
+ elog "\`rc-update add vboxinit default\`"
+ elog "If the server is on a remote host, than the script must be"
+ elog "copied manually from"
+ elog "${FILESDIR}/vboxinit-initd to /etc/init.d/vboxinit"
+ elog "on the remote host."
+}