summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-11-06 21:04:21 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-11-06 21:04:21 +0000
commit754e4f3b4b7015d746c753227250803ac409c53c (patch)
tree849c1c9ccfe1510ffa502db5ae0b926663c28369 /app-emulation/mol
parentaqbanking fix conditionally setting of depend (diff)
downloadgentoo-2-754e4f3b4b7015d746c753227250803ac409c53c.tar.gz
gentoo-2-754e4f3b4b7015d746c753227250803ac409c53c.tar.bz2
gentoo-2-754e4f3b4b7015d746c753227250803ac409c53c.zip
New version with compressed disk image support.
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog8
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.72_pre13
-rw-r--r--app-emulation/mol/mol-0.9.72_pre1.ebuild138
3 files changed, 148 insertions, 1 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 2ceefedef5ba..68f2cd22e530 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.65 2006/10/28 19:54:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.66 2006/11/06 21:04:21 josejx Exp $
+
+*mol-0.9.72_pre1 (06 Nov 2006)
+
+ 06 Nov 2006; Joseph Jezak <josejx@gentoo.org>
+ -files/mol-0.9.71_pre8-to-pre9.patch, +mol-0.9.72_pre1.ebuild:
+ New version with compressed disk image support.
*mol-0.9.71.1 (28 Oct 2006)
diff --git a/app-emulation/mol/files/digest-mol-0.9.72_pre1 b/app-emulation/mol/files/digest-mol-0.9.72_pre1
new file mode 100644
index 000000000000..d89d54e013db
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.72_pre1
@@ -0,0 +1,3 @@
+MD5 24d254ebf4a6ff3d1acb6da63a102b97 mol-0.9.72_pre1.tar.bz2 1850554
+RMD160 e099ca41b1f64a317e2e418b575a80bec71c5100 mol-0.9.72_pre1.tar.bz2 1850554
+SHA256 27e6302eb9eba909f1c2758d48934a09bcbc8751258a30c1140b3995fc3a9ddc mol-0.9.72_pre1.tar.bz2 1850554
diff --git a/app-emulation/mol/mol-0.9.72_pre1.ebuild b/app-emulation/mol/mol-0.9.72_pre1.ebuild
new file mode 100644
index 000000000000..a6a6d4b6c2ea
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.72_pre1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre1.ebuild,v 1.1 2006/11/06 21:04:21 josejx Exp $
+
+inherit flag-o-matic eutils linux-mod
+
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+HOMEPAGE="http://mac-on-linux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mac-on-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc"
+IUSE="vnc alsa oss fbcon X oldworld sheep debug dga usb pci"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables
+ alsa? ( virtual/alsa )
+ vnc? ( net-misc/vnc )
+ X? ( || ( ( x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga )
+ )
+ virtual/x11
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-libs/libXt
+ x11-proto/xextproto
+ dga? ( x11-proto/xf86dgaproto )
+ )
+ virtual/x11
+ )
+ )"
+
+MODULE_NAMES="mol(mol:${S}/src/kmod/Linux)
+ sheep(net:${S}/src/netdriver)"
+
+pkg_setup() {
+ echo
+ einfo "If you want to use MOL fullscreen on a virtual console"
+ einfo "be sure to have the USE-flag \"fbcon\" set!"
+ echo
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # PCI Debugging Patch
+ if use debug; then
+ epatch ${FILESDIR}/${PN}-pciproxy-dump.patch
+ fi
+}
+
+src_compile() {
+ filter-flags -fsigned-char
+ append-flags -D_FILE_OFFSET_BITS=64
+ append-flags -D_LARGE_FILES
+
+ export KERNEL_SOURCE="/usr/src/${FK}"
+ export LDFLAGS=""
+
+ # initialize all needed build-files
+ ./autogen.sh
+ ./configure --prefix="/usr" || die "Configure failed."
+
+ # workaround for proper module-building
+ emake defconfig || die "Make failed."
+
+ sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
+ sed -i "s:CONFIG_TUN=y:# CONFIG_TUN is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
+
+ einfo "The configuration has been altered according to your USE-flags."
+ # reinitialize our changed configuration
+ emake oldconfig
+
+ cd ${S}
+ emake BUILD_MODS=n || die "Build failed."
+
+ # Build the modules too!
+ BUILD_PARAMS="KERNEL_SOURCE=${KV_DIR} LV=${KV_MAJOR}${KV_MINOR} MP=${KV_OBJ}
+ KUNAME=${KV}"
+ BUILD_TARGETS=all
+ linux-mod_src_compile
+}
+
+src_install() {
+ #linux-mod_src_install
+ cd ${S}
+ emake DESTDIR=${D} install || die "Failed to install"
+ dodoc CREDITS Doc/Boot-ROM Doc/NewWorld-ROM Doc/Sound Doc/Video
+ dodoc Doc/Networking Doc/Dev/Debugger Doc/Dev/Addresses
+ dodoc Doc/man/molvconfig.1 Doc/man/startmol.1 Doc/man/molrc.5
+ insinto /var/lib/mol
+ doins ${S}/mollib/nvram/nvram.x
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " http://www.maconlinux.org"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ ewarn "For networking and sound you might install the drivers in the"
+ ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ ewarn "If errors with networking occur, make sure you have the following"
+ ewarn "kernel functions enabled:"
+ einfo "For connecting to Linux:"
+ einfo " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ einfo "For the dhcp server:"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}