summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-02-09 19:19:52 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-02-09 19:19:52 +0000
commitfcb57acae6548416c2f993cd13eff394d7e56ccc (patch)
treeb46beea17e6bd847f32bc6823804df0c1c1ca40d /app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild
parentRestored freetype-2.1.9-r1.ebuild because that version is still in use by alp... (diff)
downloadgentoo-2-fcb57acae6548416c2f993cd13eff394d7e56ccc.tar.gz
gentoo-2-fcb57acae6548416c2f993cd13eff394d7e56ccc.tar.bz2
gentoo-2-fcb57acae6548416c2f993cd13eff394d7e56ccc.zip
Depend on dev-libs/glib-2 instead of dev-libs/glib-1 for bug 166088. Thanks to Ooblick <txe_stc at yahoo.com>.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild')
-rw-r--r--app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild b/app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..2bbec235f3d1
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/libspectrum-0.2.2-r1.ebuild,v 1.1 2007/02/09 19:19:52 vanquirius Exp $
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://www.srcf.ucam.org/~pak21/spectrum/libspectrum.html"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/libgcrypt
+ dev-lang/perl"
+
+src_compile() {
+ econf --with-glib || die
+ emake -j1 || die "libspectrum make failed!"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+}