summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-08 20:22:22 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-08 20:22:22 +0000
commit7e7fe7833db7dc7c776d87b52547baff93636dfe (patch)
tree24e57bfde874129e062d1397d693d88cd6fcf367 /app-emulation/libguestfs-appliance
parentVersion bump. (diff)
downloadgentoo-2-7e7fe7833db7dc7c776d87b52547baff93636dfe.tar.gz
gentoo-2-7e7fe7833db7dc7c776d87b52547baff93636dfe.tar.bz2
gentoo-2-7e7fe7833db7dc7c776d87b52547baff93636dfe.zip
Unpack directly into $D to speed the install up. Add a blocker against older libguestfs versions #501588 by Ernest CHIARELLO.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation/libguestfs-appliance')
-rw-r--r--app-emulation/libguestfs-appliance/ChangeLog9
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild44
2 files changed, 52 insertions, 1 deletions
diff --git a/app-emulation/libguestfs-appliance/ChangeLog b/app-emulation/libguestfs-appliance/ChangeLog
index cbe2047ae775..3444d6528359 100644
--- a/app-emulation/libguestfs-appliance/ChangeLog
+++ b/app-emulation/libguestfs-appliance/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/libguestfs-appliance
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.2 2014/05/01 19:57:02 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.3 2014/11/08 20:22:22 vapier Exp $
+
+*libguestfs-appliance-1.26.0-r1 (08 Nov 2014)
+
+ 08 Nov 2014; Mike Frysinger <vapier@gentoo.org>
+ +libguestfs-appliance-1.26.0-r1.ebuild:
+ Unpack directly into $D to speed the install up. Add a blocker against older
+ libguestfs versions #501588 by Ernest CHIARELLO.
*libguestfs-appliance-1.24.8 (01 May 2014)
*libguestfs-appliance-1.26.0 (01 May 2014)
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..6a51f482ca57
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/libguestfs-appliance-1.26.0-r1.ebuild,v 1.1 2014/11/08 20:22:22 vapier Exp $
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ rm README* || die
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}