summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-24 21:18:41 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-24 21:18:41 +0000
commitcf0806d58bfec0fa71aa5b181aa570b38d25e14f (patch)
treeb4a9c7ab90747d8c3092d439b63ab86b95ae2c58 /app-emulation/hercules
parentarm/s390/sh stable (diff)
downloadgentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.tar.gz
gentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.tar.bz2
gentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.zip
Version bump #183079 by Jay Maynard.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/ChangeLog7
-rw-r--r--app-emulation/hercules/files/digest-hercules-3.053
-rw-r--r--app-emulation/hercules/hercules-3.05.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index 878ae8753f9f..60521aba43d2 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.17 2007/04/07 14:50:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.18 2007/06/24 21:18:41 vapier Exp $
+
+*hercules-3.05 (24 Jun 2007)
+
+ 24 Jun 2007; Mike Frysinger <vapier@gentoo.org> +hercules-3.05.ebuild:
+ Version bump #183079 by Jay Maynard.
*hercules-3.04 (07 Apr 2007)
diff --git a/app-emulation/hercules/files/digest-hercules-3.05 b/app-emulation/hercules/files/digest-hercules-3.05
new file mode 100644
index 000000000000..90e074479875
--- /dev/null
+++ b/app-emulation/hercules/files/digest-hercules-3.05
@@ -0,0 +1,3 @@
+MD5 da8d85ac18c140b460574a0454abb936 hercules-3.05.tar.gz 2470621
+RMD160 98013b1d2f642ea86f71a07638a90758de7b396e hercules-3.05.tar.gz 2470621
+SHA256 f190221fa25692c0316be331f618c0675f9f9875c44b8af3efa7a431d138b1e2 hercules-3.05.tar.gz 2470621
diff --git a/app-emulation/hercules/hercules-3.05.ebuild b/app-emulation/hercules/hercules-3.05.ebuild
new file mode 100644
index 000000000000..073e94352142
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.05.ebuild,v 1.1 2007/06/24 21:18:41 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.org/"
+SRC_URI="http://www.hercules-390.org/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="custom-cflags"
+
+src_compile() {
+ use custom-cflags || strip-flags
+ econf \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES CHANGES
+}