summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-07-21 15:08:51 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-07-21 15:08:51 +0000
commitc66a63a63b83f4700bd22ad2b5007119f90ea9e7 (patch)
treedeee7ae2d50af2315a71e93f5352551289ec11db /app-emulation/bochs
parentfixed bass's nonsense variables (diff)
downloadgentoo-2-c66a63a63b83f4700bd22ad2b5007119f90ea9e7.tar.gz
gentoo-2-c66a63a63b83f4700bd22ad2b5007119f90ea9e7.tar.bz2
gentoo-2-c66a63a63b83f4700bd22ad2b5007119f90ea9e7.zip
Added LICENSE and SLOTS to meet repoman and lintool requirements
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/bochs-1.4.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-emulation/bochs/bochs-1.4.ebuild b/app-emulation/bochs/bochs-1.4.ebuild
index 0408e619ccdf..cb6a87084b24 100644
--- a/app-emulation/bochs/bochs-1.4.ebuild
+++ b/app-emulation/bochs/bochs-1.4.ebuild
@@ -1,28 +1,31 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
PN=${P/_/.}
S=${WORKDIR}/${PN}
DESCRIPTION="Bochs is a pc emulator.
- This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
+This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
CDROM drive.
- It also comes with a disk image using dlxlinux."
+It also comes with a disk image using dlxlinux."
SRC_URI="mirror://sourceforge/bochs/${PN}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
HOMEPAGE="http://bochs.sourceforge.net"
+LICENSE="LGPL-2.1"
+SLOT="0"
#build-time dependencies
DEPEND=">=sys-libs/glibc-2.1.3
>=x11-base/xfree-4.0.1"
+RDEPEND="${DEPEND}"
+
KEYWORDS="x86 ppc"
src_unpack() {
+ unpack ${PN}.tar.gz
- unpack ${PN}.tar.gz
-
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ cd $S
+ cp Makefile.in Makefile.in.orig
+ sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
-e 's: $(prefix): $(DESTDIR)$(prefix):g' \
-e 's: $(bindir): $(DESTDIR)$(bindir):g' \
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
@@ -31,20 +34,20 @@ src_unpack() {
src_compile() {
- ./configure --enable-fpu --enable-cdrom --enable-control-panel \
+ ./configure --enable-fpu --enable-cdrom --enable-control-panel \
--enable-ne2000 --enable-sb16=linux -enable-slowdown --prefix=/usr \
--infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} --with-x11 || die
# there's an sdl interface now, but since we an only compile 1 interface at a time
# i'd rather have xwindows.
- emake || die
+ emake || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CVS README TESTFORM.txt
}