summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-02-20 13:48:07 +0000
committerUlrich Müller <ulm@gentoo.org>2011-02-20 13:48:07 +0000
commitc5a2a63ec911222f3b0da200459e43d1f4d79f11 (patch)
tree81a30f3d61a97382c1e68487ff9fda408404cfbf /app-emacs
parentFix compilation for userpriv (diff)
downloadgentoo-2-c5a2a63ec911222f3b0da200459e43d1f4d79f11.tar.gz
gentoo-2-c5a2a63ec911222f3b0da200459e43d1f4d79f11.tar.bz2
gentoo-2-c5a2a63ec911222f3b0da200459e43d1f4d79f11.zip
Version bump. Call elisp-site-regen in postinst phase, fixes bug 355451.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/python-mode/ChangeLog10
-rw-r--r--app-emacs/python-mode/files/50python-mode-gentoo.el10
-rw-r--r--app-emacs/python-mode/python-mode-5.1.0.ebuild8
-rw-r--r--app-emacs/python-mode/python-mode-5.2.0.ebuild31
4 files changed, 52 insertions, 7 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 011dd844eb2c..54a060016ad4 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/python-mode
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.49 2010/10/12 22:30:04 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.50 2011/02/20 13:48:07 ulm Exp $
+
+*python-mode-5.2.0 (20 Feb 2011)
+
+ 20 Feb 2011; Ulrich Mueller <ulm@gentoo.org> +files/50python-mode-gentoo.el,
+ python-mode-5.1.0.ebuild, +python-mode-5.2.0.ebuild:
+ Version bump. Call elisp-site-regen in postinst phase, fixes bug 355451.
12 Oct 2010; Ulrich Mueller <ulm@gentoo.org> -files/setup.py:
Remove unused file, fixes bug 340705.
diff --git a/app-emacs/python-mode/files/50python-mode-gentoo.el b/app-emacs/python-mode/files/50python-mode-gentoo.el
new file mode 100644
index 000000000000..bdb5c12ceb6b
--- /dev/null
+++ b/app-emacs/python-mode/files/50python-mode-gentoo.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'python-mode "python-mode" "Major mode for editing Python files." t)
+(autoload 'jython-mode "python-mode" "Major mode for editing Jython files." t)
+(autoload 'py-shell "python-mode"
+ "Start an interactive Python interpreter in another window." t)
+
+(add-to-list 'auto-mode-alist '("\\.py$" . python-mode))
+(add-to-list 'interpreter-mode-alist '("python" . python-mode))
+(add-to-list 'interpreter-mode-alist '("jython" . jython-mode))
diff --git a/app-emacs/python-mode/python-mode-5.1.0.ebuild b/app-emacs/python-mode/python-mode-5.1.0.ebuild
index d6d0ca5920f1..4eadd5b3c0f3 100644
--- a/app-emacs/python-mode/python-mode-5.1.0.ebuild
+++ b/app-emacs/python-mode/python-mode-5.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-5.1.0.ebuild,v 1.10 2010/04/30 14:56:43 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-5.1.0.ebuild,v 1.11 2011/02/20 13:48:06 ulm Exp $
inherit elisp
@@ -14,12 +14,10 @@ SLOT="0"
KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
S=${WORKDIR}
SITEFILE=60${PN}-gentoo-5.1.el
pkg_postinst() {
+ elisp-site-regen
elog "Note that doctest support is now split out to app-emacs/doctest-mode."
}
diff --git a/app-emacs/python-mode/python-mode-5.2.0.ebuild b/app-emacs/python-mode/python-mode-5.2.0.ebuild
new file mode 100644
index 000000000000..061ae1bc858c
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-5.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-5.2.0.ebuild,v 1.1 2011/02/20 13:48:06 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS"
+
+src_prepare() {
+ # doctest-mode has its own package,
+ # pycomplete is not yet ready for production.
+ rm doctest-mode.el pycomplete.el || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest support is split out to app-emacs/doctest-mode."
+}