summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-04-10 16:47:10 +0000
committerNaohiro Aota <naota@gentoo.org>2011-04-10 16:47:10 +0000
commitafbf25568a35150a8f7785d143e09d3fc6b72453 (patch)
tree88218d5cc7569fe2800268e9ac54c9f1816cbdb3 /app-emacs
parentRemove useless libtool archive wrt #362885 by Cesko Voeten. Remove static arc... (diff)
downloadgentoo-2-afbf25568a35150a8f7785d143e09d3fc6b72453.tar.gz
gentoo-2-afbf25568a35150a8f7785d143e09d3fc6b72453.tar.bz2
gentoo-2-afbf25568a35150a8f7785d143e09d3fc6b72453.zip
New ebuild for calfw.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/calfw/ChangeLog10
-rw-r--r--app-emacs/calfw/calfw-0.1.ebuild39
-rw-r--r--app-emacs/calfw/files/calfw-0.1-cl.patch13
-rw-r--r--app-emacs/calfw/files/calfw-0.1-howm-menu.patch13
-rw-r--r--app-emacs/calfw/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/calfw/ChangeLog b/app-emacs/calfw/ChangeLog
new file mode 100644
index 000000000000..6227599bf014
--- /dev/null
+++ b/app-emacs/calfw/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/calfw
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/ChangeLog,v 1.1 2011/04/10 16:47:10 naota Exp $
+
+*calfw-0.1 (10 Apr 2011)
+
+ 10 Apr 2011; Naohiro Aota <naota@elisp.net> +calfw-0.1.ebuild,
+ +files/calfw-0.1-cl.patch, +files/calfw-0.1-howm-menu.patch, +metadata.xml:
+ New ebuild for calfw. Ebuild written by me.
+
diff --git a/app-emacs/calfw/calfw-0.1.ebuild b/app-emacs/calfw/calfw-0.1.ebuild
new file mode 100644
index 000000000000..c23bc2da0160
--- /dev/null
+++ b/app-emacs/calfw/calfw-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/calfw-0.1.ebuild,v 1.1 2011/04/10 16:47:10 naota Exp $
+
+EAPI=3
+
+inherit elisp-common eutils
+
+DESCRIPTION="A calendar framework for Emacs"
+HOMEPAGE="https://github.com/kiwanami/emacs-calfw"
+SRC_URI="https://github.com/kiwanami/emacs-calfw/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="howm"
+
+DEPEND="howm? ( app-emacs/howm )"
+RDEPEND="${DEPEND}"
+
+COMMON_ELISPS="calfw.el
+calfw-ical.el"
+
+src_prepare() {
+ mv kiwanami-emacs-calfw-* "${P}"
+ cd "${P}"
+ epatch "${FILESDIR}"/${PN}-0.1-cl.patch
+ use howm && epatch "${FILESDIR}"/${PN}-0.1-howm-menu.patch
+}
+
+src_compile() {
+ use howm && (elisp-compile calfw-howm.el || die)
+ for x in ${COMMON_ELISPS}; do elisp-compile $x || die; done
+}
+
+src_install() {
+ use howm && elisp-install ${PN} calfw-howm.el calfw-howm.elc
+ for x in ${COMMON_ELISPS}; do elisp-install ${x} ${x}; done
+}
diff --git a/app-emacs/calfw/files/calfw-0.1-cl.patch b/app-emacs/calfw/files/calfw-0.1-cl.patch
new file mode 100644
index 000000000000..373f0be664cb
--- /dev/null
+++ b/app-emacs/calfw/files/calfw-0.1-cl.patch
@@ -0,0 +1,13 @@
+diff --git a/calfw-ical.el b/calfw-ical.el
+index d95db06..6eba94a 100644
+--- a/calfw-ical.el
++++ b/calfw-ical.el
+@@ -39,6 +39,8 @@
+ (require 'icalendar)
+ (require 'url)
+
++(eval-when-compile (require 'cl))
++
+ (defun cfw:decode-to-calendar (dec)
+ (cfw:date
+ (nth 4 dec) (nth 3 dec) (nth 5 dec)))
diff --git a/app-emacs/calfw/files/calfw-0.1-howm-menu.patch b/app-emacs/calfw/files/calfw-0.1-howm-menu.patch
new file mode 100644
index 000000000000..486d60564aef
--- /dev/null
+++ b/app-emacs/calfw/files/calfw-0.1-howm-menu.patch
@@ -0,0 +1,13 @@
+diff --git a/calfw-howm.el b/calfw-howm.el
+index 9624baa..d34aea8 100644
+--- a/calfw-howm.el
++++ b/calfw-howm.el
+@@ -34,7 +34,7 @@
+
+ ;;; Code:
+
+-(require 'howm-menu)
++(require 'howm)
+ (require 'calfw)
+
+ (defvar cfw:howm-schedule-cache nil "howmのスケジュールデータのキャッシュ")
diff --git a/app-emacs/calfw/metadata.xml b/app-emacs/calfw/metadata.xml
new file mode 100644
index 000000000000..9b2c04f99f9d
--- /dev/null
+++ b/app-emacs/calfw/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='howm'>Add support for app-emacs/howm</flag>
+</use>
+</pkgmetadata>