summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-10-15 22:43:20 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-10-15 22:43:20 +0000
commit448da17269fbb3f8ce9f40df5fb69655e434a319 (patch)
tree0e1733f1e6f1716cf8bf0a41036de358604cc69f /app-emacs
parentFix kde-meta.eclass to work with EAPI-2 (diff)
downloadgentoo-2-448da17269fbb3f8ce9f40df5fb69655e434a319.tar.gz
gentoo-2-448da17269fbb3f8ce9f40df5fb69655e434a319.tar.bz2
gentoo-2-448da17269fbb3f8ce9f40df5fb69655e434a319.zip
clean up
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/chess/ChangeLog6
-rw-r--r--app-emacs/chess/chess-2.0_beta6-r1.ebuild45
-rw-r--r--app-emacs/chess/files/50chess-gentoo-2.0_beta6.el33
3 files changed, 5 insertions, 79 deletions
diff --git a/app-emacs/chess/ChangeLog b/app-emacs/chess/ChangeLog
index 33e248278484..40830d3c1a51 100644
--- a/app-emacs/chess/ChangeLog
+++ b/app-emacs/chess/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/chess
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.31 2009/10/15 14:07:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.32 2009/10/15 22:43:19 fauli Exp $
+
+ 15 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
+ -chess-2.0_beta6-r1.ebuild, -files/50chess-gentoo-2.0_beta6.el:
+ clean up
15 Oct 2009; Markus Meier <maekke@gentoo.org> chess-2.0_beta6-r2.ebuild:
amd64/x86 stable, bug #288395
diff --git a/app-emacs/chess/chess-2.0_beta6-r1.ebuild b/app-emacs/chess/chess-2.0_beta6-r1.ebuild
deleted file mode 100644
index ddba6cb80e4b..000000000000
--- a/app-emacs/chess/chess-2.0_beta6-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r1.ebuild,v 1.6 2009/09/10 13:07:37 ulm Exp $
-
-inherit elisp
-
-DESCRIPTION="A chess client and library for Emacs"
-HOMEPAGE="http://emacs-chess.sourceforge.net/"
-SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.gz
- mirror://gentoo/emacs-chess-sounds-2.0.tar.bz2
- mirror://gentoo/emacs-chess-pieces-2.0.tar.bz2"
-
-LICENSE="GPL-2 FDL-1.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="|| ( games-board/gnuchess
- games-board/crafty
- games-board/phalanx
- games-board/sjeng )"
-
-S="${WORKDIR}/${PN}"
-DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
-ELISP_PATCHES="${PV}-chess-pos-move-gentoo.patch
- ${PV}-chess-common-handler-gentoo.patch"
-SITEFILE="50${PN}-gentoo-${PV}.el"
-
-# this is needed; elisp.eclass redefines src_compile() from portage default
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- elisp_src_install
-
- doinfo chess.info
- einfo "Installing sound files ..."
- insinto /usr/share/sounds/${PN}
- doins "${WORKDIR}"/sounds/*
- einfo "Installing pixmap files ..."
- insinto /usr/share/pixmaps/${PN}
- doins -r "${WORKDIR}"/pieces/*
-}
diff --git a/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el b/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el
deleted file mode 100644
index d8566c780211..000000000000
--- a/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el
+++ /dev/null
@@ -1,33 +0,0 @@
-(add-to-list 'load-path "@SITELISP@")
-
-(autoload 'chess "chess"
- "Start a game of chess, playing against ENGINE (a module name)." t)
-(defalias 'chess-session 'chess)
-(autoload 'chess-create-display "chess"
- "Create a display, letting the user's customization decide the style.")
-(autoload 'chess-link "chess-link"
- "Play out a game between two engines, and watch the progress." t)
-(autoload 'chess-pgn-read "chess-pgn"
- "Read and display a PGN game after point." t)
-(autoload 'chess-pgn-mode "chess-pgn"
- "A mode for editing chess PGN files." t)
-(defalias 'pgn-mode 'chess-pgn-mode)
-(autoload 'chess-puzzle "chess-puzzle"
- "Pick a random puzzle from FILE, and solve it against the default engine." t)
-(autoload 'chess-fischer-random-position "chess-random"
- "Generate a Fischer Random style position.")
-(autoload 'chess-tutorial "chess-tutorial"
- "A simple chess training display." t)
-(autoload 'chess-ics "chess-ics"
- "Connect to an Internet Chess Server." t)
-
-(add-to-list 'auto-mode-alist '("\\.pgn\\'" . chess-pgn-mode))
-
-(setq chess-images-directory "/usr/share/pixmaps/chess/xboard")
-(setq chess-sound-directory "/usr/share/sounds/chess")
-
-;; Change the order of the engine preference list to coincide with the order
-;; of our dependencies: games-board/gnuchess, crafty, phalanx, and sjeng.
-;; The user can override this using M-x customize-group RET chess RET
-(setq chess-default-engine
- '(chess-gnuchess chess-crafty chess-phalanx chess-sjeng))