summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-27 19:14:53 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-27 19:14:53 +0000
commit7245eb09c2b3189142df27b182ae350a501c6cf4 (patch)
tree119731c489c31773fec96d204c33d4ad8c6168cb /app-emacs/table
parentFix scrolling bug. (diff)
downloadgentoo-2-7245eb09c2b3189142df27b182ae350a501c6cf4.tar.gz
gentoo-2-7245eb09c2b3189142df27b182ae350a501c6cf4.tar.bz2
gentoo-2-7245eb09c2b3189142df27b182ae350a501c6cf4.zip
Deactivate table for Emacs 22 where it is already included.
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-emacs/table')
-rw-r--r--app-emacs/table/ChangeLog9
-rw-r--r--app-emacs/table/files/50table-gentoo.el8
-rw-r--r--app-emacs/table/files/digest-table-1.5.54-r23
-rw-r--r--app-emacs/table/table-1.5.54-r2.ebuild39
4 files changed, 58 insertions, 1 deletions
diff --git a/app-emacs/table/ChangeLog b/app-emacs/table/ChangeLog
index 8616e45dd556..0055092612cd 100644
--- a/app-emacs/table/ChangeLog
+++ b/app-emacs/table/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/table
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.15 2007/05/16 17:30:50 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.16 2007/08/27 19:14:53 ulm Exp $
+
+*table-1.5.54-r2 (27 Aug 2007)
+
+ 27 Aug 2007; Ulrich Mueller <ulm@gentoo.org> +files/50table-gentoo.el,
+ +table-1.5.54-r2.ebuild:
+ Deactivate table for Emacs 22 where it is already included. Output a
+ corresponding message in pkg_postinst.
16 May 2007; Gustavo Zacarias <gustavoz@gentoo.org>
-files/50table-gentoo.el, -table-1.5.54.ebuild, table-1.5.54-r1.ebuild:
diff --git a/app-emacs/table/files/50table-gentoo.el b/app-emacs/table/files/50table-gentoo.el
new file mode 100644
index 000000000000..9988e030ba9b
--- /dev/null
+++ b/app-emacs/table/files/50table-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; table site-lisp configuration
+
+;; Emacs 22 and later include the table package
+(unless (fboundp 'table-insert)
+ (add-to-list 'load-path "@SITELISP@")
+ (load "table-autoloads" nil t)
+ (add-hook 'text-mode-hook 'table-recognize))
diff --git a/app-emacs/table/files/digest-table-1.5.54-r2 b/app-emacs/table/files/digest-table-1.5.54-r2
new file mode 100644
index 000000000000..5624fb376706
--- /dev/null
+++ b/app-emacs/table/files/digest-table-1.5.54-r2
@@ -0,0 +1,3 @@
+MD5 bf610808fa37ec0c6393e841d99defd9 table-1.5.54.el.gz 58136
+RMD160 da7312476e92bc298fc997f7940910a924507f8c table-1.5.54.el.gz 58136
+SHA256 af7f3337e1dc517bcb9f5683103d5e32a34dcf311f1187a02660fc3642089cba table-1.5.54.el.gz 58136
diff --git a/app-emacs/table/table-1.5.54-r2.ebuild b/app-emacs/table/table-1.5.54-r2.ebuild
new file mode 100644
index 000000000000..342484dcaf40
--- /dev/null
+++ b/app-emacs/table/table-1.5.54-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/table-1.5.54-r2.ebuild,v 1.1 2007/08/27 19:14:53 ulm Exp $
+
+inherit elisp versionator
+
+DESCRIPTION="Table editor for Emacs"
+HOMEPAGE="http://table.sourceforge.net/"
+SRC_URI="mirror://sourceforge/table/${P}.el.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SIMPLE_ELISP=t
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ elisp-make-autoload-file || die "elisp-make-autoload-file failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ # prevent inclusion of package dir by subdirs.el
+ touch "${D}${SITELISP}/${PN}/.nosearch"
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ if version_is_at_least 22 "$(elisp-emacs-version)"; then
+ echo
+ elog "Please note that \"${PN}\" is already included with Emacs 22 or"
+ elog "later, so ${CATEGORY}/${PN} is only needed for lower versions."
+ elog "You may select the active Emacs version with \"eselect emacs\"."
+ fi
+}