summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-01 13:01:37 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-01 13:01:37 +0000
commita643cfaa08357d14c6cfe223f942f31d04f14614 (patch)
treed728387b20b0dda0e3d34f433c23bd6663fba688 /app-emacs/slime
parentamd64 stable (tested by me) and keyword for ~x86 (tested by bheekling) (diff)
downloadgentoo-2-a643cfaa08357d14c6cfe223f942f31d04f14614.tar.gz
gentoo-2-a643cfaa08357d14c6cfe223f942f31d04f14614.tar.bz2
gentoo-2-a643cfaa08357d14c6cfe223f942f31d04f14614.zip
Reorganise directory structure. Sync swank.asd from the lisp overlay.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25-gentoo-r6 i686)
Diffstat (limited to 'app-emacs/slime')
-rw-r--r--app-emacs/slime/ChangeLog21
-rw-r--r--app-emacs/slime/files/2.0_p20061118/70slime-gentoo.el14
-rw-r--r--app-emacs/slime/files/2.0_p20070816/70slime-gentoo.el (renamed from app-emacs/slime/files/71slime-gentoo.el)3
-rw-r--r--app-emacs/slime/files/2.0_p20070816/changelog-date.patch (renamed from app-emacs/slime/files/slime-changelog-date.patch)0
-rw-r--r--app-emacs/slime/files/2.0_p20070816/save-restriction-if-possible.patch (renamed from app-emacs/slime/files/slime-2.0_p20070816-save-restriction-if-possible.patch)0
-rw-r--r--app-emacs/slime/files/2.0_p20070816/set-swank-wire-protocol-version.patch (renamed from app-emacs/slime/files/slime-set-swank-wire-protocol-version.patch)0
-rw-r--r--app-emacs/slime/files/2.0_p20070816/swank.asd (renamed from app-emacs/slime/files/swank.asd)86
-rw-r--r--app-emacs/slime/files/70slime-gentoo.el13
-rwxr-xr-xapp-emacs/slime/files/new-slime-ball11
-rw-r--r--app-emacs/slime/slime-2.0_p20061118.ebuild6
-rw-r--r--app-emacs/slime/slime-2.0_p20070816-r3.ebuild (renamed from app-emacs/slime/slime-2.0_p20070816-r2.ebuild)15
11 files changed, 79 insertions, 90 deletions
diff --git a/app-emacs/slime/ChangeLog b/app-emacs/slime/ChangeLog
index 9c5acd727a03..3159065c1062 100644
--- a/app-emacs/slime/ChangeLog
+++ b/app-emacs/slime/ChangeLog
@@ -1,6 +1,25 @@
# ChangeLog for app-emacs/slime
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/ChangeLog,v 1.55 2008/07/30 09:12:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/ChangeLog,v 1.56 2008/08/01 13:01:35 ulm Exp $
+
+*slime-2.0_p20070816-r3 (01 Aug 2008)
+
+ 01 Aug 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/2.0_p20061118/70slime-gentoo.el,
+ +files/2.0_p20070816/70slime-gentoo.el,
+ +files/2.0_p20070816/changelog-date.patch,
+ +files/2.0_p20070816/save-restriction-if-possible.patch,
+ +files/2.0_p20070816/set-swank-wire-protocol-version.patch,
+ +files/2.0_p20070816/swank.asd, -files/71slime-gentoo.el,
+ -files/slime-2.0_p20070816-save-restriction-if-possible.patch,
+ -files/70slime-gentoo.el, -files/new-slime-ball,
+ -files/slime-changelog-date.patch,
+ -files/slime-set-swank-wire-protocol-version.patch, -files/swank.asd,
+ slime-2.0_p20061118.ebuild, -slime-2.0_p20070816-r2.ebuild,
+ +slime-2.0_p20070816-r3.ebuild:
+ Reorganise directory structure. Sync swank.asd from the lisp overlay.
+ Remove unused new-slime-ball script. Thanks to Stelian Ionescu
+ <sionescu@common-lisp.net>.
*slime-2.0_p20070816-r2 (30 Jul 2008)
diff --git a/app-emacs/slime/files/2.0_p20061118/70slime-gentoo.el b/app-emacs/slime/files/2.0_p20061118/70slime-gentoo.el
new file mode 100644
index 000000000000..3859f7d65e01
--- /dev/null
+++ b/app-emacs/slime/files/2.0_p20061118/70slime-gentoo.el
@@ -0,0 +1,14 @@
+
+;;; slime site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(require 'slime)
+(slime-setup)
+
+;; this allows us not to require dev-lisp/hyperspec
+;; (which is non-free) as a hard dependency
+(setq common-lisp-hyperspec-root
+ (if (file-exists-p "/usr/share/doc/hyperspec/HyperSpec")
+ "file:///usr/share/doc/hyperspec/HyperSpec/"
+ "http://www.lispworks.com/reference/HyperSpec/"))
diff --git a/app-emacs/slime/files/71slime-gentoo.el b/app-emacs/slime/files/2.0_p20070816/70slime-gentoo.el
index e872b7cb9408..f967021cab07 100644
--- a/app-emacs/slime/files/71slime-gentoo.el
+++ b/app-emacs/slime/files/2.0_p20070816/70slime-gentoo.el
@@ -2,10 +2,11 @@
;;; slime site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
+
(require 'slime-autoloads)
(slime-setup)
-;; this prevents us from requiring the user get dev-lisp/hyperspec
+;; this allows us not to require dev-lisp/hyperspec
;; (which is non-free) as a hard dependency
(setq common-lisp-hyperspec-root
(if (file-exists-p "/usr/share/doc/hyperspec/HyperSpec")
diff --git a/app-emacs/slime/files/slime-changelog-date.patch b/app-emacs/slime/files/2.0_p20070816/changelog-date.patch
index bf816bc771e2..bf816bc771e2 100644
--- a/app-emacs/slime/files/slime-changelog-date.patch
+++ b/app-emacs/slime/files/2.0_p20070816/changelog-date.patch
diff --git a/app-emacs/slime/files/slime-2.0_p20070816-save-restriction-if-possible.patch b/app-emacs/slime/files/2.0_p20070816/save-restriction-if-possible.patch
index 952b3a79c00d..952b3a79c00d 100644
--- a/app-emacs/slime/files/slime-2.0_p20070816-save-restriction-if-possible.patch
+++ b/app-emacs/slime/files/2.0_p20070816/save-restriction-if-possible.patch
diff --git a/app-emacs/slime/files/slime-set-swank-wire-protocol-version.patch b/app-emacs/slime/files/2.0_p20070816/set-swank-wire-protocol-version.patch
index dd48caeff3b4..dd48caeff3b4 100644
--- a/app-emacs/slime/files/slime-set-swank-wire-protocol-version.patch
+++ b/app-emacs/slime/files/2.0_p20070816/set-swank-wire-protocol-version.patch
diff --git a/app-emacs/slime/files/swank.asd b/app-emacs/slime/files/2.0_p20070816/swank.asd
index e1b6c8fa74d1..35c64b9ee2fb 100644
--- a/app-emacs/slime/files/swank.asd
+++ b/app-emacs/slime/files/2.0_p20070816/swank.asd
@@ -1,8 +1,7 @@
;;; -*- mode: lisp; syntax: common-lisp; package: common-lisp -*-
(defpackage #:swank-system
- (:use #:common-lisp
- #:asdf))
+ (:use #:common-lisp #:asdf))
(defpackage #:swank-loader
(:use #:common-lisp)
@@ -10,16 +9,18 @@
(in-package #:swank-system)
-;; http://www.caddr.com/macho/archives/sbcl-devel/2004-3/3014.html
-
-(defclass unsafe-file (cl-source-file) ())
+(defun load-user-init-file ()
+ "Load the user init file, return NIL if it does not exist."
+ (load (merge-pathnames (user-homedir-pathname)
+ (make-pathname :name ".swank" :type "lisp"))
+ :if-does-not-exist nil))
-(defmethod perform :around ((op compile-op) (c unsafe-file))
- (setf (operation-on-warnings op) :ignore
- (operation-on-failure op) :warn) ; adjust to taste
- (call-next-method))
+(defun load-site-init-file ()
+ (load (make-pathname :name "site-init" :type "lisp"
+ :defaults *load-truename*)
+ :if-does-not-exist nil))
-(defmacro define-swank-system (&rest sysdep-components)
+(defmacro define-swank-system (sysdep-files)
`(defsystem swank
:name "Swank is the Common Lips back-end to SLIME"
:serial t
@@ -29,57 +30,34 @@
(if (atom component)
(list :file component)
component))
- sysdep-components)
+ sysdep-files)
(:file "swank"))
- :depends-on (#+sbcl sb-bsd-sockets)))
-
-#+sbcl (define-swank-system
- "swank-sbcl"
- "swank-source-path-parser"
- "swank-source-file-cache"
- "swank-gray")
-
-#+openmcl (define-swank-system
- "metering"
- "swank-openmcl"
- "swank-gray")
-
-#+cmu (define-swank-system
- "swank-source-path-parser"
- "swank-source-file-cache"
- "swank-cmucl")
-
-#+clisp (define-swank-system
- "xref"
- "metering"
- "swank-clisp"
- "swank-gray")
-
-#+armedbear (define-swank-system
- "swank-abcl")
-
-#+ecl (define-swank-system
- "swank-ecl" "swank-gray")
+ :depends-on (#+sbcl sb-bsd-sockets)
+ :perform (load-op :after (op swank)
+ (load-site-init-file)
+ (load-user-init-file))))
+
+#+(or cmu scl sbcl openmcl lispworks allegro clisp armedbear cormanlisp ecl)
+(define-swank-system
+ #+cmu (swank-source-path-parser swank-source-file-cache swank-cmucl)
+ #+scl (swank-source-path-parser swank-source-file-cache swank-scl)
+ #+sbcl (swank-source-path-parser swank-source-file-cache swank-sbcl swank-gray)
+ #+openmcl (metering swank-openmcl swank-gray)
+ #+lispworks (swank-lispworks swank-gray)
+ #+allegro (swank-allegro swank-gray)
+ #+clisp (xref metering swank-clisp swank-gray)
+ #+armedbear (swank-abcl)
+ #+cormanlisp (swank-corman swank-gray)
+ #+ecl (swank-source-path-parser swank-source-file-cache swank-ecl swank-gray))
+
+#-(or cmu scl sbcl openmcl lispworks allegro clisp armedbear cormanlisp ecl)
+(error "Your CL implementation is not supported !")
(in-package #:swank-loader)
(defparameter *source-directory*
(asdf:component-pathname (asdf:find-system :swank)))
-(defun load-user-init-file ()
- "Load the user init file, return NIL if it does not exist."
- (load (merge-pathnames (user-homedir-pathname)
- (make-pathname :name ".swank" :type "lisp"))
- :if-does-not-exist nil))
-
-(defun load-site-init-file ()
- (load (make-pathname :name "site-init" :type "lisp"
- :defaults *load-truename*)
- :if-does-not-exist nil))
-
;; (funcall (intern (string :warn-unimplemented-interfaces) :swank-backend))
-(load-site-init-file)
-(load-user-init-file)
-
;; swank.asd ends here
diff --git a/app-emacs/slime/files/70slime-gentoo.el b/app-emacs/slime/files/70slime-gentoo.el
deleted file mode 100644
index 2687bb5c4f14..000000000000
--- a/app-emacs/slime/files/70slime-gentoo.el
+++ /dev/null
@@ -1,13 +0,0 @@
-
-;;; site-lisp configuration for slime-cvs
-
-(add-to-list 'load-path "@SITELISP@")
-(require 'slime)
-(slime-setup)
-
-;; this prevents us from requiring the user get dev-lisp/hyperspec
-;; (which is non-free) as a hard dependency
-
-(if (file-exists-p "/usr/share/doc/hyperspec/HyperSpec")
- (setq common-lisp-hyperspec-root "file:///usr/share/doc/hyperspec/HyperSpec/")
- (setq common-lisp-hyperspec-root "http://www.lispworks.com/reference/HyperSpec/"))
diff --git a/app-emacs/slime/files/new-slime-ball b/app-emacs/slime/files/new-slime-ball
deleted file mode 100755
index 6b4d51f8cb3f..000000000000
--- a/app-emacs/slime/files/new-slime-ball
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-TMP=`mktemp -d -t new-slime-ball.XXXXXX`
-trap "rm -r $TMP* 2>/dev/null" 0
-DIR=${PWD}
-THEIR_PV=2.0 # whatever they're calling the current release
-OUR_PV=`date +'%Y%m%d'`
-PV="${THEIR_PV}_p${OUR_PV}"
-cd $TMP
-cvs -z9 -d:pserver:anonymous@common-lisp.net:/project/slime/cvsroot co slime || exit 1
-mv slime slime-${PV}
-tar cvjf ${DIR}/slime-${PV}.tar.bz2 slime-${PV} --exclude CVS --exclude .cvsignore
diff --git a/app-emacs/slime/slime-2.0_p20061118.ebuild b/app-emacs/slime/slime-2.0_p20061118.ebuild
index 3808d3cc0110..1105a1444b7b 100644
--- a/app-emacs/slime/slime-2.0_p20061118.ebuild
+++ b/app-emacs/slime/slime-2.0_p20061118.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0_p20061118.ebuild,v 1.4 2008/07/07 17:09:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0_p20061118.ebuild,v 1.5 2008/08/01 13:01:35 ulm Exp $
inherit elisp eutils
DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
HOMEPAGE="http://common-lisp.net/project/slime/"
-# use ${FILESDIR}/new-slime-ball to create new snapshots
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2 xref.lisp"
@@ -19,6 +18,7 @@ DEPEND="${RDEPEND}
doc? ( virtual/texi2dvi )"
CLPACKAGE=swank
+SITEFILE=70${PN}-gentoo.el
src_compile() {
elisp-comp *.el || die
@@ -27,7 +27,7 @@ src_compile() {
src_install() {
elisp-install ${PN} *
- elisp-site-file-install "${FILESDIR}/70slime-gentoo.el"
+ elisp-site-file-install "${FILESDIR}"/${PV}/${SITEFILE}
dodoc README* ChangeLog HACKING NEWS PROBLEMS
dodir /usr/share/common-lisp/systems
dosym /usr/share/emacs/site-lisp/${PN}/swank.asd \
diff --git a/app-emacs/slime/slime-2.0_p20070816-r2.ebuild b/app-emacs/slime/slime-2.0_p20070816-r3.ebuild
index 41bb3815f064..e65bc95c8825 100644
--- a/app-emacs/slime/slime-2.0_p20070816-r2.ebuild
+++ b/app-emacs/slime/slime-2.0_p20070816-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0_p20070816-r2.ebuild,v 1.1 2008/07/30 09:12:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0_p20070816-r3.ebuild,v 1.1 2008/08/01 13:01:35 ulm Exp $
inherit common-lisp elisp eutils
@@ -19,14 +19,15 @@ DEPEND="${RDEPEND}
CLPACKAGE=swank
SWANK_VERSION="2007-08-16"
-SITEFILE=71${PN}-gentoo.el
+SITEFILE=70${PN}-gentoo.el
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-set-swank-wire-protocol-version.patch
- epatch "${FILESDIR}"/${PN}-changelog-date.patch
- epatch "${FILESDIR}"/${P}-save-restriction-if-possible.patch
+
+ epatch "${FILESDIR}"/${PV}/set-swank-wire-protocol-version.patch
+ epatch "${FILESDIR}"/${PV}/changelog-date.patch
+ epatch "${FILESDIR}"/${PV}/save-restriction-if-possible.patch
# extract date of last update from ChangeLog, bug 233270
SLIME_CHANGELOG_DATE=$(sed -n \
@@ -51,10 +52,10 @@ src_compile() {
src_install() {
elisp-install ${PN} *.el{,c} "${FILESDIR}"/swank-loader.lisp \
|| die "Cannot install SLIME core"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ elisp-site-file-install "${FILESDIR}"/${PV}/${SITEFILE} \
|| die "elisp-site-file-install failed"
insinto "${CLSOURCEROOT}"/swank
- doins *.lisp "${FILESDIR}"/swank.asd
+ doins *.lisp "${FILESDIR}"/${PV}/swank.asd
dodir "${CLSYSTEMROOT}"
dosym "${CLSOURCEROOT}"/swank/swank.asd "${CLSYSTEMROOT}"
dosym "${SITELISP}"/${PN}/swank-version.el "${CLSOURCEROOT}"/swank