summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-03-07 16:54:33 +0000
committerUlrich Müller <ulm@gentoo.org>2012-03-07 16:54:33 +0000
commitef5a305604b4ff33246a96fc9aa3ae285075ec4c (patch)
treebb51df70d0cf2dca29277134660659d5fa77c51f /app-emacs/python-mode
parentVersion bump. (diff)
downloadgentoo-2-ef5a305604b4ff33246a96fc9aa3ae285075ec4c.tar.gz
gentoo-2-ef5a305604b4ff33246a96fc9aa3ae285075ec4c.tar.bz2
gentoo-2-ef5a305604b4ff33246a96fc9aa3ae285075ec4c.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog7
-rw-r--r--app-emacs/python-mode/python-mode-6.0.5.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index cfd3a504f4ee..3dbfa04a53c6 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/python-mode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.60 2012/03/07 00:23:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.61 2012/03/07 16:54:33 ulm Exp $
+
+*python-mode-6.0.5 (07 Mar 2012)
+
+ 07 Mar 2012; Ulrich Müller <ulm@gentoo.org> +python-mode-6.0.5.ebuild:
+ Version bump.
*python-mode-6.0.4-r1 (07 Mar 2012)
diff --git a/app-emacs/python-mode/python-mode-6.0.5.ebuild b/app-emacs/python-mode/python-mode-6.0.5.ebuild
new file mode 100644
index 000000000000..5d04f86561ed
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.0.5.ebuild,v 1.1 2012/03/07 16:54:33 ulm Exp $
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+# remove bundled pymacs.el
+ELISP_REMOVE="pymacs.el"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest and pymacs are in their own packages,"
+ elog "app-emacs/doctest-mode and app-emacs/pymacs, respectively."
+}