summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-29 13:32:21 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-29 13:32:21 +0000
commite58d1accaaf4641b3be6c3666e0b1afcf7511d79 (patch)
tree5f2168478fc6febb48b34a8eb3465ca9d64c35de /app-emacs/ocaml-mode
parentx86 stable (diff)
downloadgentoo-2-e58d1accaaf4641b3be6c3666e0b1afcf7511d79.tar.gz
gentoo-2-e58d1accaaf4641b3be6c3666e0b1afcf7511d79.tar.bz2
gentoo-2-e58d1accaaf4641b3be6c3666e0b1afcf7511d79.zip
Autoload camldebug in site-init file, fixes bug #197405.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog5
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el2
2 files changed, 6 insertions, 1 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
index cb19ce7be16a..fd411e3f98bb 100644
--- a/app-emacs/ocaml-mode/ChangeLog
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/ocaml-mode
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.21 2007/10/28 13:26:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.22 2007/10/29 13:32:21 ulm Exp $
+
+ 29 Oct 2007; Ulrich Mueller <ulm@gentoo.org> files/50ocaml-mode-gentoo.el:
+ Autoload camldebug in site-init file, fixes bug #197405.
28 Oct 2007; Markus Rothe <corsair@gentoo.org>
ocaml-mode-3.09.3-r1.ebuild, ocaml-mode-3.10.0.ebuild:
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
index d1ed867e7eb6..7d1b8f0e3be5 100644
--- a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
@@ -5,6 +5,8 @@
(add-to-list 'auto-mode-alist '("\\.ml[iylp]?\\'" . caml-mode))
(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
(autoload 'run-caml "inf-caml" "Run an inferior Caml process." t)
+(autoload 'camldebug "camldebug"
+ "Run camldebug on program FILE in buffer *camldebug-FILE*." t)
(autoload 'inferior-caml-mode-font-hook "caml-font")
(eval-after-load "caml" '(require 'caml-font))