summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-09 13:01:14 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-09 13:01:14 +0000
commit5698580c6987b8d5acf6b29e18160bddff0c83ba (patch)
tree6080b8eab92e9e55f062a5a06f95495d86c67898 /app-emacs/mell
parentRemove econf call from src_unpack. (diff)
downloadgentoo-2-5698580c6987b8d5acf6b29e18160bddff0c83ba.tar.gz
gentoo-2-5698580c6987b8d5acf6b29e18160bddff0c83ba.tar.bz2
gentoo-2-5698580c6987b8d5acf6b29e18160bddff0c83ba.zip
Ebuild completely redone, use facilities of elisp.eclass instead of the package's build system.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs/mell')
-rw-r--r--app-emacs/mell/ChangeLog12
-rw-r--r--app-emacs/mell/files/51mell-gentoo.el4
-rw-r--r--app-emacs/mell/mell-1.0.0-r1.ebuild32
3 files changed, 46 insertions, 2 deletions
diff --git a/app-emacs/mell/ChangeLog b/app-emacs/mell/ChangeLog
index 3b76a7a58679..90eea50852da 100644
--- a/app-emacs/mell/ChangeLog
+++ b/app-emacs/mell/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/mell
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mell/ChangeLog,v 1.16 2007/12/02 15:14:47 opfer Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mell/ChangeLog,v 1.17 2009/03/09 13:01:14 ulm Exp $
+
+*mell-1.0.0-r1 (09 Mar 2009)
+
+ 09 Mar 2009; Ulrich Mueller <ulm@gentoo.org> +files/51mell-gentoo.el,
+ +mell-1.0.0-r1.ebuild:
+ Ebuild completely redone, use facilities of elisp.eclass instead of the
+ package's build system. Byte-compile all elisp files. Install Japanese
+ documentation with LINGUAS=ja only.
02 Dec 2007; Christian Faulhammer <opfer@gentoo.org> mell-1.0.0.ebuild:
only install useful documentation and make dodoc argument readable
diff --git a/app-emacs/mell/files/51mell-gentoo.el b/app-emacs/mell/files/51mell-gentoo.el
new file mode 100644
index 000000000000..91e6a28443fa
--- /dev/null
+++ b/app-emacs/mell/files/51mell-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; mell site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/mell/mell-1.0.0-r1.ebuild b/app-emacs/mell/mell-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..f5c6dfc9119b
--- /dev/null
+++ b/app-emacs/mell/mell-1.0.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mell/mell-1.0.0-r1.ebuild,v 1.1 2009/03/09 13:01:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="M Emacs Lisp Library"
+HOMEPAGE="http://taiyaki.org/elisp/mell/"
+SRC_URI="http://taiyaki.org/elisp/mell/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="linguas_ja"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile() {
+ cd src
+ elisp_src_compile
+}
+
+src_install() {
+ cd src
+ elisp_src_install
+ cd ..
+ dodoc README AUTHORS ChangeLog || die
+
+ if use linguas_ja; then
+ dohtml doc/index.html || die
+ fi
+}