summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-16 21:25:14 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-16 21:25:14 +0000
commit99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777 (patch)
tree023aad796fbdbf94aa22dbc894b406750a83a62c /app-emacs/http-emacs
parentAdded patch for webdav per security bug #196066. Removed past version, and va... (diff)
downloadgentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.tar.gz
gentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.tar.bz2
gentoo-2-99d1a34ceea6b0ddfc5f67e140bf4fa3afb2d777.zip
Also byte-compile the simple-wiki elisp files.
(Portage version: 2.1.3.13)
Diffstat (limited to 'app-emacs/http-emacs')
-rw-r--r--app-emacs/http-emacs/ChangeLog8
-rw-r--r--app-emacs/http-emacs/files/51http-emacs-gentoo.el15
-rw-r--r--app-emacs/http-emacs/files/digest-http-emacs-1.1-r13
-rw-r--r--app-emacs/http-emacs/http-emacs-1.1-r1.ebuild23
4 files changed, 48 insertions, 1 deletions
diff --git a/app-emacs/http-emacs/ChangeLog b/app-emacs/http-emacs/ChangeLog
index be6d84ab40c4..936359b8c73c 100644
--- a/app-emacs/http-emacs/ChangeLog
+++ b/app-emacs/http-emacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/http-emacs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/ChangeLog,v 1.9 2007/10/08 14:34:33 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/ChangeLog,v 1.10 2007/10/16 21:25:14 ulm Exp $
+
+*http-emacs-1.1-r1 (16 Oct 2007)
+
+ 16 Oct 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/51http-emacs-gentoo.el, +http-emacs-1.1-r1.ebuild:
+ Also byte-compile the simple-wiki elisp files.
08 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
http-emacs-1.1.ebuild:
diff --git a/app-emacs/http-emacs/files/51http-emacs-gentoo.el b/app-emacs/http-emacs/files/51http-emacs-gentoo.el
new file mode 100644
index 000000000000..2e0b1a6025ef
--- /dev/null
+++ b/app-emacs/http-emacs/files/51http-emacs-gentoo.el
@@ -0,0 +1,15 @@
+
+;;; site-lisp configuration for http-emacs
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'http-get "http-get"
+ "Get URL in a buffer, and return the process." t)
+(autoload 'swc-emacswiki-browse "simple-wiki-completion" nil t)
+(autoload 'simple-wiki-edit "simple-wiki-edit")
+
+;;; The following are an attempt at some reasonable defaults based on
+;;; the EmacsWiki page:
+;;; http://emacswiki.org/cgi-bin/wiki.pl?SimpleWikiEditMode
+
+;; (add-hook 'simple-wiki-edit-mode-hooks 'pcomplete-simple-wiki-setup)
+;; (add-hook 'simple-wiki-edit-mode-hooks 'turn-off-auto-fill)
diff --git a/app-emacs/http-emacs/files/digest-http-emacs-1.1-r1 b/app-emacs/http-emacs/files/digest-http-emacs-1.1-r1
new file mode 100644
index 000000000000..6f1dd655d642
--- /dev/null
+++ b/app-emacs/http-emacs/files/digest-http-emacs-1.1-r1
@@ -0,0 +1,3 @@
+MD5 1c4195457ba5becd2e8e1d5ee45c5003 http-emacs-1.1.tar.gz 11030
+RMD160 192bd20ea7c909a04f4d3736dace173f03d68891 http-emacs-1.1.tar.gz 11030
+SHA256 f3b7f22bab59461d90c749e444d90eb97c7e419001d1e0877e1d43def9cccf20 http-emacs-1.1.tar.gz 11030
diff --git a/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild b/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild
new file mode 100644
index 000000000000..24979d67c425
--- /dev/null
+++ b/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/http-emacs/http-emacs-1.1-r1.ebuild,v 1.1 2007/10/16 21:25:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Fetch, render and post html pages and edit wiki pages via Emacs."
+HOMEPAGE="http://emacswiki.org/cgi-bin/wiki.pl?SimpleWikiEditMode"
+SRC_URI="http://savannah.nongnu.org/download/http-emacs/http-emacs.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+DOCS="CONTRIBUTORS"
+
+SITEFILE=51${PN}-gentoo.el
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+}