summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-08 17:47:44 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-08 17:47:44 +0000
commit3057d96fa2ae5ef0262ff83c37f740d4ccc0d1f1 (patch)
tree62817e7b044875a646ffc0ac3b7d1edaf373d349 /app-emacs/gentoo-syntax
parentadd prefix keywords - migrate from Gentoo Prefix (diff)
downloadgentoo-2-3057d96fa2ae5ef0262ff83c37f740d4ccc0d1f1.tar.gz
gentoo-2-3057d96fa2ae5ef0262ff83c37f740d4ccc0d1f1.tar.bz2
gentoo-2-3057d96fa2ae5ef0262ff83c37f740d4ccc0d1f1.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux i686)
Diffstat (limited to 'app-emacs/gentoo-syntax')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog9
-rw-r--r--app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.14.el12
-rw-r--r--app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el3
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild4
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.15.ebuild38
5 files changed, 63 insertions, 3 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index c8637a8d0011..4b2543d54247 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.51 2009/09/22 20:13:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.52 2009/10/08 17:47:43 ulm Exp $
+
+*gentoo-syntax-1.15 (08 Oct 2009)
+
+ 08 Oct 2009; Ulrich Mueller <ulm@gentoo.org> gentoo-syntax-1.14.ebuild,
+ +files/50gentoo-syntax-gentoo-1.14.el, files/50gentoo-syntax-gentoo.el,
+ +gentoo-syntax-1.15.ebuild:
+ Version bump.
*gentoo-syntax-1.14 (22 Sep 2009)
diff --git a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.14.el b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.14.el
new file mode 100644
index 000000000000..f9ef9628b1b5
--- /dev/null
+++ b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo-1.14.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "gentoo-syntax"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'eselect-mode "gentoo-syntax" "Major mode for .eselect files." t)
+
+(add-to-list 'auto-mode-alist
+ '("\\.\\(ebuild\\|eclass\\|eblit\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)
+
+(setq ebuild-mode-portdir "@PORTDIR@")
diff --git a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
index f9ef9628b1b5..4ef68c519b94 100644
--- a/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
+++ b/app-emacs/gentoo-syntax/files/50gentoo-syntax-gentoo.el
@@ -6,6 +6,9 @@
(add-to-list 'auto-mode-alist
'("\\.\\(ebuild\\|eclass\\|eblit\\)\\'" . ebuild-mode))
(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
+(add-to-list 'auto-mode-alist
+ '("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'"
+ . gentoo-newsitem-mode))
(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild
index 7befec831357..35a7548c9ce9 100644
--- a/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild,v 1.1 2009/09/22 20:13:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.14.ebuild,v 1.2 2009/10/08 17:47:43 ulm Exp $
inherit elisp
@@ -14,7 +14,7 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbs
IUSE=""
DOCS="ChangeLog"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
src_compile() {
elisp_src_compile
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.15.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.15.ebuild
new file mode 100644
index 000000000000..9c54ee6b197e
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.15.ebuild,v 1.1 2009/10/08 17:47:43 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}