summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-07-09 03:42:35 +0000
committerNaohiro Aota <naota@gentoo.org>2013-07-09 03:42:35 +0000
commitaee5edd170043b0de05c9979c06a50efcdb34aa6 (patch)
tree23d686eec1646c6e8eda88f02b288e124f18a33f /app-emacs/ddskk/ddskk-15.1.ebuild
parentRestrict tests (they require network access and try to start wine) and add mi... (diff)
downloadgentoo-2-aee5edd170043b0de05c9979c06a50efcdb34aa6.tar.gz
gentoo-2-aee5edd170043b0de05c9979c06a50efcdb34aa6.tar.bz2
gentoo-2-aee5edd170043b0de05c9979c06a50efcdb34aa6.zip
Version bump wrt #474550
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-emacs/ddskk/ddskk-15.1.ebuild')
-rw-r--r--app-emacs/ddskk/ddskk-15.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/ddskk/ddskk-15.1.ebuild b/app-emacs/ddskk/ddskk-15.1.ebuild
new file mode 100644
index 000000000000..e7dd8d5b6f60
--- /dev/null
+++ b/app-emacs/ddskk/ddskk-15.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ddskk/ddskk-15.1.ebuild,v 1.1 2013/07/09 03:42:35 naota Exp $
+
+EAPI=3
+
+inherit elisp eutils
+
+DESCRIPTION="One Japanese input methods on Emacs"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="|| ( ( =virtual/emacs-21 >=app-emacs/apel-10.7 )
+ >=virtual/emacs-22 )"
+RDEPEND="${DEPEND}
+ || ( app-i18n/skk-jisyo virtual/skkserv )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ find . -type f | xargs sed -i -e "s:/usr/local:${EPREFIX}/usr:g" || die
+ epatch "${FILESDIR}"/${P}-skk-mk.patch
+}
+
+src_compile() {
+ emake < /dev/null || die "emake failed"
+ emake info < /dev/null || die "emake info failed"
+ #cd nicola
+ #emake < /dev/null || die
+ BYTECOMPFLAGS="${BYTECOMPFLAGS} -L .."
+ cd "${S}/tut-code"
+ elisp-compile *.el || die "elisp-compile tut-code/*.el failed"
+
+ cd "${S}/bayesian"
+ elisp-compile *.el || die "elisp-compile bayesian/*.el failed"
+}
+
+src_install () {
+ elisp-install ${PN} *.{el,elc} nicola/*.el tut-code/*.{el,elc} bayesian/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ insinto /usr/share/skk
+ doins etc/*SKK.tut* etc/skk.xpm || die
+
+ dodoc READMEs/* ChangeLog*
+ doinfo doc/skk.info* || die
+
+ #docinto nicola
+ #dodoc nicola/ChangeLog* nicola/README* || die
+ docinto tut-code
+ dodoc tut-code/README.tut || die
+
+ #dobin bayesian/bskk || die
+ docinto bayesian
+ dodoc bayesian/README.ja bayesian/bskk || die
+}