summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-06-07 10:19:07 +0000
committerUlrich Müller <ulm@gentoo.org>2014-06-07 10:19:07 +0000
commitc78a5bed8d027eb2f9c13ce3e768e139e4c6c280 (patch)
tree347f9433b291d7744ebfcadb4bcd74134fcd8459 /app-editors
parentRemove old, bug 394589. (diff)
downloadgentoo-2-c78a5bed8d027eb2f9c13ce3e768e139e4c6c280.tar.gz
gentoo-2-c78a5bed8d027eb2f9c13ce3e768e139e4c6c280.tar.bz2
gentoo-2-c78a5bed8d027eb2f9c13ce3e768e139e4c6c280.zip
Remove Emacs 21 and 22, bug 394589.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.4-r25.ebuild195
-rw-r--r--app-editors/emacs/emacs-22.3-r12.ebuild253
-rw-r--r--app-editors/emacs/metadata.xml2
4 files changed, 5 insertions, 451 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index e678b9650ac0..833abc4b7101 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.624 2014/06/04 17:16:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.625 2014/06/07 10:19:07 ulm Exp $
+
+ 07 Jun 2014; Ulrich Müller <ulm@gentoo.org> -emacs-21.4-r25.ebuild,
+ -emacs-22.3-r12.ebuild, metadata.xml:
+ Remove Emacs 21 and 22, bug 394589.
04 Jun 2014; Ulrich Müller <ulm@gentoo.org> emacs-23.4-r11.ebuild:
Avoid gcc -Wformat-security warning, bug 512426.
diff --git a/app-editors/emacs/emacs-21.4-r25.ebuild b/app-editors/emacs/emacs-21.4-r25.ebuild
deleted file mode 100644
index 1434b3eb64f6..000000000000
--- a/app-editors/emacs/emacs-21.4-r25.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r25.ebuild,v 1.1 2014/04/04 18:08:44 ulm Exp $
-
-EAPI=5
-WANT_AUTOMAKE="none"
-
-inherit elisp-common flag-o-matic eutils multilib toolchain-funcs autotools
-
-DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
-HOMEPAGE="http://www.gnu.org/software/emacs/"
-SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
- mirror://gentoo/${P}-patches-13.tar.bz2
- leim? ( mirror://gnu/emacs/leim-${PV}.tar.gz )"
-
-LICENSE="GPL-2+ FDL-1.1+ BSD HPND MIT"
-SLOT="21"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X Xaw3d leim motif sendmail"
-
-DEPEND="sys-libs/ncurses
- >=app-admin/eselect-emacs-1.16
- X? (
- x11-libs/libXext
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXmu
- x11-libs/libXpm
- x11-misc/xbitmaps
- >=media-libs/giflib-4.1.0.1b
- virtual/jpeg:0=
- >=media-libs/tiff-3.5.5-r3
- >=media-libs/libpng-1.4:0=
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( motif? ( >=x11-libs/motif-2.3:0 ) )
- )"
-
-RDEPEND="${DEPEND}
- >=app-emacs/emacs-common-gentoo-1.3[X?]
- sendmail? ( virtual/mta )"
-
-src_prepare() {
- EPATCH_SUFFIX=patch epatch
-
- sed -i \
- -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
- -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
- "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
-
- # This will need to be updated for X-Compilation
- sed -i -e "s:/usr/lib/\([^ ]*\).o:/usr/$(get_libdir)/\1.o:g" \
- "${S}/src/s/gnu-linux.h" || die
-
- sed -i -e "/^\\.so/s/etags/&-emacs-${SLOT}/" etc/ctags.1 \
- || die "unable to sed ctags.1"
-
- # custom aclocal.m4 was only needed for autoconf 2.13 and earlier
- rm aclocal.m4
- eaclocal
- eautoconf
-}
-
-src_configure() {
- # -fstack-protector gets internal compiler error at xterm.c (bug 33265)
- filter-flags -fstack-protector -fstack-protector-all
-
- # emacs doesn't handle LDFLAGS properly (bug #77430 and bug #65002)
- unset LDFLAGS
-
- # ever since GCC 3.2
- replace-flags "-O[3-9]" -O2
-
- # -march is known to cause signal 6 on some environment
- filter-flags "-march=*"
-
- local myconf
- if use X ; then
- myconf="${myconf}
- --with-x
- --with-xpm
- --with-jpeg
- --with-tiff
- --with-gif
- --with-png"
-
- if use Xaw3d ; then
- einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
- myconf="${myconf} --with-x-toolkit=athena"
- use motif \
- && ewarn "USE flag \"motif\" ignored (superseded by \"Xaw3d\")"
- elif use motif ; then
- einfo "Configuring to build with Motif toolkit"
- myconf="${myconf} --with-x-toolkit=motif"
- else
- # do not build emacs with any toolkit, bug 35300
- einfo "Configuring to build with no toolkit"
- myconf="${myconf} --with-x-toolkit=no"
- fi
- else
- myconf="${myconf} --without-x"
- fi
-
- econf ${myconf}
-
- # leave this in src_configure
- emake \
- locallisppath="/etc/emacs:${SITELISP}:/usr/share/emacs/${PV}/leim" \
- epaths-force
-}
-
-src_compile() {
- export SANDBOX_ON=0
- emake CC="$(tc-getCC)"
-
- einfo "Recompiling patched lisp files..."
- (cd lisp; emake recompile)
- (cd src; emake versionclean)
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- local i m
-
- einstall infodir="${D}/usr/share/info/emacs-${SLOT}"
-
- for i in "${D}"/usr/bin/* ; do
- mv "${i}" "${i}-emacs-${SLOT}" || die "mv ${i} failed"
- done
- mv "${D}"/usr/bin/emacs{-emacs,}-${SLOT} || die "mv emacs failed"
- rm "${D}"/usr/bin/emacs-${PV}-emacs-${SLOT}
-
- # move man pages to the correct place
- for m in "${D}"/usr/share/man/man1/* ; do
- mv "${m}" "${m%.1}-emacs-${SLOT}.1" || die "mv ${m} failed"
- done
- mv "${D}"/usr/share/man/man1/emacs{-emacs,}-${SLOT}.1 \
- || die "moving emacs man page failed"
-
- # move info dir to avoid collisions with the dir file generated by portage
- mv "${D}"/usr/share/info/emacs-${SLOT}/dir{,.orig} \
- || die "moving info dir failed"
- touch "${D}"/usr/share/info/emacs-${SLOT}/.keepinfodir
- docompress -x /usr/share/info/emacs-${SLOT}/dir.orig
-
- # avoid collision between slots
- rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
-
- # remove unused <version>/site-lisp dir
- rm -rf "${D}"/usr/share/emacs/${PV}/site-lisp
-
- # fix permissions
- find "${D}" -perm 664 |xargs chmod -f 644 2>/dev/null
- find "${D}" -type d |xargs chmod -f 755 2>/dev/null
-
- keepdir /usr/share/emacs/${PV}/leim
-
- dodoc BUGS ChangeLog README
-}
-
-pkg_preinst() {
- # move Info dir file to correct name
- local infodir=/usr/share/info/emacs-${SLOT} f
- if [ -f "${D}"${infodir}/dir.orig ]; then
- mv "${D}"${infodir}/dir{.orig,} || die "moving info dir failed"
- elif [[ -d "${D}"${infodir} ]]; then
- # this should not happen in EAPI 4
- ewarn "Regenerating Info directory index in ${infodir} ..."
- rm -f "${D}"${infodir}/dir{,.*}
- for f in "${D}"${infodir}/*; do
- if [[ ${f##*/} != *[0-9].info* && -e ${f} ]]; then
- install-info --info-dir="${D}"${infodir} "${f}" \
- || die "install-info failed"
- fi
- done
- fi
-}
-
-pkg_postinst() {
- eselect emacs update ifunset
-
- if ! use sendmail && ! has_version "virtual/mta"; then
- elog "You disabled sendmail support for Emacs. If you later install"
- elog "a MTA then you will need to recompile Emacs. See Bug #11104."
- fi
-
- if use X; then
- elog "You need to install some fonts for Emacs."
- elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
- elog "machine would satisfy basic Emacs requirements under X11."
- fi
-}
-
-pkg_postrm() {
- eselect emacs update ifunset
-}
diff --git a/app-editors/emacs/emacs-22.3-r12.ebuild b/app-editors/emacs/emacs-22.3-r12.ebuild
deleted file mode 100644
index 7022d64c49bd..000000000000
--- a/app-editors/emacs/emacs-22.3-r12.ebuild
+++ /dev/null
@@ -1,253 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r12.ebuild,v 1.1 2014/05/05 07:06:01 ulm Exp $
-
-EAPI=5
-WANT_AUTOMAKE="none"
-
-inherit autotools elisp-common eutils flag-o-matic
-
-DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
-HOMEPAGE="http://www.gnu.org/software/emacs/"
-SRC_URI="mirror://gnu/emacs/${P}.tar.gz
- mirror://gentoo/${P}-patches-8.tar.bz2"
-
-LICENSE="GPL-3+ FDL-1.2+ BSD HPND MIT"
-SLOT="22"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa games gif gtk gzip-el hesiod jpeg kerberos motif png sound source tiff toolkit-scroll-bars X Xaw3d +xpm"
-
-RDEPEND="sys-libs/ncurses
- >=app-admin/eselect-emacs-1.16
- >=app-emacs/emacs-common-gentoo-1.4-r1[games?,X?]
- net-libs/liblockfile
- hesiod? ( net-dns/hesiod )
- kerberos? ( virtual/krb5 )
- alsa? ( media-libs/alsa-lib )
- X? (
- x11-libs/libXmu
- x11-libs/libXt
- x11-misc/xbitmaps
- gif? ( media-libs/giflib )
- jpeg? ( virtual/jpeg:0= )
- png? ( >=media-libs/libpng-1.4:0= )
- tiff? ( media-libs/tiff )
- xpm? ( x11-libs/libXpm )
- gtk? ( x11-libs/gtk+:2 )
- !gtk? (
- Xaw3d? ( x11-libs/libXaw3d )
- !Xaw3d? ( motif? ( >=x11-libs/motif-2.3:0 ) )
- )
- )"
-
-DEPEND="${RDEPEND}
- alsa? ( virtual/pkgconfig )
- X? ( gtk? ( virtual/pkgconfig ) )
- gzip-el? ( app-arch/gzip )"
-
-# FULL_VERSION keeps the full version number, which is needed in order to
-# determine some path information correctly for copy/move operations later on
-FULL_VERSION="${PV}"
-EMACS_SUFFIX="emacs-${SLOT}"
-SITEFILE="20${PN}-${SLOT}-gentoo.el"
-
-src_prepare() {
- EPATCH_SUFFIX=patch epatch
-
- sed -i \
- -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
- -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
- "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
-
- sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" etc/ctags.1 \
- || die "unable to sed ctags.1"
-
- if ! use alsa; then
- # ALSA is detected even if not requested by its USE flag.
- # Suppress it by supplying pkg-config with a wrong library name.
- sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
- || die "unable to sed configure.in"
- fi
- if ! use gzip-el; then
- # Emacs' build system automatically detects the gzip binary and
- # compresses el files. We don't want that so confuse it with a
- # wrong binary name
- sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
- || die "unable to sed configure.in"
- fi
-
- eautoreconf
-}
-
-src_configure() {
- strip-flags
- filter-flags -fstack-protector -fstack-protector-all #285778
- replace-flags "-O[3-9]" -O2
- sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
-
- local myconf
-
- if use alsa && ! use sound; then
- einfo "Although sound USE flag is disabled you chose to have alsa,"
- einfo "so sound is switched on anyway."
- myconf="${myconf} --with-sound"
- else
- myconf="${myconf} $(use_with sound)"
- fi
-
- if use X; then
- myconf="${myconf} --with-x"
- myconf="${myconf} $(use_with toolkit-scroll-bars)"
- myconf="${myconf} $(use_with gif) $(use_with jpeg)"
- myconf="${myconf} $(use_with png) $(use_with tiff)"
- myconf="${myconf} $(use_with xpm)"
-
- # GTK+ is the default toolkit if USE=gtk is chosen with other
- # possibilities. Emacs upstream thinks this should be standard
- # policy on all distributions
- if use gtk; then
- einfo "Configuring to build with GIMP Toolkit (GTK+)"
- myconf="${myconf} --with-x-toolkit=gtk"
- elif use Xaw3d; then
- einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
- myconf="${myconf} --with-x-toolkit=athena"
- myconf="${myconf} --without-gtk"
- elif use motif; then
- einfo "Configuring to build with Motif toolkit"
- myconf="${myconf} --with-x-toolkit=motif"
- myconf="${myconf} --without-gtk"
- else
- einfo "Configuring to build with no toolkit"
- myconf="${myconf} --with-x-toolkit=no"
- myconf="${myconf} --without-gtk"
- fi
-
- local f tk=
- for f in gtk Xaw3d motif; do
- use ${f} || continue
- [ "${tk}" ] \
- && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
- tk="${tk}${tk:+ }${f}"
- done
- else
- myconf="${myconf} --without-x"
- fi
-
- econf \
- --program-suffix=-${EMACS_SUFFIX} \
- --infodir=/usr/share/info/${EMACS_SUFFIX} \
- --localstatedir=/var \
- --enable-locallisppath="/etc/emacs:${SITELISP}" \
- --without-carbon \
- --with-gameuser="${GAMES_USER_DED:-games}" \
- $(use_with hesiod) \
- $(use_with kerberos) $(use_with kerberos kerberos5) \
- ${myconf}
-}
-
-src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake CC="$(tc-getCC)"
-}
-
-src_install () {
- emake DESTDIR="${D}" install
-
- rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
- || die "removing duplicate emacs executable failed"
- mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
- || die "moving emacs executable failed"
-
- # move man pages to the correct place
- local m
- mv "${D}"/usr/share/man/man1/{emacs,${EMACS_SUFFIX}}.1 \
- || die "moving emacs man page failed"
- for m in ctags emacsclient etags; do
- mv "${D}"/usr/share/man/man1/${m}{,-${EMACS_SUFFIX}}.1 \
- || die "moving ${m} man page failed"
- done
-
- # move info dir to avoid collisions with the dir file generated by portage
- mv "${D}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} \
- || die "moving info dir failed"
- touch "${D}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
- docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
-
- # avoid collision between slots, see bug #169033 e.g.
- rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
- rm -rf "${D}"/var
-
- # remove unused <version>/site-lisp dir
- rm -rf "${D}"/usr/share/emacs/${FULL_VERSION}/site-lisp
-
- local c=";;"
- if use source; then
- insinto /usr/share/emacs/${FULL_VERSION}/src
- # This is not meant to install all the source -- just the
- # C source you might find via find-function
- doins src/*.[ch]
- c=""
- fi
-
- sed 's/^X//' >"${T}/${SITEFILE}" <<-EOF
- X
- ;;; ${PN}-${SLOT} site-lisp configuration
- X
- (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
- X ${c}(setq find-function-C-source-directory
- X ${c} "/usr/share/emacs/${FULL_VERSION}/src")
- X (let ((path (getenv "INFOPATH"))
- X (dir "/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`/usr/share/info\\\\>"))
- X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
- X (let* ((p (cons nil (split-string path ":" t))) (q p))
- X (while (and (cdr q) (not (string-match re (cadr q))))
- X (setq q (cdr q)))
- X (setcdr q (cons dir (delete dir (cdr q))))
- X (setq Info-directory-list (prune-directory-list (cdr p)))))))
- EOF
- elisp-site-file-install "${T}/${SITEFILE}" || die
-
- dodoc AUTHORS BUGS CONTRIBUTE README
-}
-
-pkg_preinst() {
- # move Info dir file to correct name
- local infodir=/usr/share/info/${EMACS_SUFFIX} f
- if [ -f "${D}"${infodir}/dir.orig ]; then
- mv "${D}"${infodir}/dir{.orig,} || die "moving info dir failed"
- elif [[ -d "${D}"${infodir} ]]; then
- # this should not happen in EAPI 4
- ewarn "Regenerating Info directory index in ${infodir} ..."
- rm -f "${D}"${infodir}/dir{,.*}
- for f in "${D}"${infodir}/*; do
- if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
- install-info --info-dir="${D}"${infodir} "${f}" \
- || die "install-info failed"
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elisp-site-regen
- eselect emacs update ifunset
-
- if use X; then
- elog "You need to install some fonts for Emacs."
- elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
- elog "machine would satisfy basic Emacs requirements under X11."
- elog
- fi
-
- elog "You can set the version to be started by /usr/bin/emacs through"
- elog "the Emacs eselect module, which also redirects man and info pages."
- elog "Therefore, several Emacs versions can be installed at the same time."
- elog "\"man emacs.eselect\" for details."
-}
-
-pkg_postrm() {
- elisp-site-regen
- eselect emacs update ifunset
-}
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
index 4981aad93704..b68a93941698 100644
--- a/app-editors/emacs/metadata.xml
+++ b/app-editors/emacs/metadata.xml
@@ -30,12 +30,10 @@
<flag name='hesiod'>Enable support for <pkg>net-dns/hesiod</pkg></flag>
<flag name='imagemagick'>Use <pkg>media-gfx/imagemagick</pkg> for image
processing</flag>
- <flag name='leim'>Add support for Emacs input methods</flag>
<flag name='libxml2'>Use <pkg>dev-libs/libxml2</pkg> to parse XML instead
of the internal Lisp implementations</flag>
<flag name='pax_kernel'>Enable building under a PaX enabled kernel
(<pkg>sys-apps/paxctl</pkg>)</flag>
- <flag name='sendmail'>Build Emacs with MTA support</flag>
<flag name='source'>Install C source files and make them available for
find-function</flag>
<flag name='toolkit-scroll-bars'>Use the selected toolkit's scrollbars in