summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-01-03 12:21:51 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-01-03 12:21:51 +0000
commit814cd851afc46c17b66c1122fdd78113907ab76a (patch)
treedbc16eea022f962d2cd6a8c625e753ff2fddca68 /app-editors
parentfix qt3/qt4 confusion issue (diff)
downloadgentoo-2-814cd851afc46c17b66c1122fdd78113907ab76a.tar.gz
gentoo-2-814cd851afc46c17b66c1122fdd78113907ab76a.tar.bz2
gentoo-2-814cd851afc46c17b66c1122fdd78113907ab76a.zip
fix qmake for qt3/qt4 issue
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/cute/ChangeLog8
-rw-r--r--app-editors/cute/cute-0.2.9-r1.ebuild6
-rw-r--r--app-editors/cute/cute-0.2.9-r2.ebuild8
-rw-r--r--app-editors/cute/cute-0.2.9.ebuild6
4 files changed, 16 insertions, 12 deletions
diff --git a/app-editors/cute/ChangeLog b/app-editors/cute/ChangeLog
index 6b5440b07757..64b56dc264c3 100644
--- a/app-editors/cute/ChangeLog
+++ b/app-editors/cute/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/cute
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/ChangeLog,v 1.19 2005/12/31 12:09:38 blubb Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/ChangeLog,v 1.20 2006/01/03 12:21:51 caleb Exp $
+
+ 03 Jan 2006; Caleb Tennis <caleb@gentoo.org> cute-0.2.9.ebuild,
+ cute-0.2.9-r1.ebuild, cute-0.2.9-r2.ebuild:
+ fix qmake for qt3/qt4 issue
31 Dec 2005; Simon Stelling <blubb@gentoo.org> cute-0.2.9-r2.ebuild:
stable on amd64
diff --git a/app-editors/cute/cute-0.2.9-r1.ebuild b/app-editors/cute/cute-0.2.9-r1.ebuild
index f670986c3e03..ee11dba2c0fa 100644
--- a/app-editors/cute/cute-0.2.9-r1.ebuild
+++ b/app-editors/cute/cute-0.2.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9-r1.ebuild,v 1.6 2005/10/30 01:52:09 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9-r1.ebuild,v 1.7 2006/01/03 12:21:51 caleb Exp $
inherit distutils
@@ -42,7 +42,7 @@ src_compile() {
cd ${S}/cute
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
addpredict "$QTDIR/etc/settings"
- ${QTDIR}/bin/qmake -o Makefile cute.pro
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake -o Makefile cute.pro
emake || die
}
diff --git a/app-editors/cute/cute-0.2.9-r2.ebuild b/app-editors/cute/cute-0.2.9-r2.ebuild
index 7cc599f2febb..dd91db487b28 100644
--- a/app-editors/cute/cute-0.2.9-r2.ebuild
+++ b/app-editors/cute/cute-0.2.9-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9-r2.ebuild,v 1.2 2005/12/31 12:09:38 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9-r2.ebuild,v 1.3 2006/01/03 12:21:51 caleb Exp $
inherit distutils
@@ -41,7 +41,7 @@ src_compile() {
cd ${S}/cute
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
addpredict "$QTDIR/etc/settings"
- ${ROOT}usr/qt/3/bin/qmake -o Makefile cute.pro
+ ${ROOT}usr/qt/3/bin/qmake QMAKE=${ROOT}usr/qt/3/bin/qmake -o Makefile cute.pro
emake || die
}
@@ -60,4 +60,4 @@ src_install() {
insinto /usr/share/icons
doins ${S}/cute/icons/cute.xpm
dodoc changelog.txt LICENSE INSTALL README
-} \ No newline at end of file
+}
diff --git a/app-editors/cute/cute-0.2.9.ebuild b/app-editors/cute/cute-0.2.9.ebuild
index f42ce30704a1..65c1b529f27f 100644
--- a/app-editors/cute/cute-0.2.9.ebuild
+++ b/app-editors/cute/cute-0.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9.ebuild,v 1.9 2005/07/25 15:33:43 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9.ebuild,v 1.10 2006/01/03 12:21:51 caleb Exp $
inherit distutils qt3
@@ -31,7 +31,7 @@ src_compile() {
cd ${S}/cute
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
addpredict "$QTDIR/etc/settings"
- ${QTDIR}/bin/qmake -o Makefile cute.pro
+ ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake -o Makefile cute.pro
sed -i -e "s:CFLAGS = -pipe -O2:CFLAGS = ${CFLAGS}:" \
-e "s:CXXFLAGS = -pipe -O2:CXXFLAGS = ${CXXFLAGS}:" Makefile
emake || die