summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-02-07 07:39:48 +0000
committerPeter Gavin <pete@gentoo.org>2001-02-07 07:39:48 +0000
commit74fcc9115156c160bfe447af730cc516c0a1f0df (patch)
treed85da428cef7a46e0dbb2ec58eea29b6e1573660 /app-editors
parentsame as emacs-x11-20.7.ebuild, just changed the prefix to /usr (diff)
downloadgentoo-2-74fcc9115156c160bfe447af730cc516c0a1f0df.tar.gz
gentoo-2-74fcc9115156c160bfe447af730cc516c0a1f0df.tar.bz2
gentoo-2-74fcc9115156c160bfe447af730cc516c0a1f0df.zip
same as emacs-motif-20.7.ebuild, just changed prefix to /usr
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-motif/emacs-motif-20.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/emacs-motif/emacs-motif-20.7-r1.ebuild b/app-editors/emacs-motif/emacs-motif-20.7-r1.ebuild
new file mode 100644
index 000000000000..0f288ded1e4e
--- /dev/null
+++ b/app-editors/emacs-motif/emacs-motif-20.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+
+A=emacs-20.7.tar.gz
+S=${WORKDIR}/emacs-20.7
+DESCRIPTION="An incredibly powerful, extensible text editor (X11/Motif version)"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/emacs/emacs-20.7.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+RDEPEND=">=sys-libs/ncurses-4.0
+ >=x11-libs/openmotif-2.1.30
+ !app-editors/emacs-nogui
+ !app-editors/emacs-x11"
+
+DEPEND=">=sys-libs/ncurses-4.0
+ >=x11-libs/openmotif-2.1.30
+ >=sys-devel/gettext-0.10.35"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --libexecdir=/usr/lib --host=${CHOST} \
+ --with-x-toolkit=motif --with-x
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 libexecdir=${D}/usr/X11R6/lib install
+ dodoc BUGS ChangeLog README
+ gzip -9 ${D}/usr/X11R6/info/*
+}
+