summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2008-07-03 21:35:11 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2008-07-03 21:35:11 +0000
commit6a642bd7c353f8403da05248d3db364d0705c74f (patch)
tree890335ede0b37b2c8fd603db97ce8d373f696194 /app-editors
parentbump to 2.20.7. Fix asserts on shutdown and various other fixes. Translation ... (diff)
downloadgentoo-2-6a642bd7c353f8403da05248d3db364d0705c74f.tar.gz
gentoo-2-6a642bd7c353f8403da05248d3db364d0705c74f.tar.bz2
gentoo-2-6a642bd7c353f8403da05248d3db364d0705c74f.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-17.6.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index f4f8a9adfb06..47a55fc6f73c 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.36 2008/04/23 17:40:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.37 2008/07/03 21:35:11 gentoofan23 Exp $
+
+*tea-17.6.3 (03 Jul 2008)
+
+ 03 Jul 2008; Thomas Anderson <gentoofan23@gentoo.org> +tea-17.6.3.ebuild:
+ Version bump
23 Apr 2008; Raúl Porcel <armin76@gentoo.org> tea-17.6.0.ebuild:
x86 stable
diff --git a/app-editors/tea/tea-17.6.3.ebuild b/app-editors/tea/tea-17.6.3.ebuild
new file mode 100644
index 000000000000..836d4011a40c
--- /dev/null
+++ b/app-editors/tea/tea-17.6.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-17.6.3.ebuild,v 1.1 2008/07/03 21:35:11 gentoofan23 Exp $
+
+EAPI="1"
+inherit autotools eutils
+
+MY_P=${P/tea/teagtk}
+
+DESCRIPTION="Small, lightweight GTK+ text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="enchant gnome hacking ipv6 spell"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ gnome? ( x11-libs/gtksourceview:2.0
+ gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ net-misc/curl
+ spell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-17.5.4-forced-cflags-and-compiler-warnings.patch
+ eautoconf
+}
+
+src_compile() {
+ local myconf
+
+ if use hacking; then
+ myconf="${myconf} --enable-hacking"
+ fi
+ if ! use gnome; then
+ myconf="${myconf} --enable-legacy"
+ fi
+ if use enchant; then
+ myconf="${myconf} --enable-enchant"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed!"
+
+ make_desktop_entry teagtk Tea /usr/share/tea/pixmaps/tea_icon_v2.png Development
+
+# insinto /usr/share/doc/tea/
+# doins AUTHORS COPYING NEWS README TODO ChangeLog doc/*
+
+# insinto /usr/share/pixmaps/
+# doins pixmaps/*
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}