summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-18 03:43:38 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-18 03:43:38 +0000
commit2ffe95dc8054c8691468f526aa4a2a85f0539159 (patch)
tree29bfcff9813c8d2880ae0fcfbd2cf7e25d76a974 /app-editors
parentRemove /usr/local paths from docs, install using `emake DESTDIR`, and dont bo... (diff)
downloadgentoo-2-2ffe95dc8054c8691468f526aa4a2a85f0539159.tar.gz
gentoo-2-2ffe95dc8054c8691468f526aa4a2a85f0539159.tar.bz2
gentoo-2-2ffe95dc8054c8691468f526aa4a2a85f0539159.zip
Fix byBedOS_Gui for building with USE=debug #234959.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog6
-rw-r--r--app-editors/nano/files/nano-2.1.4-debug.patch13
-rw-r--r--app-editors/nano/nano-2.1.4.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index c69456044e5e..23071153ba17 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.201 2008/08/16 14:45:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.202 2008/08/18 03:43:38 vapier Exp $
+
+ 18 Aug 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/nano-2.1.4-debug.patch, nano-2.1.4.ebuild:
+ Fix byBedOS_Gui for building with USE=debug #234959.
*nano-2.1.4 (16 Aug 2008)
diff --git a/app-editors/nano/files/nano-2.1.4-debug.patch b/app-editors/nano/files/nano-2.1.4-debug.patch
new file mode 100644
index 000000000000..bab5f6bb34f9
--- /dev/null
+++ b/app-editors/nano/files/nano-2.1.4-debug.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/234959
+
+--- nano-2.1.4/src/text.c
++++ nano-2.1.4/src/text.c
+@@ -649,7 +649,7 @@
+ filestruct *newnode = make_new_node(openfile->current);
+ size_t extra = 0;
+
+- assert(openfile->current != NULL && xopenfile->current->data != NULL);
++ assert(openfile->current != NULL && openfile->current->data != NULL);
+
+ #ifndef NANO_TINY
+ update_undo(SPLIT);
diff --git a/app-editors/nano/nano-2.1.4.ebuild b/app-editors/nano/nano-2.1.4.ebuild
index 6d64adcafb04..b7cd00c61066 100644
--- a/app-editors/nano/nano-2.1.4.ebuild
+++ b/app-editors/nano/nano-2.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.4.ebuild,v 1.1 2008/08/16 14:45:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.4.ebuild,v 1.2 2008/08/18 03:43:38 vapier Exp $
inherit eutils
if [[ ${PV} == "9999" ]] ; then
@@ -29,6 +29,7 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-debug.patch #234959
epatch "${FILESDIR}"/${P}-open-mode.patch #232079
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"