summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-03 19:18:38 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-03 19:18:38 +0000
commit22cc17f3e6ec0739b70c7299e1022dce74015bd7 (patch)
tree0fe3fab7e7d177991e2ed48867ccedd5ceaa52bf /app-editors
parentVersion bump (diff)
downloadgentoo-2-22cc17f3e6ec0739b70c7299e1022dce74015bd7.tar.gz
gentoo-2-22cc17f3e6ec0739b70c7299e1022dce74015bd7.tar.bz2
gentoo-2-22cc17f3e6ec0739b70c7299e1022dce74015bd7.zip
Make rtf2pdf.sh accessible from /usr/bin (bug #347926 by James Broadhead) and fix parallel make (bug 385485 by Ian Delaney).
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ted/ChangeLog9
-rw-r--r--app-editors/ted/files/ted-2.21-make.patch12
-rw-r--r--app-editors/ted/ted-2.21.ebuild6
3 files changed, 23 insertions, 4 deletions
diff --git a/app-editors/ted/ChangeLog b/app-editors/ted/ChangeLog
index 5a22bb8c6c78..91dd537ebb67 100644
--- a/app-editors/ted/ChangeLog
+++ b/app-editors/ted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ted
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.46 2011/10/23 20:02:52 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.47 2012/03/03 19:18:38 pacho Exp $
+
+ 03 Mar 2012; Pacho Ramos <pacho@gentoo.org> +files/ted-2.21-make.patch,
+ ted-2.21.ebuild:
+ Make rtf2pdf.sh accessible from /usr/bin (bug #347926 by James Broadhead) and
+ fix parallel make (bug 385485 by Ian Delaney).
23 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -ted-2.20.ebuild,
-files/ted-2.20-libpng14.patch:
diff --git a/app-editors/ted/files/ted-2.21-make.patch b/app-editors/ted/files/ted-2.21-make.patch
new file mode 100644
index 000000000000..2916c9505556
--- /dev/null
+++ b/app-editors/ted/files/ted-2.21-make.patch
@@ -0,0 +1,12 @@
+diff -ur Ted-2.21.orig//Makefile Ted-2.21/Makefile
+--- Ted-2.21.orig//Makefile 2009-10-16 23:20:58.000000000 +0800
++++ Ted-2.21/Makefile 2011-10-04 00:22:30.615975269 +0800
+@@ -198,7 +198,7 @@
+ : To install Ted, you can now run 'make install' AS ROOT
+
+ package.shared: tedPackage/makefile compile.shared
+- cd tedPackage && make package.shared
++ cd tedPackage && $(MAKE) package.shared
+ :
+ : Dynamically linked package ready.
+ : To install Ted, you can now run 'make install' AS ROOT
diff --git a/app-editors/ted/ted-2.21.ebuild b/app-editors/ted/ted-2.21.ebuild
index 6ffdc44f9623..e53626bbb1ef 100644
--- a/app-editors/ted/ted-2.21.ebuild
+++ b/app-editors/ted/ted-2.21.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.21.ebuild,v 1.9 2011/10/23 16:07:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.21.ebuild,v 1.10 2012/03/03 19:18:38 pacho Exp $
EAPI=4
inherit eutils toolchain-funcs
@@ -26,6 +26,7 @@ S=${WORKDIR}/Ted-${PV}
src_prepare() {
epatch "${FILESDIR}"/${P}-libpng15.patch
+ epatch "${FILESDIR}"/${P}-make.patch
sed -i -e 's|/Ted/|/share/Ted/|' \
"${S}"/appFrame/appFrameConfig.h.in \
@@ -54,4 +55,5 @@ src_install() {
dodir /usr/share
mv "${ED}"usr/Ted "${ED}"usr/share/Ted
+ dosym /usr/share/Ted/rtf2pdf.sh /usr/bin/rtf2pdf.sh
}