summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-28 08:27:36 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-28 08:27:36 +0000
commit098c6c4ae835c99c7568fc2cd838af08879e643d (patch)
tree418e92b6be2f6e33cb672bfe9e24ef4c07b7f424 /app-editors
parentAppend kde-telepathy-0.5.0 to tp-qt mask as it is needed as build dependency. (diff)
downloadgentoo-2-098c6c4ae835c99c7568fc2cd838af08879e643d.tar.gz
gentoo-2-098c6c4ae835c99c7568fc2cd838af08879e643d.tar.bz2
gentoo-2-098c6c4ae835c99c7568fc2cd838af08879e643d.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vile/ChangeLog8
-rw-r--r--app-editors/vile/files/vile-9.8h-flex.patch30
-rw-r--r--app-editors/vile/vile-9.8h.ebuild48
3 files changed, 85 insertions, 1 deletions
diff --git a/app-editors/vile/ChangeLog b/app-editors/vile/ChangeLog
index f38b51fae61b..12a6881dffa5 100644
--- a/app-editors/vile/ChangeLog
+++ b/app-editors/vile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.45 2012/07/08 18:16:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.46 2012/08/28 08:27:36 radhermit Exp $
+
+*vile-9.8h (28 Aug 2012)
+
+ 28 Aug 2012; Tim Harder <radhermit@gentoo.org> +vile-9.8h.ebuild,
+ +files/vile-9.8h-flex.patch:
+ Version bump.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> vile-9.8g.ebuild:
alpha/ia64/sparc stable wrt #418409
diff --git a/app-editors/vile/files/vile-9.8h-flex.patch b/app-editors/vile/files/vile-9.8h-flex.patch
new file mode 100644
index 000000000000..bb1c1c301110
--- /dev/null
+++ b/app-editors/vile/files/vile-9.8h-flex.patch
@@ -0,0 +1,30 @@
+--- vile-9.8h/filters/filters.h
++++ vile-9.8h/filters/filters.h
+@@ -200,27 +200,6 @@
+ #endif
+ #endif /* __GNUC__ */
+
+-/*
+- * 2003/5/20 - "new" flex 2.5.31:
+- * workaround for "developers" who don't use compiler-warnings...
+- * perhaps by the time "new" flex merits the term "beta", they'll fix this:
+- */
+-#if defined(FLEX_BETA)
+-extern FILE *yyget_in (void);
+-extern FILE *yyget_out (void);
+-extern char *yyget_text (void);
+-extern int yyget_debug (void);
+-extern int yyget_leng (void);
+-extern int yyget_lineno (void);
+-extern int yylex_destroy (void);
+-extern void yyset_debug (int bdebug);
+-extern void yyset_in (FILE * in_str);
+-extern void yyset_lineno (int line_number);
+-extern void yyset_out (FILE * out_str);
+-/* there's also warnings for unused 'yyunput()', but I don't see a fix */
+-/* flex's skeleton includes <unistd.h> - no particular reason apparent */
+-#endif
+-
+ #define YY_NO_INPUT 1 /* get rid of 'input()' function */
+
+ /*
diff --git a/app-editors/vile/vile-9.8h.ebuild b/app-editors/vile/vile-9.8h.ebuild
new file mode 100644
index 000000000000..1e07506c10f7
--- /dev/null
+++ b/app-editors/vile/vile-9.8h.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.8h.ebuild,v 1.1 2012/08/28 08:27:36 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-admin/eselect-vi"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flex.patch
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}