summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-19 02:06:01 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-19 02:06:01 +0000
commit0297be6411cd5459459bf3629c16af88db47f8cb (patch)
treea90045c5e946e80223b43a38938e76421ea40df5 /app-editors
parenturl update (diff)
downloadgentoo-2-0297be6411cd5459459bf3629c16af88db47f8cb.tar.gz
gentoo-2-0297be6411cd5459459bf3629c16af88db47f8cb.tar.bz2
gentoo-2-0297be6411cd5459459bf3629c16af88db47f8cb.zip
*** empty log message ***
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-gtk/files/digest-vim-gtk-5.7-r42
-rw-r--r--app-editors/vim-gtk/vim-gtk-5.7-r4.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-editors/vim-gtk/files/digest-vim-gtk-5.7-r4 b/app-editors/vim-gtk/files/digest-vim-gtk-5.7-r4
new file mode 100644
index 000000000000..bd52e4ba82b9
--- /dev/null
+++ b/app-editors/vim-gtk/files/digest-vim-gtk-5.7-r4
@@ -0,0 +1,2 @@
+MD5 0b2bca69c7018a8777d8d5390e23d06e vim-5.7-src.tar.gz
+MD5 b7d9cbc64479e26f52e2bc58d312bd84 vim-5.7-rt.tar.gz
diff --git a/app-editors/vim-gtk/vim-gtk-5.7-r4.ebuild b/app-editors/vim-gtk/vim-gtk-5.7-r4.ebuild
new file mode 100644
index 000000000000..e925cd870013
--- /dev/null
+++ b/app-editors/vim-gtk/vim-gtk-5.7-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-gtk/vim-gtk-5.7-r4.ebuild,v 1.1 2001/04/19 02:06:01 achim Exp $
+
+P=vim-gtk-5.7
+A="vim-5.7-src.tar.gz vim-5.7-rt.tar.gz"
+S=${WORKDIR}/vim-5.7
+DESCRIPTION="Handy vi-compatible editor"
+SRC_URI="ftp://ftp.home.vim.org/pub/vim/unix/vim-5.7-src.tar.gz
+ ftp://ftp.home.vim.org/pub/vim/unix/vim-5.7-rt.tar.gz"
+HOMEPAGE="http://www.vim.org"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/ncurses-5.2
+ >=x11-libs/gtk+-1.2.8
+ python? ( virtual/python )
+ tcltk? ( >=dev-lang/tcl-tk-8.1.1 )"
+
+RDEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tcl-tk-8.1.1 )
+ >=x11-libs/gtk+-1.2.8
+ gpm? ( >=sys-libs/gpm-1.19.3 )"
+
+src_compile() {
+ local myconf
+ if [ "`use python`" ]
+ then
+ myconf="--enable-pythoninterp"
+ fi
+ if [ "`use tcltk`" ]
+ then
+ myconf="$myconf --enable-tclinterp"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --enable-gui=gtk --enable-max-features \
+ --enable-xim --enable-fontset --with-x $myconf
+ try make
+}
+
+src_install() {
+ into /usr
+ cd ${S}/src
+ cp vim gvim
+ dobin gvim
+
+}
+
+
+