summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-22 02:20:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-22 02:20:28 +0000
commitd61cd125a12843e6ac6051c258f02673ae47958c (patch)
treec9c54635f7bb7f930a661e0cc397c05747e2e478 /app-editors/screem
parentRemoving hawking as a maintainer since he was retired. (diff)
downloadgentoo-2-d61cd125a12843e6ac6051c258f02673ae47958c.tar.gz
gentoo-2-d61cd125a12843e6ac6051c258f02673ae47958c.tar.bz2
gentoo-2-d61cd125a12843e6ac6051c258f02673ae47958c.zip
Bump to 0.16.1-r1,
* Remove deprecation warnings, bug #127486. * Make add tag file feature work, bug #256611. * About dialog does not close, bug #256803. * Fix error in exit due to old dbus calls, bug #255750. * Port to GOption, fix tests. * Install translations, bug #256611. (Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/screem')
-rw-r--r--app-editors/screem/ChangeLog20
-rw-r--r--app-editors/screem/files/screem-0.16.1-add-tag-file.patch42
-rw-r--r--app-editors/screem/files/screem-0.16.1-dbus-closing.patch30
-rw-r--r--app-editors/screem/files/screem-0.16.1-deprecated.patch25
-rw-r--r--app-editors/screem/files/screem-0.16.1-fix-about-dialog.patch19
-rw-r--r--app-editors/screem/files/screem-0.16.1-goption.patch96
-rw-r--r--app-editors/screem/screem-0.16.1-r1.ebuild94
7 files changed, 324 insertions, 2 deletions
diff --git a/app-editors/screem/ChangeLog b/app-editors/screem/ChangeLog
index 0d83a8e20f95..569e822950da 100644
--- a/app-editors/screem/ChangeLog
+++ b/app-editors/screem/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for app-editors/screem
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/screem/ChangeLog,v 1.15 2008/08/04 21:11:36 eva Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/screem/ChangeLog,v 1.16 2009/03/22 02:20:28 eva Exp $
+
+*screem-0.16.1-r1 (22 Mar 2009)
+
+ 22 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/screem-0.16.1-add-tag-file.patch,
+ +files/screem-0.16.1-dbus-closing.patch,
+ +files/screem-0.16.1-deprecated.patch,
+ +files/screem-0.16.1-fix-about-dialog.patch,
+ +files/screem-0.16.1-goption.patch, +screem-0.16.1-r1.ebuild:
+ Bump to 0.16.1-r1,
+ * Remove deprecation warnings, bug #127486.
+ * Make add tag file feature work, bug #256611.
+ * About dialog does not close, bug #256803.
+ * Fix error in exit due to old dbus calls, bug #255750.
+ * Port to GOption, fix tests.
+ * Install translations, bug #256611.
04 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
-files/screem-0.8.1-makefile-fix.patch, -screem-0.16.0.ebuild:
diff --git a/app-editors/screem/files/screem-0.16.1-add-tag-file.patch b/app-editors/screem/files/screem-0.16.1-add-tag-file.patch
new file mode 100644
index 000000000000..d5bb046fd4be
--- /dev/null
+++ b/app-editors/screem/files/screem-0.16.1-add-tag-file.patch
@@ -0,0 +1,42 @@
+---
+Tag tree feature does not work.
+
+https://bugs.gentoo.org/show_bug.cgi?id=256611
+https://sourceforge.net/support/tracker.php?aid=2543273
+
+--- a/src/screem-tagtree.c 2009-01-21 20:00:39.000000000 +0100
++++ b/src/screem-tagtree.c 2009-01-27 15:37:12.000000000 +0100
+@@ -673,12 +673,8 @@
+ G_TYPE_POINTER );
+
+ priv->dtdbranch = screem_tag_file_new();
++ model=priv->umodel;
+
+- model = gtk_tree_model_sort_new_with_model( priv->umodel );
+- gtk_tree_sortable_set_sort_func( GTK_TREE_SORTABLE( model ),
+- 0, screem_tag_tree_sort, tree, NULL );
+- gtk_tree_sortable_set_sort_column_id( GTK_TREE_SORTABLE( model ),
+- SCREEM_TAG_FILE_NAME, GTK_SORT_ASCENDING );
+ priv->sorted = model;
+
+ screem_tag_tree_add_file( tree, priv->dtdbranch, TRUE );
+@@ -688,7 +684,6 @@
+ model );
+ gdk_threads_leave();
+
+- g_object_unref( model );
+
+ return FALSE;
+ }
+--- a/src/screem-preferences.c 2009-01-27 16:50:33.000000000 +0100
++++ b/src/screem-preferences.c 2009-01-27 17:25:38.000000000 +0100
+@@ -1387,7 +1387,8 @@
+ glade_xml_signal_autoconnect( dxml );
+
+ if( gtk_dialog_run( GTK_DIALOG( widget ) ) == GTK_RESPONSE_OK ) {
+- widget = glade_xml_get_widget( dxml, "url" );
++ widget = glade_xml_get_widget( dxml, "open_file_uri" );
++ widget = GTK_BIN( widget )->child;
+ url = gtk_entry_get_text( GTK_ENTRY( widget ) );
+
+ found = screem_gtk_list_store_find_string( GTK_LIST_STORE( model ), &it, TAG_FILE_URI_COL, url );
diff --git a/app-editors/screem/files/screem-0.16.1-dbus-closing.patch b/app-editors/screem/files/screem-0.16.1-dbus-closing.patch
new file mode 100644
index 000000000000..04510de9b770
--- /dev/null
+++ b/app-editors/screem/files/screem-0.16.1-dbus-closing.patch
@@ -0,0 +1,30 @@
+---
+https://bugs.gentoo.org/show_bug.cgi?id=255750
+https://sourceforge.net/tracker/index.php?func=detail&aid=2543239&group_id=142&atid=100142
+
+This removes some obsolete calls to dbus-0.33.0 which were introduced in 2005,
+according to the internal ChangeLog of the package.
+
+
+--- a/src/screem-dbus.c 2009-01-18 12:26:29.000000000 +0100
++++ b/src/screem-dbus.c 2009-01-18 21:57:55.000000000 +0100
+@@ -129,19 +129,9 @@
+
+ #ifdef HAVE_DBUS
+ if( priv->conn ) {
+-#if DBUS_VERSION > 33000
+- dbus_connection_close( priv->conn );
+-#else
+- dbus_connection_disconnect( priv->conn );
+-#endif
+ dbus_connection_unref( priv->conn );
+ }
+ if( priv->sconn ) {
+-#if DBUS_VERSION > 33000
+- dbus_connection_close( priv->sconn );
+-#else
+- dbus_connection_disconnect( priv->sconn );
+-#endif
+ dbus_connection_unref( priv->sconn );
+ }
+ #endif
diff --git a/app-editors/screem/files/screem-0.16.1-deprecated.patch b/app-editors/screem/files/screem-0.16.1-deprecated.patch
new file mode 100644
index 000000000000..386323a3771e
--- /dev/null
+++ b/app-editors/screem/files/screem-0.16.1-deprecated.patch
@@ -0,0 +1,25 @@
+---
+http://patches.ubuntu.com/by-release/extracted/ubuntu/s/screem/0.16.1-4.2ubuntu1/no-disable-deprecated.patch
+
+--- a/configure.ac 2007-11-15 09:17:22.000000000 +0100
++++ b/configure.ac 2007-11-15 09:17:31.000000000 +0100
+@@ -255,7 +255,7 @@
+ dnl being the blocker here, need a util function which does the
+ dnl same for utf-8
+
+-DEPRECATION_FLAGS="-DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGNOMEUI_DISABLE_DEPRECATED"
++DEPRECATION_FLAGS=""
+
+ CFLAGS="$SCREEM_CFLAGS -Wall $DEPRECATION_FLAGS $CFLAGS"
+ AC_SUBST(CFLAGS)
+--- a/configure
++++ b/configure
+@@ -26003,7 +26003,7 @@
+
+
+
+-DEPRECATION_FLAGS="-DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGNOMEUI_DISABLE_DEPRECATED"
++DEPRECATION_FLAGS=""
+
+ CFLAGS="$SCREEM_CFLAGS -Wall $DEPRECATION_FLAGS $CFLAGS"
+
diff --git a/app-editors/screem/files/screem-0.16.1-fix-about-dialog.patch b/app-editors/screem/files/screem-0.16.1-fix-about-dialog.patch
new file mode 100644
index 000000000000..d911729faf7d
--- /dev/null
+++ b/app-editors/screem/files/screem-0.16.1-fix-about-dialog.patch
@@ -0,0 +1,19 @@
+---
+The "about" window does not close.
+
+https://bugs.gentoo.org/show_bug.cgi?id=256803
+http://patches.ubuntu.com/by-release/extracted/ubuntu/s/screem/0.16.1-4.2ubuntu1/fix_help_about_dialog.patch
+https://sourceforge.net/tracker/index.php?func=detail&aid=1752102&group_id=142&atid=100142
+
+--- a/src/screem-window-menus.c 2005-11-12 13:56:37.000000000 -0500
++++ b/src/screem-window-menus.c 2008-10-13 09:43:30.000000000 -0400
+@@ -3030,6 +3030,9 @@
+ g_signal_connect_swapped( G_OBJECT( about ), "destroy",
+ G_CALLBACK( g_nullify_pointer ),
+ &about );
++ g_signal_connect( G_OBJECT( about ), "response",
++ G_CALLBACK( gtk_widget_destroy ),
++ NULL );
+ }
+ gtk_window_set_transient_for( GTK_WINDOW( about ),
+ GTK_WINDOW( user_data ) );
diff --git a/app-editors/screem/files/screem-0.16.1-goption.patch b/app-editors/screem/files/screem-0.16.1-goption.patch
new file mode 100644
index 000000000000..8cedb3caa651
--- /dev/null
+++ b/app-editors/screem/files/screem-0.16.1-goption.patch
@@ -0,0 +1,96 @@
+---
+Use GOption in place of popt.
+
+http://patches.ubuntu.com/by-release/extracted/ubuntu/s/screem/0.16.1-4.2ubuntu1/switch-to-goption.patch
+
+--- a/src/screem-main.c 2005-10-10 20:17:58.000000000 +0100
++++ b/src/screem-main.c 2006-04-24 23:11:08.732661938 +0100
+@@ -54,12 +54,23 @@
+ static gchar *session_filename = SESSION_LAST;
+
+ /* passed parameters stuff */
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ static const struct poptOption options[] = {
+ { "load-session", 'l', POPT_ARG_STRING, &session_filename, 0,
+ N_("Load the given session file"),
+ N_("FILE") },
+ { NULL, '\0', 0, NULL, 0, NULL, NULL }
+ };
++#else /* USE GOption interface */
++static const gchar **remaining_args = NULL;
++static GOptionEntry option_entries[] = {
++ { "load-session", 'l', 0, G_OPTION_ARG_STRING, &(session_filename),
++ N_("Load the given session file"), N_("FILE") },
++ { G_OPTION_REMAINING, 0, 0, G_OPTION_ARG_FILENAME_ARRAY, &remaining_args,
++ "Special option that collects any remaining arguments for us" },
++ { NULL }
++};
++#endif
+
+ typedef enum {
+ MISSING_GLADE,
+@@ -75,8 +86,10 @@
+ int main( int argc, char *argv[] )
+ {
+ GnomeProgram *program;
++ const gchar** start_files;
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ poptContext ctx;
+- const gchar** start_files;
++#endif
+ const gchar *icon;
+
+ gchar *dotdir;
+@@ -88,11 +101,21 @@
+ bind_textdomain_codeset( GETTEXT_PACKAGE, "UTF-8" );
+ textdomain( GETTEXT_PACKAGE );
+ #endif
++
++#ifdef GNOME_PARAM_GOPTION_CONTEXT
++ GOptionContext *option_context = g_option_context_new("screem");
++ g_option_context_add_main_entries(option_context, option_entries, NULL);
++#endif
++
+ program = gnome_program_init( PACKAGE, VERSION,
+ LIBGNOMEUI_MODULE,
+ argc, argv,
+ GNOME_PROGRAM_STANDARD_PROPERTIES,
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ GNOME_PARAM_POPT_TABLE, options,
++#else
++ GNOME_PARAM_GOPTION_CONTEXT, option_context,
++#endif
+ GNOME_PARAM_APP_DATADIR, DATADIR,
+ LIBGNOMEUI_PARAM_DEFAULT_ICON,
+ DATADIR"/pixmaps/screem.png",
+@@ -105,10 +128,14 @@
+ icon = DATADIR"/pixmaps/screem.png";
+ gtk_window_set_default_icon_from_file( icon, NULL );
+
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ /* parse arguments */
+ g_object_get( G_OBJECT( program ),
+ GNOME_PARAM_POPT_CONTEXT, &ctx, NULL );
+ start_files = parse_args( ctx, argc, argv );
++#else
++ start_files = remaining_args;
++#endif
+
+ gnome_vfs_init();
+ gnome_authentication_manager_init();
+@@ -160,6 +187,7 @@
+ return FALSE;
+ }
+
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ static const gchar **parse_args( poptContext ctx, int argc, char *argv[] )
+ {
+ const gchar** start_files;
+@@ -169,6 +197,7 @@
+
+ return start_files;
+ }
++#endif
+
+ static void screem_main_missing( MissingType type )
+ {
diff --git a/app-editors/screem/screem-0.16.1-r1.ebuild b/app-editors/screem/screem-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..c23bc8376859
--- /dev/null
+++ b/app-editors/screem/screem-0.16.1-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/screem/screem-0.16.1-r1.ebuild,v 1.1 2009/03/22 02:20:28 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="SCREEM is an integrated environment for the creation and maintenance of websites and pages"
+HOMEPAGE="http://www.screem.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dbus spell nls"
+
+# glib raised to 2.10 for goption
+RDEPEND=">=dev-libs/glib-2.10.0
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/libxml2-2.4.3
+ >=gnome-base/libglade-2.3
+ >=gnome-base/gconf-2.2
+ >=gnome-base/gnome-vfs-2.8.3
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.6
+ =gnome-extra/gtkhtml-2*
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ =x11-libs/gtksourceview-1*
+ >=dev-libs/libcroco-0.6.0
+ >=gnome-base/gnome-menus-2.9.2
+ dbus? ( >=sys-apps/dbus-1.0.2 )
+ spell? ( >=app-text/enchant-1.1.6 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-0.1.1
+ >=dev-util/intltool-0.29
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ >=x11-misc/shared-mime-info-0.3.14"
+
+DOCS="AUTHORS BUGS COPYING-DOCS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mime
+ --disable-update-desktop
+ --disable-schemas-install
+ $(use_enable nls)
+ $(use_enable dbus)
+ $(use_enable spell enchant)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove deprecation warnings, bug #127486
+ epatch "${FILESDIR}/${P}-deprecated.patch"
+
+ # Make add tag file feature work, bug #256611
+ epatch "${FILESDIR}/${P}-add-tag-file.patch"
+
+ # About dialog does not close, bug #256803
+ epatch "${FILESDIR}/${P}-fix-about-dialog.patch"
+
+ # Fix error in exit due to old dbus calls, bug #255750
+ epatch "${FILESDIR}/${P}-dbus-closing.patch"
+
+ # Port to GOption
+ epatch "${FILESDIR}/${P}-goption.patch"
+
+ # Fix tests
+ echo "gdl/layout.glade" >> po/POTFILES.in
+ echo "src/screem-debug-console.c" >> po/POTFILES.in
+
+ strip-linguas -i "${S}/po"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Install translations, bug #256611
+ if use nls; then
+ cd po
+ for loc in ${LINGUAS}; do
+ msgfmt ${loc}.po --output-file ${loc}.gmo || die "fail to build ${loc}.po"
+ domo ${loc}.gmo || die "domo ${loc}.gmo"
+ done
+ fi
+}