summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-10-04 20:37:58 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-10-04 20:37:58 +0000
commita52879419b80565e08ee388caacd4cf42e8ce369 (patch)
treeaee52c331b7ad8d0f1148ca083a500fff4ecce99 /app-editors/qxmledit
parentReplace the tslib build patch with a set of new patches in order to fix bug #... (diff)
downloadgentoo-2-a52879419b80565e08ee388caacd4cf42e8ce369.tar.gz
gentoo-2-a52879419b80565e08ee388caacd4cf42e8ce369.tar.bz2
gentoo-2-a52879419b80565e08ee388caacd4cf42e8ce369.zip
Add myself as co-maintainer and version bump
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog8
-rw-r--r--app-editors/qxmledit/metadata.xml20
-rw-r--r--app-editors/qxmledit/qxmledit-0.4.9.ebuild47
3 files changed, 67 insertions, 8 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index acd6e28215a6..4a5ca773b892 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.10 2010/07/02 08:00:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.11 2010/10/04 20:37:58 chiiph Exp $
+
+*qxmledit-0.4.9 (04 Oct 2010)
+
+ 04 Oct 2010; Tomas Touceda <chiiph@gentoo.org> +qxmledit-0.4.9.ebuild,
+ metadata.xml:
+ Add myself as co-maintainer and version bump
02 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
-qxmledit-0.3.0-r1.ebuild, -qxmledit-0.4.3.ebuild:
diff --git a/app-editors/qxmledit/metadata.xml b/app-editors/qxmledit/metadata.xml
index d5f9562e2df2..e37f1be95756 100644
--- a/app-editors/qxmledit/metadata.xml
+++ b/app-editors/qxmledit/metadata.xml
@@ -1,12 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
-<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-</maintainer>
-<longdescription lang="en">
-</longdescription>
+ <herd>qt</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <maintainer>
+ <email>chiiph@gentoo.org</email>
+ <name>Tomas Touceda</name>
+ </maintainer>
+ <longdescription lang="en">
+ QXmlEdit is a simple XML editor written in qt4, it is not a complete and
+ full featured editor.
+ </longdescription>
</pkgmetadata>
diff --git a/app-editors/qxmledit/qxmledit-0.4.9.ebuild b/app-editors/qxmledit/qxmledit-0.4.9.ebuild
new file mode 100644
index 000000000000..53a84b6fb370
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.4.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.4.9.ebuild,v 1.1 2010/10/04 20:37:58 chiiph Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+MY_P="QXmlEdit-${PV}-sources"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src/"
+
+DOCS="AUTHORS NEWS README TODO"
+DOCSDIR="${WORKDIR}/${P}/"
+
+src_prepare(){
+ # fix installation path
+ sed -i "/^target.path/ s/\/opt\/${PN}/\/usr\/bin/" QXmlEdit.pro || \
+ die "failed to fix installation path"
+ # fix translations
+ sed -i "/^translations.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix translations"
+ # fix snippets and style paths
+ sed -i "/^snippets.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix snippets"
+ sed -i "/^styles.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
+ die "failed to fix style path"
+ qt4-r2_src_prepare
+}
+
+src_install(){
+ qt4-r2_src_install
+ newicon "${S}"/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor;"
+}