summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-12 13:03:29 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-12 13:03:29 +0000
commited91d797d9604e37ba25852a8e0a5fec87f602e8 (patch)
tree0b52e94f41cc464ffd1551a73235be9ef07e0007 /app-editors/nvu
parentStable on sparc wrt #165742 (diff)
downloadgentoo-2-ed91d797d9604e37ba25852a8e0a5fec87f602e8.tar.gz
gentoo-2-ed91d797d9604e37ba25852a8e0a5fec87f602e8.tar.bz2
gentoo-2-ed91d797d9604e37ba25852a8e0a5fec87f602e8.zip
Add patch to make nvu compile with >freetype-2.1, bug 166401 and remove unneeded version
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-editors/nvu')
-rw-r--r--app-editors/nvu/ChangeLog7
-rw-r--r--app-editors/nvu/files/1.0/nvu-1.0-const.patch58
-rw-r--r--app-editors/nvu/files/digest-nvu-1.0-r23
-rw-r--r--app-editors/nvu/nvu-1.0-r2.ebuild88
-rw-r--r--app-editors/nvu/nvu-1.0-r4.ebuild7
5 files changed, 70 insertions, 93 deletions
diff --git a/app-editors/nvu/ChangeLog b/app-editors/nvu/ChangeLog
index c15b7a40e58f..db9c5255e68a 100644
--- a/app-editors/nvu/ChangeLog
+++ b/app-editors/nvu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nvu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/ChangeLog,v 1.25 2007/01/24 02:48:25 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/ChangeLog,v 1.26 2007/02/12 13:03:29 armin76 Exp $
+
+ 12 Feb 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/1.0/nvu-1.0-const.patch, -nvu-1.0-r2.ebuild, nvu-1.0-r4.ebuild:
+ Add patch to make nvu compile with >freetype-2.1, bug 166401 and remove
+ unneeded version
24 Jan 2007; Marius Mauch <genone@gentoo.org> nvu-1.0-r2.ebuild,
nvu-1.0-r4.ebuild:
diff --git a/app-editors/nvu/files/1.0/nvu-1.0-const.patch b/app-editors/nvu/files/1.0/nvu-1.0-const.patch
new file mode 100644
index 000000000000..c4e8226c1987
--- /dev/null
+++ b/app-editors/nvu/files/1.0/nvu-1.0-const.patch
@@ -0,0 +1,58 @@
+--- gfx/src/ps/nsType1.cpp 2002-12-11 08:24:47.000000000 +0200
++++ gfx/src/ps/nsType1.cpp 2006-10-11 17:17:11.000000000 +0300
+@@ -81,8 +81,8 @@
+ int wmode;
+ } FT2PT1_info;
+
+-static int cubicto(FT_Vector *aControlPt1, FT_Vector *aControlPt2,
+- FT_Vector *aEndPt, void *aClosure);
++static int cubicto(const FT_Vector *aControlPt1, const FT_Vector *aControlPt2,
++ const FT_Vector *aEndPt, void *aClosure);
+ static int Type1CharStringCommand(unsigned char **aBufPtrPtr, int aCmd);
+ static int Type1EncodeCharStringInt(unsigned char **aBufPtrPtr, int aValue);
+
+@@ -173,7 +173,7 @@
+ }
+
+ static PRBool
+-sideWidthAndBearing(FT_Vector *aEndPt, FT2PT1_info *aFti)
++sideWidthAndBearing(const FT_Vector *aEndPt, FT2PT1_info *aFti)
+ {
+ int aw = 0;
+ int ah = 0;
+@@ -216,7 +216,7 @@
+ }
+
+ static int
+-moveto(FT_Vector *aEndPt, void *aClosure)
++moveto(const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *fti = (FT2PT1_info *)aClosure;
+ FT_UShort upm = fti->face->units_per_EM;
+@@ -253,7 +253,7 @@
+ }
+
+ static int
+-lineto(FT_Vector *aEndPt, void *aClosure)
++lineto(const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *fti = (FT2PT1_info *)aClosure;
+ FT_UShort upm = fti->face->units_per_EM;
+@@ -279,7 +279,7 @@
+ }
+
+ static int
+-conicto(FT_Vector *aControlPt, FT_Vector *aEndPt, void *aClosure)
++conicto(const FT_Vector *aControlPt, const FT_Vector *aEndPt, void *aClosure)
+ {
+ FT2PT1_info *ftinfo = (FT2PT1_info *)aClosure;
+ FT_UShort upm = ftinfo->face->units_per_EM;
+@@ -311,7 +311,7 @@
+ }
+
+ static int
+-cubicto(FT_Vector *aControlPt1, FT_Vector *aControlPt2, FT_Vector *aEndPt,
++cubicto(const FT_Vector *aControlPt1, const FT_Vector *aControlPt2, const FT_Vector *aEndPt,
+ void *aClosure)
+ {
+ FT2PT1_info *ftinfo = (FT2PT1_info *)aClosure;
diff --git a/app-editors/nvu/files/digest-nvu-1.0-r2 b/app-editors/nvu/files/digest-nvu-1.0-r2
deleted file mode 100644
index 9e9bf40be61d..000000000000
--- a/app-editors/nvu/files/digest-nvu-1.0-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ae0f7c85e230ce8a90dc438b53be06e6 nvu-1.0-sources.tar.bz2 29687976
-RMD160 6d6fdb747d79e8602a4757e8eff8bbb21db6df8c nvu-1.0-sources.tar.bz2 29687976
-SHA256 9ec892e352c3596a4f734a885c6e085028574714cf0d44c2dac32b0d89b4b630 nvu-1.0-sources.tar.bz2 29687976
diff --git a/app-editors/nvu/nvu-1.0-r2.ebuild b/app-editors/nvu/nvu-1.0-r2.ebuild
deleted file mode 100644
index 0db1acf6fd67..000000000000
--- a/app-editors/nvu/nvu-1.0-r2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-1.0-r2.ebuild,v 1.5 2007/01/24 02:48:25 genone Exp $
-
-inherit eutils mozconfig flag-o-matic multilib
-
-DESCRIPTION="A WYSIWYG web editor for linux similiar to Dreamweaver"
-HOMEPAGE="http://www.nvu.com/"
-SRC_URI="http://cvs.nvu.com/download/${P}-sources.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE=""
-DEPEND="|| ( x11-proto/printproto virtual/x11 )
- sys-apps/gawk
- dev-lang/perl
- >=media-libs/freetype-2.1.9-r1"
-
-S=${WORKDIR}/mozilla
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Fix those darn directories! Make something more "standard"
- # That can extend to future versions with much more ease. - Chris
- epatch ${FILESDIR}/1.0/nvu-0.50-dir.patch || die "failed to apply dir. patch"
- epatch ${FILESDIR}/1.0/nvu-0.50-freetype-compile.patch || die "failed to patch for freetype"
- epatch ${FILESDIR}/1.0/${P}-gcc4-1.patch || die "failed to apply gcc-4 patch"
-
- # I had to manually edit the mozconfig.linux file as it
- # has some quirks... just copy the darn thing over :) - Chris
- # cp ${FILESDIR}/mozconfig ${S}/.mozconfig
- # remove --enable-optimize and let the code below
- # add the appropriate one - basic
- # Also set mozilla-five-home (and libdir) below - herbs
- grep -v 'enable-optimize\|mozilla-five-home' \
- ${FILESDIR}/1.0/mozconfig-1.0 > .mozconfig
-
- # Set the lib directory
- echo "ac_add_options --libdir=/usr/$(get_libdir)" >> .mozconfig
- echo "ac_add_options --with-default-mozilla-five-home=/usr/$(get_libdir)/nvu" >> .mozconfig
-
- # copied from mozilla.eclass (modified slightly),
- # otherwise it defaults to -O which crashes on startup for me - basic
- # Set optimization level based on CFLAGS
- if is-flag -O0; then
- echo 'ac_add_options --enable-optimize=-O0' >> .mozconfig
- elif is-flag -O1; then
- echo 'ac_add_options --enable-optimize=-O1' >> .mozconfig
- else
- # mozilla fallback
- echo 'ac_add_options --enable-optimize=-O2' >> .mozconfig
- fi
-}
-
-src_compile() {
- # The build system is a weeee bit sensitive to naughty -O flags.
- # filter them out and let the build system figure out what
- # won't let it die :) - Chris
- filter-flags '-O*'
- # epatch ${FILESDIR}/nvu-0.80-mozconfig.patch
-
- make -f client.mk build_all || die "Make failed"
-}
-
-src_install() {
-
- # patch the final nvu binary to workaround bug #67658
- epatch ${FILESDIR}/1.0/nvu-0.50-nvu.patch
-
- make -f client.mk DESTDIR=${D} install || die
-
- #menu entry for gnome/kde
- insinto /usr/share/applications
- sed -e "s:/usr/lib/nvu:/usr/$(get_libdir)/nvu:" \
- ${FILESDIR}/1.0/nvu.desktop > ${T}/nvu.desktop
- doins ${T}/nvu.desktop
-}
-
-pkg_postinst() {
- elog "If you choose to setup the webbrowser feature to execute urls"
- elog "under the HELP section please refer to"
- elog "http://www.nvu.com/Building_From_Source.php#tipsandhints ."
- elog "Make sure you follow the instructions to the letter if you have"
- elog "any problems email me at anarchy@gentoo.org I will be more then"
- elog "happy to assist you. DO NOT file a bug report on this issue."
-}
diff --git a/app-editors/nvu/nvu-1.0-r4.ebuild b/app-editors/nvu/nvu-1.0-r4.ebuild
index 585a8b0c4747..31b2ff66da50 100644
--- a/app-editors/nvu/nvu-1.0-r4.ebuild
+++ b/app-editors/nvu/nvu-1.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-1.0-r4.ebuild,v 1.8 2007/01/24 02:48:25 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvu/nvu-1.0-r4.ebuild,v 1.9 2007/02/12 13:03:29 armin76 Exp $
inherit eutils mozconfig flag-o-matic multilib
@@ -31,6 +31,11 @@ src_unpack() {
epatch "${FILESDIR}/010_glibc-2.4.patch" || die "failed to apply glibc-2.4 patch"
epatch ${FILESDIR}/1.0/mozilla-1.7.13-as-needed.patch || die "failed to apply as-needed patch"
+ # >freetype-2.1* compile patch #166401
+ if has_version '>=media-libs/freetype-2.2*'; then
+ epatch "${FILESDIR}/1.0/${P}-const.patch"
+ fi
+
# I had to manually edit the mozconfig.linux file as it
# has some quirks... just copy the darn thing over :) - Chris
# cp ${FILESDIR}/mozconfig ${S}/.mozconfig