summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-09-17 11:09:37 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-09-17 11:09:37 +0000
commit4e3d4f6a6819d021b86dd403b17edd51d22c4aa2 (patch)
treec2513a8ed034abce4087b38f350bb23c6eecbfc7 /app-editors/nvi
parentRemoved other keywords than ~s390 from 1.5.0 because generation 2 eclasses sh... (diff)
downloadgentoo-2-4e3d4f6a6819d021b86dd403b17edd51d22c4aa2.tar.gz
gentoo-2-4e3d4f6a6819d021b86dd403b17edd51d22c4aa2.tar.bz2
gentoo-2-4e3d4f6a6819d021b86dd403b17edd51d22c4aa2.zip
Include <db.h> when checking for db_create
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'app-editors/nvi')
-rw-r--r--app-editors/nvi/ChangeLog6
-rw-r--r--app-editors/nvi/files/nvi-1.81.5-db4.patch134
-rw-r--r--app-editors/nvi/nvi-1.81.5-r3.ebuild3
3 files changed, 141 insertions, 2 deletions
diff --git a/app-editors/nvi/ChangeLog b/app-editors/nvi/ChangeLog
index 0e2419505494..cbe3ea30d899 100644
--- a/app-editors/nvi/ChangeLog
+++ b/app-editors/nvi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/nvi
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.26 2006/07/24 08:47:27 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.27 2006/09/17 11:09:37 truedfx Exp $
+
+ 17 Sep 2006; Harald van Dijk <truedfx@gentoo.org>
+ files/nvi-1.81.5-db4.patch, nvi-1.81.5-r3.ebuild:
+ Include <db.h> when checking for db_create
*nvi-1.81.5-r3 (24 Jul 2006)
diff --git a/app-editors/nvi/files/nvi-1.81.5-db4.patch b/app-editors/nvi/files/nvi-1.81.5-db4.patch
index 38248b6eed39..d6191cb501f2 100644
--- a/app-editors/nvi/files/nvi-1.81.5-db4.patch
+++ b/app-editors/nvi/files/nvi-1.81.5-db4.patch
@@ -1,3 +1,137 @@
+--- nvi-1.81.5/dist/configure.in
++++ nvi-1.81.5/dist/configure.in
+@@ -922,11 +922,14 @@
+ CFLAGS="-I$with_db3/include $CFLAGS"
+ fi;
+
++saveLIBS="$LIBS"
++LIBS="$LIBS -ldb"
+-AC_CHECK_LIB(db, db_create,
++AC_TRY_LINK([#include <db.h>], [db_create(0, 0, 0)],
+ [vi_cv_dbfatal="no"], [vi_cv_dbfatal="yes"])
+ if test "$vi_cv_dbfatal" = "yes"; then
+- AC_MSG_ERROR([Need DB 3.])
++ AC_MSG_ERROR([Need DB 4.])
+ fi
++LIBS="$saveLIBS"
+
+ LDFLAGS="$saveLDFLAGS"
+
+--- nvi-1.81.5/dist/configure
++++ nvi-1.81.5/dist/configure
+@@ -10679,56 +10679,36 @@
+ CFLAGS="-I$with_db3/include $CFLAGS"
+ fi;
+
+-echo $ac_n "checking for db_create in -ldb""... $ac_c" 1>&6
+-echo "configure:10684: checking for db_create in -ldb" >&5
+-ac_lib_var=`echo db'_'db_create | sed 'y%./+-%__p_%'`
+-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+- echo $ac_n "(cached) $ac_c" 1>&6
+-else
+- ac_save_LIBS="$LIBS"
+-LIBS="-ldb $LIBS"
++saveLIBS="$LIBS"
++LIBS="$LIBS -ldb"
+ cat > conftest.$ac_ext <<EOF
+-#line 10692 "configure"
++#line 10686 "configure"
+ #include "confdefs.h"
+-/* Override any gcc2 internal prototype to avoid an error. */
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char db_create();
+-
++#include <db.h>
+ int main() {
+-db_create()
++db_create(0, 0, 0)
+ ; return 0; }
+ EOF
+-if { (eval echo configure:10703: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
++if { (eval echo configure:10693: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+- eval "ac_cv_lib_$ac_lib_var=yes"
++ vi_cv_dbfatal="no"
+ else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+- eval "ac_cv_lib_$ac_lib_var=no"
++ vi_cv_dbfatal="yes"
+ fi
+ rm -f conftest*
+-LIBS="$ac_save_LIBS"
+-
+-fi
+-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+- echo "$ac_t""yes" 1>&6
+- vi_cv_dbfatal="no"
+-else
+- echo "$ac_t""no" 1>&6
+-vi_cv_dbfatal="yes"
+-fi
+-
+ if test "$vi_cv_dbfatal" = "yes"; then
+- { echo "configure: error: Need DB 3." 1>&2; exit 1; }
++ { echo "configure: error: Need DB 4." 1>&2; exit 1; }
+ fi
++LIBS="$saveLIBS"
+
+ LDFLAGS="$saveLDFLAGS"
+
+
+ echo $ac_n "checking if --enable-dynamic-loading option specified""... $ac_c" 1>&6
+-echo "configure:10732: checking if --enable-dynamic-loading option specified" >&5
++echo "configure:10712: checking if --enable-dynamic-loading option specified" >&5
+ # Check whether --enable-dynamic-loading or --disable-dynamic-loading was given.
+ if test "${enable_dynamic_loading+set}" = set; then
+ enableval="$enable_dynamic_loading"
+@@ -10740,7 +10720,7 @@
+ echo "$ac_t""$vi_cv_dl" 1>&6
+ if test "$vi_cv_dl" = yes; then
+ echo $ac_n "checking for dlopen in -ldl""... $ac_c" 1>&6
+-echo "configure:10744: checking for dlopen in -ldl" >&5
++echo "configure:10724: checking for dlopen in -ldl" >&5
+ ac_lib_var=`echo dl'_'dlopen | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+@@ -10748,7 +10728,7 @@
+ ac_save_LIBS="$LIBS"
+ LIBS="-ldl $LIBS"
+ cat > conftest.$ac_ext <<EOF
+-#line 10752 "configure"
++#line 10732 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+@@ -10759,7 +10739,7 @@
+ dlopen()
+ ; return 0; }
+ EOF
+-if { (eval echo configure:10763: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
++if { (eval echo configure:10743: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+ else
+@@ -10789,7 +10769,7 @@
+ # Extract the first word of "libdb-3.so", so it can be a program name with args.
+ set dummy libdb-3.so; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+-echo "configure:10793: checking for $ac_word" >&5
++echo "configure:10773: checking for $ac_word" >&5
+ if eval "test \"`echo '$''{'ac_cv_path_vi_cv_path_db3'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -10843,7 +10823,7 @@
+
+
+ echo $ac_n "checking if --disable-re option specified""... $ac_c" 1>&6
+-echo "configure:10847: checking if --disable-re option specified" >&5
++echo "configure:10827: checking if --disable-re option specified" >&5
+ # Check whether --enable-re or --disable-re was given.
+ if test "${enable_re+set}" = set; then
+ enableval="$enable_re"
--- nvi-1.81.5/common/exf.c
+++ nvi-1.81.5/common/exf.c
@@ -282,7 +282,7 @@
diff --git a/app-editors/nvi/nvi-1.81.5-r3.ebuild b/app-editors/nvi/nvi-1.81.5-r3.ebuild
index ab2c3f11f2e0..5fa5f262a8fd 100644
--- a/app-editors/nvi/nvi-1.81.5-r3.ebuild
+++ b/app-editors/nvi/nvi-1.81.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r3.ebuild,v 1.1 2006/07/24 08:47:27 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r3.ebuild,v 1.2 2006/09/17 11:09:37 truedfx Exp $
inherit eutils
@@ -27,6 +27,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-tcsetattr.patch
epatch "${FILESDIR}"/${P}-gcc4.patch
epatch "${FILESDIR}"/${P}-db4.patch
+ touch "${S}"/dist/{configure,aclocal.m4,Makefile.in,stamp-h.in}
}
src_compile() {