summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-16 14:44:25 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-16 14:44:25 +0000
commit682061c8ef1e7edd9b9f1192baa5cb950fd25630 (patch)
treefe49c5f78b4a6078c65fdb5e15d38f4e26621b2f /app-editors/nano
parentDropping ~ppc keyword due to new tlslite dependency (diff)
downloadgentoo-2-682061c8ef1e7edd9b9f1192baa5cb950fd25630.tar.gz
gentoo-2-682061c8ef1e7edd9b9f1192baa5cb950fd25630.tar.bz2
gentoo-2-682061c8ef1e7edd9b9f1192baa5cb950fd25630.zip
old
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/nano-2.1.0-disable-speller.patch19
-rw-r--r--app-editors/nano/nano-2.1.0.ebuild80
-rw-r--r--app-editors/nano/nano-2.1.1-r1.ebuild84
-rw-r--r--app-editors/nano/nano-2.1.1.ebuild76
4 files changed, 0 insertions, 259 deletions
diff --git a/app-editors/nano/files/nano-2.1.0-disable-speller.patch b/app-editors/nano/files/nano-2.1.0-disable-speller.patch
deleted file mode 100644
index ed727d93b090..000000000000
--- a/app-editors/nano/files/nano-2.1.0-disable-speller.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-fix building with --disable-speller
-
-http://bugs.gentoo.org/221219
-https://savannah.gnu.org/bugs/index.php?23227
-
---- src/global.c
-+++ src/global.c
-@@ -1033,9 +1033,11 @@ void shortcut_init(bool unjustify)
- add_to_sclist(MMAIN, "^C", do_cursorpos_void, 0, TRUE);
- add_to_sclist(MMAIN, "F11", do_cursorpos_void, 0, TRUE);
- #ifndef NANO_TINY
-+#ifndef DISABLE_SPELLER
- add_to_sclist(MMAIN, "^T", do_spell, 0, TRUE);
- add_to_sclist(MMAIN, "F12", do_spell, 0, TRUE);
- #endif
-+#endif
- add_to_sclist(MMAIN, "^_", do_gotolinecolumn_void, 0, TRUE);
- add_to_sclist(MMAIN, "F13", do_gotolinecolumn_void, 0, TRUE);
- add_to_sclist(MMAIN, "M-G", do_gotolinecolumn_void, 0, TRUE);
diff --git a/app-editors/nano/nano-2.1.0.ebuild b/app-editors/nano/nano-2.1.0.ebuild
deleted file mode 100644
index 9db3f07514a6..000000000000
--- a/app-editors/nano/nano-2.1.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.0.ebuild,v 1.4 2008/05/10 21:38:29 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-disable-speller.patch #221219
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- insinto /usr/share/nano
- doins "${FILESDIR}"/*.nanorc || die
- echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.1-r1.ebuild b/app-editors/nano/nano-2.1.1-r1.ebuild
deleted file mode 100644
index 71aca52badfb..000000000000
--- a/app-editors/nano/nano-2.1.1-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1-r1.ebuild,v 1.4 2008/06/16 03:39:15 josejx Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.1.0-disable-speller.patch #221219
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-
- insinto /usr/share/nano
- local f
- for f in "${FILESDIR}"/*.nanorc ; do
- [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
- doins "${f}" || die
- echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
- done
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}
diff --git a/app-editors/nano/nano-2.1.1.ebuild b/app-editors/nano/nano-2.1.1.ebuild
deleted file mode 100644
index 06f3cae9a418..000000000000
--- a/app-editors/nano/nano-2.1.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1.ebuild,v 1.6 2008/05/12 13:48:13 corsair Exp $
-
-inherit eutils
-if [[ ${PV} == "9999" ]] ; then
- ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
- ECVS_MODULE="nano"
- ECVS_AUTH="pserver"
- ECVS_USER="anonymous"
- inherit cvs
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha ~amd64 arm ~hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
- nls? ( sys-devel/gettext )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.1.0-disable-speller.patch #221219
- if [[ ! -e configure ]] ; then
- ./autogen.sh || die "autogen failed"
- fi
-}
-
-src_compile() {
- local myconf=""
- use ncurses \
- && myconf="--without-slang" \
- || myconf="${myconf} $(use_with slang)"
-
- econf \
- --bindir=/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- ${myconf} \
- || die "configure failed"
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml *.html
- insinto /etc
- newins doc/nanorc.sample nanorc
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
- elog "More helpful info about nano, visit the GDP page:"
- elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}