summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit85bf0780b54b0388919f656d5d2475ac8dfbfc7d (patch)
tree5462eacfdcae74754e7ca88e02f792ab14b385f0 /app-editors/jed
parentversion bump, first gpg-signed package ;) (Manifest recommit) (diff)
downloadgentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.gz
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.bz2
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/jed')
-rw-r--r--app-editors/jed/jed-0.99.16-r1.ebuild29
-rw-r--r--app-editors/jed/jed-0.99.16-r2.ebuild29
2 files changed, 24 insertions, 34 deletions
diff --git a/app-editors/jed/jed-0.99.16-r1.ebuild b/app-editors/jed/jed-0.99.16-r1.ebuild
index a7a63471d1ab..ce34134f4e1f 100644
--- a/app-editors/jed/jed-0.99.16-r1.ebuild
+++ b/app-editors/jed/jed-0.99.16-r1.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r1.ebuild,v 1.13 2004/04/20 09:00:17 liquidx Exp $
-
-IUSE="X gpm truetype"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r1.ebuild,v 1.14 2004/05/31 22:12:03 vapier Exp $
P0=${PN}-0.99-16
S=${WORKDIR}/${P0}
DESCRIPTION="Console S-Lang-based editor"
-SRC_URI="ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v0.99/${P0}.tar.bz2"
HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v0.99/${P0}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="X gpm truetype"
DEPEND=">=sys-libs/slang-1.4.5
>=sys-apps/sed-4
@@ -16,13 +19,8 @@ DEPEND=">=sys-libs/slang-1.4.5
gpm? ( sys-libs/gpm )
X? ( truetype? ( virtual/xft
>=media-libs/freetype-2.0 ) )"
-
PROVIDE="virtual/editor"
-SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
-LICENSE="GPL-2"
-
src_compile() {
export JED_ROOT=/usr/share/jed
@@ -31,7 +29,7 @@ src_compile() {
--bindir=/usr/bin \
--mandir=/usr/share/man || die
- if [ -n "`use gpm`" ] ; then
+ if use gpm ; then
cd src
sed -i -e 's/#MOUSEFLAGS/MOUSEFLAGS/' \
-e 's/#MOUSELIB/MOUSELIB/' \
@@ -41,7 +39,7 @@ src_compile() {
cd ${S}
fi
- if [ -n "`use X`" -a -n "`use truetype`" ]; then
+ if use X && use truetype ; then
cd src
sed -i -e 's/#XRENDERFONTLIBS/XRENDERFONTLIBS/' Makefile
sed -i -e 's/^CONFIG_H = config.h/xterm_C_FLAGS = `freetype-config --cflags`\nCONFIG_H = config.h/' Makefile
@@ -53,20 +51,19 @@ src_compile() {
emake || die
- if [ -n "`use X`" ] ; then
+ if use X ; then
emake xjed || die
fi
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd doc
cp README AUTHORS
cd ${S}
- dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README \
- doc/AUTHORS doc/manual/jed.tex
+ dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
cd ${S}/info
rm info.info
@@ -86,5 +83,3 @@ src_install () {
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}
-
-
diff --git a/app-editors/jed/jed-0.99.16-r2.ebuild b/app-editors/jed/jed-0.99.16-r2.ebuild
index e17f44b00fdf..995c71205d93 100644
--- a/app-editors/jed/jed-0.99.16-r2.ebuild
+++ b/app-editors/jed/jed-0.99.16-r2.ebuild
@@ -1,16 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r2.ebuild,v 1.4 2004/05/03 15:47:56 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.16-r2.ebuild,v 1.5 2004/05/31 22:12:03 vapier Exp $
inherit eutils
-IUSE="X gpm truetype"
-
P0=${PN}-0.99-16
S=${WORKDIR}/${P0}
DESCRIPTION="Console S-Lang-based editor"
-SRC_URI="ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v0.99/${P0}.tar.bz2"
HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v0.99/${P0}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~amd64"
+IUSE="X gpm truetype"
DEPEND=">=sys-libs/slang-1.4.5
>=sys-apps/sed-4
@@ -18,13 +21,8 @@ DEPEND=">=sys-libs/slang-1.4.5
gpm? ( sys-libs/gpm )
X? ( truetype? ( virtual/xft
>=media-libs/freetype-2.0 ) )"
-
PROVIDE="virtual/editor"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~amd64"
-LICENSE="GPL-2"
-
src_unpack() {
unpack ${A}
cd ${S}; epatch ${FILESDIR}/${P}-jed.info.patch
@@ -38,7 +36,7 @@ src_compile() {
--bindir=/usr/bin \
--mandir=/usr/share/man || die
- if [ -n "`use gpm`" ] ; then
+ if use gpm ; then
cd src
sed -i -e 's/#MOUSEFLAGS/MOUSEFLAGS/' \
-e 's/#MOUSELIB/MOUSELIB/' \
@@ -48,7 +46,7 @@ src_compile() {
cd ${S}
fi
- if [ -n "`use X`" -a -n "`use truetype`" ]; then
+ if use X && use truetype ; then
cd src
sed -i -e 's/#XRENDERFONTLIBS/XRENDERFONTLIBS/' Makefile
sed -i -e 's/^CONFIG_H = config.h/xterm_C_FLAGS = `freetype-config --cflags`\nCONFIG_H = config.h/' Makefile
@@ -60,20 +58,19 @@ src_compile() {
emake || die
- if [ -n "`use X`" ] ; then
+ if use X ; then
emake xjed || die
fi
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd doc
cp README AUTHORS
cd ${S}
- dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README \
- doc/AUTHORS doc/manual/jed.tex
+ dodoc INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
cd ${S}/info
rm info.info
@@ -93,5 +90,3 @@ src_install () {
rm -rf usr/share/jed/info
# can't rm usr/share/jed/doc -- used internally by jed/xjed
}
-
-