summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-01-23 23:17:48 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-01-23 23:17:48 +0000
commitb7067277f2a674efcb6d0ef7af9e07168af834ae (patch)
tree278d743c34dad78c5ab99c5c8b0716808abfd3a1 /app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
parentversion bump (diff)
downloadgentoo-2-b7067277f2a674efcb6d0ef7af9e07168af834ae.tar.gz
gentoo-2-b7067277f2a674efcb6d0ef7af9e07168af834ae.tar.bz2
gentoo-2-b7067277f2a674efcb6d0ef7af9e07168af834ae.zip
Pin dependencies to appropriate slots and make use of python eclass for proper mutliple python slots support.
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild')
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
index 0f8f537fdd74..76e28419e73c 100644
--- a/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild,v 1.2 2010/11/01 12:30:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-2.30.0.ebuild,v 1.3 2011/01/23 23:17:48 eva Exp $
EAPI="2"
GCONF_DEBUG="no"
+PYTHON_DEPEND="session? 2"
+PYTHON_USE_WITH_OPT="session? xml"
inherit gnome2 multilib python eutils
@@ -16,19 +18,16 @@ SLOT="0"
IUSE="bookmarks +bracketcompletion charmap colorpicker +drawspaces +joinlines python +session showtabbar smartspaces terminal"
-RDEPEND=">=x11-libs/gtk+-2.14
+RDEPEND=">=x11-libs/gtk+-2.14:2
gnome-base/gconf
- >=x11-libs/gtksourceview-2.6
+ >=x11-libs/gtksourceview-2.6:2.0
>=app-editors/gedit-2.29.3[python]
- >=dev-python/pygtk-2.14
+ >=dev-python/pygtk-2.14:2
charmap? (
>=gnome-extra/gucharmap-2.24.3
)
- session? (
- dev-lang/python[xml]
- )
python? (
- >=dev-python/pygtksourceview-2.2.0
+ >=dev-python/pygtksourceview-2.2:2
)
terminal? (
dev-python/gconf-python
@@ -55,6 +54,8 @@ pkg_setup() {
--disable-dependency-tracking
--with-plugins=${myplugins}
$(use_enable python)"
+
+ python_set_active_version 2
}
src_prepare() {