summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-01-28 10:54:33 +0000
committerUlrich Müller <ulm@gentoo.org>2012-01-28 10:54:33 +0000
commitd58433f8cb9299cb3f6b1e2125851273167d468e (patch)
tree0aa8397f1a98972e38d4c191cd3da0715c049fef /app-editors/emacs
parentVersion bump. Add ruby19. Stop trying to run the cucumber features since thei... (diff)
downloadgentoo-2-d58433f8cb9299cb3f6b1e2125851273167d468e.tar.gz
gentoo-2-d58433f8cb9299cb3f6b1e2125851273167d468e.tar.bz2
gentoo-2-d58433f8cb9299cb3f6b1e2125851273167d468e.zip
USE="athena Xaw3d" is a valid combination, so don't warn.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-23.3-r4.ebuild19
-rw-r--r--app-editors/emacs/emacs-23.4_rc1.ebuild19
3 files changed, 23 insertions, 21 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index cd283b19371d..7102658f31fc 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.470 2012/01/19 19:15:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.471 2012/01/28 10:54:33 ulm Exp $
+
+ 28 Jan 2012; Ulrich Müller <ulm@gentoo.org> emacs-23.3-r4.ebuild,
+ emacs-23.4_rc1.ebuild:
+ USE="athena Xaw3d" is a valid combination, so don't warn.
*emacs-23.4_rc1 (19 Jan 2012)
diff --git a/app-editors/emacs/emacs-23.3-r4.ebuild b/app-editors/emacs/emacs-23.3-r4.ebuild
index 08cf64b25113..cae407ae8c34 100644
--- a/app-editors/emacs/emacs-23.3-r4.ebuild
+++ b/app-editors/emacs/emacs-23.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r4.ebuild,v 1.6 2012/01/16 03:00:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.3-r4.ebuild,v 1.7 2012/01/28 10:54:33 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -149,9 +149,16 @@ src_configure() {
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf="${myconf} --with-x-toolkit=gtk"
- elif use Xaw3d || use athena; then
+ local f
+ for f in athena Xaw3d motif; do
+ use ${f} && ewarn "USE flag \"${f}\" ignored" \
+ "(superseded by \"gtk\")"
+ done
+ elif use athena || use Xaw3d; then
einfo "Configuring to build with Athena/Lucid toolkit"
myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
+ use motif && ewarn "USE flag \"motif\" ignored" \
+ "(superseded by \"athena\" or \"Xaw3d\")"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"
@@ -159,14 +166,6 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf="${myconf} --with-x-toolkit=no"
fi
-
- local f tk=
- for f in gtk Xaw3d athena motif; do
- use ${f} || continue
- [[ ${tk} ]] \
- && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
- tk="${tk}${tk:+ }${f}"
- done
elif use aqua; then
einfo "Configuring to build with Cocoa support"
myconf="${myconf} --with-ns --disable-ns-self-contained"
diff --git a/app-editors/emacs/emacs-23.4_rc1.ebuild b/app-editors/emacs/emacs-23.4_rc1.ebuild
index 99a9291d7150..5526781f8cdf 100644
--- a/app-editors/emacs/emacs-23.4_rc1.ebuild
+++ b/app-editors/emacs/emacs-23.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4_rc1.ebuild,v 1.1 2012/01/19 19:15:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.4_rc1.ebuild,v 1.2 2012/01/28 10:54:33 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -149,9 +149,16 @@ src_configure() {
if use gtk; then
einfo "Configuring to build with GIMP Toolkit (GTK+)"
myconf="${myconf} --with-x-toolkit=gtk"
- elif use Xaw3d || use athena; then
+ local f
+ for f in athena Xaw3d motif; do
+ use ${f} && ewarn "USE flag \"${f}\" ignored" \
+ "(superseded by \"gtk\")"
+ done
+ elif use athena || use Xaw3d; then
einfo "Configuring to build with Athena/Lucid toolkit"
myconf="${myconf} --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
+ use motif && ewarn "USE flag \"motif\" ignored" \
+ "(superseded by \"athena\" or \"Xaw3d\")"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"
@@ -159,14 +166,6 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf="${myconf} --with-x-toolkit=no"
fi
-
- local f tk=
- for f in gtk Xaw3d athena motif; do
- use ${f} || continue
- [[ ${tk} ]] \
- && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
- tk="${tk}${tk:+ }${f}"
- done
elif use aqua; then
einfo "Configuring to build with Cocoa support"
myconf="${myconf} --with-ns --disable-ns-self-contained"