summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-29 09:36:44 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-29 09:36:44 +0000
commit9921dda98837ff979b7233a3f6a798e009070796 (patch)
treea684902946584720b345f6fdc14af922882073e6 /app-editors/emacs
parentDisable docs generation. (diff)
downloadgentoo-2-9921dda98837ff979b7233a3f6a798e009070796.tar.gz
gentoo-2-9921dda98837ff979b7233a3f6a798e009070796.tar.bz2
gentoo-2-9921dda98837ff979b7233a3f6a798e009070796.zip
Warn about possible problems if the package manager does not preserve file modification times, bugs 181021 and 264130.
(Portage version: 2.2_rc27/cvs/Linux i686)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog7
-rw-r--r--app-editors/emacs/emacs-21.4-r18.ebuild15
-rw-r--r--app-editors/emacs/emacs-22.3-r2.ebuild15
3 files changed, 34 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 86f5aa5fa08c..bc2dffb88014 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.307 2009/03/12 10:19:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.308 2009/03/29 09:36:44 ulm Exp $
+
+ 29 Mar 2009; Ulrich Mueller <ulm@gentoo.org> emacs-21.4-r18.ebuild,
+ emacs-22.3-r2.ebuild:
+ Warn about possible problems if the package manager does not preserve file
+ modification times, bugs 181021 and 264130.
*emacs-21.4-r18 (12 Mar 2009)
diff --git a/app-editors/emacs/emacs-21.4-r18.ebuild b/app-editors/emacs/emacs-21.4-r18.ebuild
index abb5f4b51517..11e1dbdfe176 100644
--- a/app-editors/emacs/emacs-21.4-r18.ebuild
+++ b/app-editors/emacs/emacs-21.4-r18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r18.ebuild,v 1.1 2009/03/12 10:19:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r18.ebuild,v 1.2 2009/03/29 09:36:44 ulm Exp $
EAPI=2
WANT_AUTOCONF="2.1"
@@ -145,6 +145,9 @@ src_install() {
keepdir /usr/share/emacs/${PV}/leim
dodoc BUGS ChangeLog README
+
+ stamp_simple_el=$(stat --format=%Y \
+ "${D}/usr/share/emacs/${FULL_VERSION}/lisp/simple.el")
}
emacs-infodir-rebuild() {
@@ -178,6 +181,16 @@ pkg_postinst() {
elog "You disabled sendmail support for Emacs. If you later install"
elog "a MTA then you will need to recompile Emacs. See Bug #11104."
fi
+
+ local stamp=$(stat --format=%Y \
+ "${ROOT}/usr/share/emacs/${FULL_VERSION}/lisp/simple.el")
+ if [ "${stamp}" != "${stamp_simple_el}" ]; then
+ echo
+ ewarn "Your package manager does not preserve file modification times"
+ ewarn "when merging. This is a known issue with some package managers"
+ ewarn "and can trigger spurious warnings in Emacs at run time. These"
+ ewarn "warnings can be safely ignored."
+ fi
}
pkg_postrm() {
diff --git a/app-editors/emacs/emacs-22.3-r2.ebuild b/app-editors/emacs/emacs-22.3-r2.ebuild
index 6adb045bf27d..11356a6799f8 100644
--- a/app-editors/emacs/emacs-22.3-r2.ebuild
+++ b/app-editors/emacs/emacs-22.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r2.ebuild,v 1.3 2009/03/12 10:19:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r2.ebuild,v 1.4 2009/03/29 09:36:44 ulm Exp $
EAPI=2
@@ -209,6 +209,9 @@ src_install () {
elisp-site-file-install "${SITEFILE}" || die
dodoc AUTHORS BUGS CONTRIBUTE README || die "dodoc failed"
+
+ stamp_simple_el=$(stat --format=%Y \
+ "${D}/usr/share/emacs/${FULL_VERSION}/lisp/simple.el")
}
emacs-infodir-rebuild() {
@@ -249,6 +252,16 @@ pkg_postinst() {
elog "the Emacs eselect module, which also redirects man and info pages."
elog "Therefore, several Emacs versions can be installed at the same time."
elog "\"man emacs.eselect\" for details."
+
+ local stamp=$(stat --format=%Y \
+ "${ROOT}/usr/share/emacs/${FULL_VERSION}/lisp/simple.el")
+ if [ "${stamp}" != "${stamp_simple_el}" ]; then
+ echo
+ ewarn "Your package manager does not preserve file modification times"
+ ewarn "when merging. This is a known issue with some package managers"
+ ewarn "and can trigger spurious warnings in Emacs at run time. These"
+ ewarn "warnings can be safely ignored."
+ fi
}
pkg_postrm() {