summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-03-13 16:54:35 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-03-13 16:54:35 +0000
commita6877fb7b168e62896aa82f323d818d18024d609 (patch)
treed8939f74d27996c0a3cb498c5e32e60bd9c4d616 /app-editors/emacs-cvs
parentUnmasking latest fixed acroread with UTF-8 patch (diff)
downloadgentoo-2-a6877fb7b168e62896aa82f323d818d18024d609.tar.gz
gentoo-2-a6877fb7b168e62896aa82f323d818d18024d609.tar.bz2
gentoo-2-a6877fb7b168e62896aa82f323d818d18024d609.zip
gtk+2 support. gnome menu item support. cleanup.
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/ChangeLog7
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild52
-rw-r--r--app-editors/emacs-cvs/files/emacs.desktop7
3 files changed, 49 insertions, 17 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 54bbd9ccb4f8..7cb69f29b77c 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.7 2003/02/12 03:46:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.8 2003/03/13 16:54:35 mkennedy Exp $
*emacs-cvs-21.3.50 (22 Nov 2002)
+ 12 Mar 2003; Matthew Kennedy <mkennedy@gentoo.org>
+ emacs-cvs-21.3.50.ebuid :
+
+ Added support for GTK+ 2. Added GNOME menu support.
+
06 Jan 2003; Seemant Kulleen <seemant@gentoo.org> emacs-cvs-21.3.50.ebuild :
PROVIDE virtual/editor in addition to virtual/emacs
diff --git a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
index f198bcfc4bc0..568a1b6b92e6 100644
--- a/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.6 2003/02/13 06:39:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-21.3.50.ebuild,v 1.7 2003/03/13 16:54:35 mkennedy Exp $
ECVS_SERVER="subversions.gnu.org:/cvsroot/emacs"
ECVS_MODULE="emacs"
@@ -9,11 +9,10 @@ ECVS_CVS_OPTIONS="-dP"
inherit cvs
-# leim integrated with emacs now
-IUSE="X nls"
+IUSE="X nls gtk Xaw3d gnome"
S=${WORKDIR}/${ECVS_MODULE}
-DESCRIPTION="An incredibly powerful, extensible text editor (latest CVS)"
+DESCRIPTION="Emacs is the extensible, customizable, self-documenting real-time display editor."
SRC_URI=""
HOMEPAGE="http://www.gnu.org/software/emacs"
@@ -23,37 +22,52 @@ SANDBOX_DISABLED="1"
DEPEND=">=sys-libs/ncurses-5.3
sys-libs/gdbm
dev-util/cvs
+ dev-python/pexpect
X? ( virtual/x11
>=media-libs/libungif-4.1.0
>=media-libs/jpeg-6b
>=media-libs/tiff-3.5.7
- >=media-libs/libpng-1.2.5
- >=x11-libs/Xaw3d-1.5-r1 )
+ >=media-libs/libpng-1.2.5 )
+ gtk? ( =x11-libs/gtk+-2* )
+ Xaw3d? ( x11-libs/Xaw3d )
+ gnome? ( gnome-base/gnome-desktop )
nls? ( >=sys-devel/gettext-0.11.5 )"
PROVIDE="virtual/emacs virtual/editor"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc "
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DFILE=emacs.desktop
src_compile() {
local myconf
use nls || myconf="${myconf} --disable-nls"
- use X && myconf="${myconf}
+ if use X ;
+ then
+ myconf="${myconf}
--with-x
--with-xpm
--with-jpeg
--with-tiff
--with-gif
- --with-png
- --with-toolkit-scroll-bars
- --with-x-toolkit=athena" \
- || myconf="${myconf} --without-x"
-
- myconf="${myconf} --with-toolkit-scroll-bars --with-x-toolkit=athena"
+ --with-png"
+ if use gtk
+ then
+ myconf="${myconf} --with-x-toolkit=gtk
+ --with-gtk
+ --with-toolkit-scroll-bars"
+ elif use Xaw3d
+ then
+ myconf="${myconf} --with-x-toolkit=athena
+ --with-toolkit-scroll-bars"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
./configure --host=${CHOST} \
--prefix=/usr \
@@ -73,12 +87,18 @@ src_install () {
install || die
# fix info documentation
- find ${D}/usr/share/info -type f -print |\
+ find ${D}/usr/share/info -type f -print | \
while read i
do
mv ${i} ${i}.info
done
-
dodoc BUGS ChangeLog README
+
+ if use gnome
+ then
+ insinto /usr/share/gnome/apps/Application
+ doins ${FILESDIR}/${DFILE}
+ fi
+
}
diff --git a/app-editors/emacs-cvs/files/emacs.desktop b/app-editors/emacs-cvs/files/emacs.desktop
new file mode 100644
index 000000000000..da88f2fbe4f2
--- /dev/null
+++ b/app-editors/emacs-cvs/files/emacs.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=GNU Emacs
+Comment=Emacs is the extensible, customizable, self-documenting real-time display editor.
+Icon=gnome-emacs.png
+Terminal=0
+Type=Application
+Exec=/usr/bin/emacs