summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-06-15 11:00:23 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-06-15 11:00:23 +0000
commit88c62c76063e9e80fa9b408004774ba276615da8 (patch)
treecf020fc03269ae500f68ee4376ea4fb71f87dcf1 /app-doc
parentDescribe USE=html for app-doc/pms. (diff)
downloadgentoo-2-88c62c76063e9e80fa9b408004774ba276615da8.tar.gz
gentoo-2-88c62c76063e9e80fa9b408004774ba276615da8.tar.bz2
gentoo-2-88c62c76063e9e80fa9b408004774ba276615da8.zip
Add a html USE flag, to generate pms as HTML as well. Patch by David Leverton.
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/pms/ChangeLog6
-rw-r--r--app-doc/pms/pms-99999999.ebuild13
2 files changed, 15 insertions, 4 deletions
diff --git a/app-doc/pms/ChangeLog b/app-doc/pms/ChangeLog
index d684c970f7d4..136fde5e1277 100644
--- a/app-doc/pms/ChangeLog
+++ b/app-doc/pms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/pms
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/ChangeLog,v 1.1 2008/06/13 01:02:43 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/ChangeLog,v 1.2 2008/06/15 11:00:23 ingmar Exp $
+
+ 15 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org> pms-99999999.ebuild:
+ Add a html USE flag, to generate pms as HTML as well. Patch by David
+ Leverton.
*pms-99999999 (13 Jun 2008)
diff --git a/app-doc/pms/pms-99999999.ebuild b/app-doc/pms/pms-99999999.ebuild
index ac33a5caff4e..ea08ebd0f3d6 100644
--- a/app-doc/pms/pms-99999999.ebuild
+++ b/app-doc/pms/pms-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/pms-99999999.ebuild,v 1.1 2008/06/13 01:02:43 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/pms-99999999.ebuild,v 1.2 2008/06/15 11:00:23 ingmar Exp $
inherit git
@@ -13,9 +13,9 @@ SRC_URI=""
LICENSE="CCPL-Attribution-ShareAlike-3.0"
SLOT="0"
KEYWORDS=""
-IUSE="all-options kdebuild"
+IUSE="all-options html kdebuild"
-DEPEND="
+DEPEND="html? ( dev-tex/tex4ht )
dev-texlive/texlive-latex
dev-texlive/texlive-latexrecommended
dev-texlive/texlive-latexextra
@@ -31,9 +31,16 @@ set_conditional() {
src_compile() {
set_conditional all-options
set_conditional kdebuild
+
emake || die "emake failed"
+ if use html; then
+ emake html || die "emake html failed"
+ fi
}
src_install() {
dodoc pms.pdf || die "dodoc failed"
+ if use html; then
+ dohtml *.html pms.css $(shopt -s nullglob; echo *.png) || die "dohtml failed"
+ fi
}