summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-02-01 06:46:03 +0000
committerPeter Volkov <pva@gentoo.org>2011-02-01 06:46:03 +0000
commite824a8c7633b5c2b5342e85ec2f9503c2202a933 (patch)
tree998e123d53a73167a44d1a6609f43c91332b62cb /app-doc/gimp-help
parentRespect LDFLAGS, #335716 thank Diego Elio Pettenò for report. Add missing de... (diff)
downloadgentoo-2-e824a8c7633b5c2b5342e85ec2f9503c2202a933.tar.gz
gentoo-2-e824a8c7633b5c2b5342e85ec2f9503c2202a933.tar.bz2
gentoo-2-e824a8c7633b5c2b5342e85ec2f9503c2202a933.zip
Version bump, #353276, thank Tim Harder for report.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/gimp-help')
-rw-r--r--app-doc/gimp-help/ChangeLog9
-rw-r--r--app-doc/gimp-help/gimp-help-2.6.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-doc/gimp-help/ChangeLog b/app-doc/gimp-help/ChangeLog
index 462c4cb2f04f..c45505ff4629 100644
--- a/app-doc/gimp-help/ChangeLog
+++ b/app-doc/gimp-help/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/gimp-help
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/ChangeLog,v 1.67 2010/03/18 05:07:37 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/ChangeLog,v 1.68 2011/02/01 06:46:03 pva Exp $
+
+*gimp-help-2.6.1 (01 Feb 2011)
+
+ 01 Feb 2011; Peter Volkov <pva@gentoo.org> +gimp-help-2.6.1.ebuild:
+ Version bump, #353276, thank Tim Harder for report.
18 Mar 2010; Peter Volkov <pva@gentoo.org>
-files/gimp-help-0.13-image-files.patch,
diff --git a/app-doc/gimp-help/gimp-help-2.6.1.ebuild b/app-doc/gimp-help/gimp-help-2.6.1.ebuild
new file mode 100644
index 000000000000..736e584e8d02
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/gimp-help-2.6.1.ebuild,v 1.1 2011/02/01 06:46:03 pva Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="http://docs.gimp.org/"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+# Only *not* outdated translations (see, configure.ac) are listed.
+# On update do not forgive to check quickreference/Makefile.am for
+# QUICKREFERENCE_ALL_LINGUAS. LANGS should include that langs too.
+LANGS="de en es fr it ja ko nl nn pl ru sv zh_CN"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+ SRC_URI="${SRC_URI} linguas_${X}? ( mirror://gimp/help/${P}-html-${X}.tar.bz2 )"
+ EMPTY_LINGUAS_SRC_URI="mirror://gimp/help/${P}-html-${X}.tar.bz2 ${EMPTY_LINGUAS_SRC_URI}"
+ EMPTY_LINGUAS_SET="!linguas_${X}? ( ${EMPTY_LINGUAS_SET} "
+ EMPTY_LINGUAS_BRAKETS="${EMPTY_LINGUAS_BRAKETS} )"
+done
+SRC_URI="${SRC_URI} ${EMPTY_LINGUAS_SET} ${EMPTY_LINGUAS_SRC_URI} ${EMPTY_LINGUAS_BRAKETS}"
+
+DEPEND=""
+RDEPEND=">=media-gfx/gimp-2.4"
+
+S=${WORKDIR}/gimp-help-2/
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/gimp/2.0/help
+ doins -r html/*
+ dodoc AUTHORS MAINTAINERS README
+}