summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 10:52:21 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 10:52:21 +0000
commit19d7f1258b149be5e3f17660f3fa745e168ad55d (patch)
treeecbb1cf500a9f226c84929136c0f24b50d74cd2f /app-dicts
parentStable for amd64 wrt bug #505016 (diff)
downloadgentoo-2-19d7f1258b149be5e3f17660f3fa745e168ad55d.tar.gz
gentoo-2-19d7f1258b149be5e3f17660f3fa745e168ad55d.tar.bz2
gentoo-2-19d7f1258b149be5e3f17660f3fa745e168ad55d.zip
[QA] Revision bump to 2.5-r1. EAPI 5, remove copies of default phases, fix desktop file QA issues.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/kasumi/ChangeLog12
-rw-r--r--app-dicts/kasumi/files/kasumi-2.5-r1-fix-desktop-QA.patch13
-rw-r--r--app-dicts/kasumi/kasumi-2.5-r1.ebuild33
3 files changed, 55 insertions, 3 deletions
diff --git a/app-dicts/kasumi/ChangeLog b/app-dicts/kasumi/ChangeLog
index 1879a55c02f9..55b97adf5bf8 100644
--- a/app-dicts/kasumi/ChangeLog
+++ b/app-dicts/kasumi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-dicts/kasumi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.45 2012/05/03 02:18:37 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.46 2014/04/02 10:52:21 tomwij Exp $
+
+*kasumi-2.5-r1 (02 Apr 2014)
+
+ 02 Apr 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/kasumi-2.5-r1-fix-desktop-QA.patch, +kasumi-2.5-r1.ebuild:
+ [QA] Revision bump to 2.5-r1. EAPI 5, remove copies of default phases, fix
+ desktop file QA issues.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> kasumi-2.3-r1.ebuild,
kasumi-2.4.ebuild, kasumi-2.5.ebuild:
@@ -199,4 +206,3 @@
10 Jul 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+kasumi-0.3.ebuild:
Initial import.
-
diff --git a/app-dicts/kasumi/files/kasumi-2.5-r1-fix-desktop-QA.patch b/app-dicts/kasumi/files/kasumi-2.5-r1-fix-desktop-QA.patch
new file mode 100644
index 000000000000..a61dc0e11d51
--- /dev/null
+++ b/app-dicts/kasumi/files/kasumi-2.5-r1-fix-desktop-QA.patch
@@ -0,0 +1,13 @@
+--- a/kasumi.desktop.in
++++ b/kasumi.desktop.in
+@@ -8,8 +8,8 @@
+ Comment=Edit Anthy dictionary.
+ Comment[ja]=Anthy の個人辞書に単語を登録、削除、編集するツールです。
+ Exec=kasumi
+-Icon=kasumi.png
++Icon=/usr/share/pixmaps/kasumi.png
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+-Categories=Applications;Settings;
++Categories=Settings;
diff --git a/app-dicts/kasumi/kasumi-2.5-r1.ebuild b/app-dicts/kasumi/kasumi-2.5-r1.ebuild
new file mode 100644
index 000000000000..d7296dcd3261
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.5-r1.ebuild,v 1.1 2014/04/02 10:52:21 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/41436/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-r1-fix-desktop-QA.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}