summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-09-27 22:53:49 +0000
committerTim Harder <radhermit@gentoo.org>2014-09-27 22:53:49 +0000
commitfc2c8e2e03a0e03ef8d4597cc8afddc3371e515f (patch)
tree8c7a015a182e74582b96ea0cdb60556ddd083dc6 /app-crypt
parentVersion bump. (diff)
downloadgentoo-2-fc2c8e2e03a0e03ef8d4597cc8afddc3371e515f.tar.gz
gentoo-2-fc2c8e2e03a0e03ef8d4597cc8afddc3371e515f.tar.bz2
gentoo-2-fc2c8e2e03a0e03ef8d4597cc8afddc3371e515f.zip
Version bump stable series.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.20.7.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index c87522f5064b..1b6e0e3f081a 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.72 2014/09/23 06:27:41 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.73 2014/09/27 22:53:49 radhermit Exp $
+
+*p11-kit-0.20.7 (27 Sep 2014)
+
+ 27 Sep 2014; Tim Harder <radhermit@gentoo.org> +p11-kit-0.20.7.ebuild:
+ Version bump stable series.
*p11-kit-0.21.3 (23 Sep 2014)
diff --git a/app-crypt/p11-kit/p11-kit-0.20.7.ebuild b/app-crypt/p11-kit/p11-kit-0.20.7.ebuild
new file mode 100644
index 000000000000..f6ee08e62864
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.20.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.20.7.ebuild,v 1.1 2014/09/27 22:53:49 radhermit Exp $
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+asn1 debug +libffi +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4[${MULTILIB_USEDEP}] )
+ libffi? ( >=dev-libs/libffi-3.0.0[${MULTILIB_USEDEP}] )
+ trust? ( app-misc/ca-certificates )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
+ $(use_enable debug) \
+ $(use_with libffi) \
+ $(use_with asn1 libtasn1)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+}