summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-19 20:42:48 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-19 20:42:48 +0000
commit70eb2c577f9aaf44fe0633e3af5de76a848be7b3 (patch)
tree5751857cc02e161c19f8307c97b6c7772b20dbf8 /app-crypt
parentdebug support, minor fixes (diff)
downloadgentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.tar.gz
gentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.tar.bz2
gentoo-2-70eb2c577f9aaf44fe0633e3af5de76a848be7b3.zip
Added gnupg-1.4 support as per bug #74931.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog6
-rw-r--r--app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch82
-rw-r--r--app-crypt/seahorse/seahorse-0.6.3-r1.ebuild11
3 files changed, 96 insertions, 3 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index d221f763fdc3..689a7d9139e8 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/seahorse
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.29 2004/12/19 13:13:44 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.30 2004/12/19 20:42:48 dragonheart Exp $
+
+ 20 Dec 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/seahorse-0.6.3-gpg1.4.patch, seahorse-0.6.3-r1.ebuild:
+ Added gnupg-1.4 support as per bug #74931.
19 Dec 2004; Daniel Black <dragonheart@gentoo.org>
+files/seahorse-0.7.5-gpg1.4.patch, seahorse-0.6.3-r1.ebuild,
diff --git a/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch b/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch
new file mode 100644
index 000000000000..2c412ec51bd4
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.6.3-gpg1.4.patch
@@ -0,0 +1,82 @@
+--- configure.in.orig 2004-12-19 20:51:41.771221552 +0930
++++ configure.in 2004-12-19 21:02:59.005777288 +0930
+@@ -42,13 +42,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -83,8 +87,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
+--- configure.orig 2004-12-19 22:26:34.407687640 +0930
++++ configure 2004-12-19 22:27:24.973368792 +0930
+@@ -7881,13 +8124,17 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
+- if test "$micro" -ge "$req_micro"; then
+- ok="yes"
+- fi
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
++ if test "$micro" -ge "$req_micro"; then
++ ok="yes"
+ fi
+- fi
++ fi
++ fi
+ fi
+
+ if test "$ok" = "yes"; then
+@@ -7962,8 +8209,12 @@
+ micro=`echo $gpgme_config_version | \
+ sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- if test "$major" -eq "$req_major"; then
+- if test "$minor" -eq "$req_minor"; then
++ if test "$major" -gt "$req_major"; then
++ ok="yes"
++ elif test "$major" -eq "$req_major"; then
++ if test "$minor" -gt "$req_minor"; then
++ ok="yes"
++ elif test "$minor" -eq "$req_minor"; then
+ if test "$micro" -ge "$req_micro"; then
+ ok="yes"
+ fi
diff --git a/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild b/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild
index e2f21b4c463e..75cb8188b134 100644
--- a/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild
+++ b/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild,v 1.7 2004/10/31 15:27:12 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.6.3-r1.ebuild,v 1.8 2004/12/19 20:42:48 dragonheart Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="gnome front end to gnupg"
HOMEPAGE="http://seahorse.sourceforge.net/"
@@ -11,6 +11,7 @@ SRC_URI="mirror://sourceforge/seahorse/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc ~amd64 ~alpha ppc64"
+IUSE="doc"
RDEPEND="virtual/x11
>=app-crypt/gnupg-1.2.0
@@ -24,6 +25,12 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gpg1.4.patch || die "patch failed"
+}
+
src_compile() {
export GPGME_CONFIG=${ROOT}/usr/bin/gpgme3-config
gnome2_src_configure