summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-03-16 16:48:43 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2015-03-16 16:48:43 +0000
commit69f05ccabd1c80feb766adbd57fe57ab7bd34718 (patch)
treeeb05a5cf605a3321bb6ea2f4f820b776039569a8 /app-crypt
parentfixed build with mercurial (diff)
downloadgentoo-2-69f05ccabd1c80feb766adbd57fe57ab7bd34718.tar.gz
gentoo-2-69f05ccabd1c80feb766adbd57fe57ab7bd34718.tar.bz2
gentoo-2-69f05ccabd1c80feb766adbd57fe57ab7bd34718.zip
Version bump, bug#543520, thanks to Bob Wya. Cleanup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/ChangeLog10
-rw-r--r--app-crypt/chntpw/chntpw-100627.ebuild44
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild48
3 files changed, 56 insertions, 46 deletions
diff --git a/app-crypt/chntpw/ChangeLog b/app-crypt/chntpw/ChangeLog
index cbcba46bfef3..8b199e217971 100644
--- a/app-crypt/chntpw/ChangeLog
+++ b/app-crypt/chntpw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/chntpw
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.21 2013/06/02 10:54:42 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.22 2015/03/16 16:48:43 alonbl Exp $
+
+*chntpw-140201 (16 Mar 2015)
+
+ 16 Mar 2015; Alon Bar-Lev <alonbl@gentoo.org> +chntpw-140201.ebuild,
+ -chntpw-100627.ebuild:
+ Version bump, bug#543520, thanks to Bob Wya. Cleanup
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #328951
diff --git a/app-crypt/chntpw/chntpw-100627.ebuild b/app-crypt/chntpw/chntpw-100627.ebuild
deleted file mode 100644
index 2c0d9a27588b..000000000000
--- a/app-crypt/chntpw/chntpw-100627.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-100627.ebuild,v 1.1 2010/07/13 11:01:55 ssuominen Exp $
-
-EAPI=2
-inherit toolchain-funcs
-
-DESCRIPTION="Offline Windows NT Password & Registry Editor"
-HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
-SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static"
-
-RDEPEND="dev-libs/openssl"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_prepare() {
- sed -i \
- -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' \
- Makefile || die
-
- emake clean || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
- LIBS="-lcrypto" || die
-}
-
-src_install() {
- dobin chntpw cpnt reged || die
-
- if use static; then
- dobin {chntpw,reged}.static || die
- fi
-
- dodoc {HISTORY,README,regedit,WinReg}.txt || die
-}
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 000000000000..a2fbe7b90191
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-140201.ebuild,v 1.1 2015/03/16 16:48:43 alonbl Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+src_prepare() {
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt
+}