summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-08-29 21:01:37 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-08-29 21:01:37 +0000
commit077d04e13571dd4147282b29e1ce71083265bc7d (patch)
tree8893194c234bf4a0394b18be84bd0b810c4478b8 /app-crypt/xca
parentVersion bump. Add multiple-users USE flag that enables ganeti's multiuser sup... (diff)
downloadgentoo-2-077d04e13571dd4147282b29e1ce71083265bc7d.tar.gz
gentoo-2-077d04e13571dd4147282b29e1ce71083265bc7d.tar.bz2
gentoo-2-077d04e13571dd4147282b29e1ce71083265bc7d.zip
Fix openssl issue, bug#520948, thanks to wmatusiak@gmail.com
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/ChangeLog10
-rw-r--r--app-crypt/xca/files/xca-0.9.3-openssl.patch45
-rw-r--r--app-crypt/xca/xca-0.9.3-r2.ebuild54
3 files changed, 107 insertions, 2 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 829da49f353b..2052f2d86844 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/xca
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.42 2013/07/04 12:18:48 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.43 2014/08/29 21:01:37 alonbl Exp $
+
+*xca-0.9.3-r2 (29 Aug 2014)
+
+ 29 Aug 2014; Alon Bar-Lev <alonbl@gentoo.org> +files/xca-0.9.3-openssl.patch,
+ +xca-0.9.3-r2.ebuild:
+ Fix openssl issue, bug#520948, thanks to wmatusiak@gmail.com
04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> xca-0.9.3-r1.ebuild:
Stable for x86, wrt bug #470302
diff --git a/app-crypt/xca/files/xca-0.9.3-openssl.patch b/app-crypt/xca/files/xca-0.9.3-openssl.patch
new file mode 100644
index 000000000000..1e6ef270698d
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.9.3-openssl.patch
@@ -0,0 +1,45 @@
+From: Oliver Winker <oliver@oli1170.net>
+Date: Tue, 12 Aug 2014 17:08:05 +0000 (+0200)
+Subject: Fix for openssl 1.0.1i
+X-Git-Url: http://gitweb.hohnstaedt.de/?p=projects%2Fxca.git;a=commitdiff_plain;h=4f7cd417320215c8ed3567536cbf2ca008946c38
+
+Fix for openssl 1.0.1i
+
+Fixes following application error
+
+Errors
+error:0D0C40D8:asn1 encoding routines:c2i_ASN1_OBJECT:invalid object encoding
+error:0D08303A:asn1 encoding routines:ASN1_TEMPLATE_NOEXP_D2I:nested asn1 error
+
+Due to openssl 1.0.1i change:
+
+ commit 03b04ddac162c7b7fa3c57eadccc5a583a00d291
+ Author: Emilia Kasper <emilia@openssl.org>
+ Date: Wed Jul 2 19:02:33 2014 +0200
+
+Commit messgae amended and
+Signed-off-by: Christian Hohnstaedt <chohnstaedt@innominate.com>
+---
+
+diff --git a/lib/x509v3ext.cpp b/lib/x509v3ext.cpp
+index cf74c32..d94cbda 100644
+--- a/lib/x509v3ext.cpp
++++ b/lib/x509v3ext.cpp
+@@ -27,6 +27,8 @@ x509v3ext::x509v3ext(const X509_EXTENSION *n)
+ x509v3ext::x509v3ext(const x509v3ext &n)
+ {
+ ext = NULL;
++ if (!n.isValid())
++ return;
+ set(n.ext);
+ }
+
+@@ -743,7 +745,7 @@ X509_EXTENSION *x509v3ext::get() const
+
+ bool x509v3ext::isValid() const
+ {
+- return ext->value->length > 0 &&
++ return ext && ext->value && ext->value->length > 0 &&
+ OBJ_obj2nid(ext->object) != NID_undef;
+ }
+
diff --git a/app-crypt/xca/xca-0.9.3-r2.ebuild b/app-crypt/xca/xca-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..3e15ebb68b39
--- /dev/null
+++ b/app-crypt/xca/xca-0.9.3-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.9.3-r2.ebuild,v 1.1 2014/08/29 21:01:37 alonbl Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc bindist"
+
+RDEPEND=">=dev-libs/openssl-0.9.8[bindist=]
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+src_prepare() {
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+ epatch "${FILESDIR}"/${PN}-0.9.0-qt_detection.patch
+ epatch "${FILESDIR}"/${PN}-0.9.1-ldflags.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-openssl.patch
+}
+
+src_configure() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR="${EPREFIX}/usr" \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ ./configure || die "configure failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install
+
+ dodoc AUTHORS
+
+ insinto /etc/xca
+ doins misc/*.txt
+}