summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-04-07 05:29:10 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-04-07 05:29:10 +0000
commit480fa5c3eb73653ddbbfd6213e3e92e8b8f2f83a (patch)
tree490ecef1457eea861df127632591808ce08db069 /app-crypt/wxchecksums
parenttrim trailing newline (diff)
downloadgentoo-2-480fa5c3eb73653ddbbfd6213e3e92e8b8f2f83a.tar.gz
gentoo-2-480fa5c3eb73653ddbbfd6213e3e92e8b8f2f83a.tar.bz2
gentoo-2-480fa5c3eb73653ddbbfd6213e3e92e8b8f2f83a.zip
De-crapify:
- move wxGTK from RDEPEND to DEPEND - don't use hardcoded wx-config - don't prestrip binaries (Portage version: 2.1.2.3)
Diffstat (limited to 'app-crypt/wxchecksums')
-rw-r--r--app-crypt/wxchecksums/ChangeLog8
-rw-r--r--app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild19
2 files changed, 15 insertions, 12 deletions
diff --git a/app-crypt/wxchecksums/ChangeLog b/app-crypt/wxchecksums/ChangeLog
index 9f0f64affb29..e7b292cecab1 100644
--- a/app-crypt/wxchecksums/ChangeLog
+++ b/app-crypt/wxchecksums/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/wxchecksums
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/ChangeLog,v 1.14 2007/01/03 03:10:34 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/ChangeLog,v 1.15 2007/04/07 05:29:10 dirtyepic Exp $
+
+ 07 Apr 2007; Ryan Hill <dirtyepic@gentoo.org> wxchecksums-1.2.2.ebuild:
+ De-crapify:
+ - move wxGTK from RDEPEND to DEPEND
+ - don't use hardcoded wx-config
+ - don't prestrip binaries
03 Jan 2007; Steve Dibb <beandog@gentoo.org> wxchecksums-1.2.2.ebuild:
amd64 stable, bug 149964
diff --git a/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild b/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
index 235ab41f51e5..f9f8efcc34ad 100644
--- a/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
+++ b/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild,v 1.5 2007/01/03 03:10:34 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild,v 1.6 2007/04/07 05:29:10 dirtyepic Exp $
inherit eutils wxwidgets
@@ -15,18 +15,20 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc"
-RDEPEND=">=x11-libs/wxGTK-2.6.1"
-DEPEND="${RDEPEND}"
+DEPEND="=x11-libs/wxGTK-2.6*"
S="${WORKDIR}/${MY_P}/src"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
- # Modify CXXFLAGS
+ export WX_GTK_VER="2.6"
+ need-wxwidgets unicode
+
sed -i \
-e "s:-O2:${CXXFLAGS}:" \
- -e "s:wx-config:wx-config-2.6:" \
+ -e "s:wx-config:${WX_CONFIG}:g" \
+ -e "s:\$(INSTALL) -s:\$(INSTALL):" \
makefile || die "sed makefile failed"
epatch "${FILESDIR}/${PN}-gcc4.patch"
@@ -34,11 +36,6 @@ src_unpack() {
epatch "${FILESDIR}/${P}-wxdebug_build.patch"
}
-pkg_setup() {
- export WX_GTK_VER="2.6"
- need-wxwidgets unicode
-}
-
src_compile() {
emake || die "emake failed"
}