summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-04-09 22:41:27 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2015-04-09 22:41:27 +0000
commit30e935c480c5d96b7db19a9ad78f47595df20603 (patch)
tree7dc30af30a7ab0988b2b7b63d85f687ce84db0a2 /app-crypt/p11-kit
parentRemove old. (diff)
downloadgentoo-2-30e935c480c5d96b7db19a9ad78f47595df20603.tar.gz
gentoo-2-30e935c480c5d96b7db19a9ad78f47595df20603.tar.bz2
gentoo-2-30e935c480c5d96b7db19a9ad78f47595df20603.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.23.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index 620b886ae754..5aefda058db5 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.82 2015/03/03 05:47:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.83 2015/04/09 22:41:27 alonbl Exp $
+
+*p11-kit-0.23.1 (09 Apr 2015)
+
+ 09 Apr 2015; Alon Bar-Lev <alonbl@gentoo.org> +p11-kit-0.23.1.ebuild:
+ Version bump
02 Mar 2015; Yixun Lan <dlan@gentoo.org> p11-kit-0.22.1.ebuild:
add arm64 support, tested on A53 board
diff --git a/app-crypt/p11-kit/p11-kit-0.23.1.ebuild b/app-crypt/p11-kit/p11-kit-0.23.1.ebuild
new file mode 100644
index 000000000000..7b196c69d365
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.23.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.23.1.ebuild,v 1.1 2015/04/09 22:41:27 alonbl Exp $
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+asn1 debug +libffi +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4[${MULTILIB_USEDEP}] )
+ libffi? ( >=dev-libs/libffi-3.0.0[${MULTILIB_USEDEP}] )
+ trust? ( app-misc/ca-certificates )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
+ $(use_enable debug) \
+ $(use_with libffi) \
+ $(use_with asn1 libtasn1)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+}