summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-01 06:31:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-01 06:31:22 +0000
commite05436d147596129ab3627738544e45a8fc268a5 (patch)
tree56f3b094140e08f674ddabc61d084738fe6dbc01 /app-crypt/mhash/mhash-0.9.9.ebuild
parentReplace as-needed patch (#176264). (diff)
downloadgentoo-2-e05436d147596129ab3627738544e45a8fc268a5.tar.gz
gentoo-2-e05436d147596129ab3627738544e45a8fc268a5.tar.bz2
gentoo-2-e05436d147596129ab3627738544e45a8fc268a5.zip
Version bump.
(Portage version: 2.1.2.5)
Diffstat (limited to 'app-crypt/mhash/mhash-0.9.9.ebuild')
-rw-r--r--app-crypt/mhash/mhash-0.9.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/mhash/mhash-0.9.9.ebuild b/app-crypt/mhash/mhash-0.9.9.ebuild
new file mode 100644
index 000000000000..795cab1a10cb
--- /dev/null
+++ b/app-crypt/mhash/mhash-0.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.9.ebuild,v 1.1 2007/05/01 06:31:22 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
+HOMEPAGE="http://mhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ econf \
+ --enable-static \
+ --enable-shared || die
+ emake || die "make failure"
+ cd doc && emake mhash.html || die "failed to build html"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib}
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS INSTALL NEWS README TODO THANKS ChangeLog
+ dodoc doc/*.txt doc/skid* doc/*.c
+ dohtml doc/mhash.html || die "dohtml failed"
+}