summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-02-01 23:37:09 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-02-01 23:37:09 +0000
commit0d88316339da023c2a767b2c0fea94c6367542b8 (patch)
treec88454c4abc412901d776686adae909ae7217f17 /app-crypt/aescrypt
parentVersion bump (diff)
downloadgentoo-2-0d88316339da023c2a767b2c0fea94c6367542b8.tar.gz
gentoo-2-0d88316339da023c2a767b2c0fea94c6367542b8.tar.bz2
gentoo-2-0d88316339da023c2a767b2c0fea94c6367542b8.zip
Initial import, useful for initramfs
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-crypt/aescrypt')
-rw-r--r--app-crypt/aescrypt/ChangeLog10
-rw-r--r--app-crypt/aescrypt/aescrypt-3.0.6b.ebuild32
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch62
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch40
-rw-r--r--app-crypt/aescrypt/metadata.xml5
5 files changed, 149 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/ChangeLog b/app-crypt/aescrypt/ChangeLog
new file mode 100644
index 000000000000..1e08a0a49a34
--- /dev/null
+++ b/app-crypt/aescrypt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/aescrypt
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aescrypt/ChangeLog,v 1.1 2013/02/01 23:37:09 alonbl Exp $
+
+*aescrypt-3.0.6b (01 Feb 2013)
+
+ 01 Feb 2013; Alon Bar-Lev <alonbl@gentoo.org> +aescrypt-3.0.6b.ebuild,
+ +files/aescrypt-3.0.6b-build.patch, +files/aescrypt-3.0.6b-iconv.patch,
+ +metadata.xml:
+ Initial import, useful for initramfs
diff --git a/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
new file mode 100644
index 000000000000..939caf05ca47
--- /dev/null
+++ b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild,v 1.1 2013/02/01 23:37:09 alonbl Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Advanced file encryption using AES"
+HOMEPAGE="http://www.aescrypt.com/"
+SRC_URI="https://www.aescrypt.com/download/v3/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-iconv.patch"
+}
+
+src_compile() {
+ if use static; then
+ append-cflags "-DDISABLE_ICONV"
+ append-ldflags "-static"
+ fi
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
new file mode 100644
index 000000000000..8dac5b4e6f47
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
@@ -0,0 +1,62 @@
+From ab74ea544739ab044af1e9b398770d31add3b435 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:16:03 +0200
+Subject: [PATCH 1/2] build: respect CFLAGS, DESTDIR and permissions
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ Makefile | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ac661a8..abcdcc4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,8 @@ CC=gcc
+
+ #The below line is for debugging
+ #CFLAGS=-I. -ggdb -Wall -D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -D_FILE_OFFSET_BITS=64
++CFLAGS=-Wall
++EXTRA_CFLAGS=-D_FILE_OFFSET_BITS=64
+
+ LIBS=
+
+@@ -27,10 +28,10 @@ LIBS=
+ all: aescrypt aescrypt_keygen
+
+ aescrypt: aescrypt.o aes.o sha256.o password.o keyfile.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ aescrypt_keygen: aescrypt_keygen.o password.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ test:
+ @$(CC) -DTEST -o sha.test sha256.c
+@@ -48,15 +49,16 @@ testfile: aescrypt
+ cmp test.orig.txt test.txt
+
+ %.o: %.c %.h
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c $*.c
+
+ install: aescrypt
+- install -o root -g root -m 755 aescrypt /usr/bin
+- install -o root -g root -m 755 aescrypt_keygen /usr/bin
++ install -m 755 -d $(DESTDIR)/usr/bin
++ install -m 755 aescrypt $(DESTDIR)/usr/bin
++ install -m 755 aescrypt_keygen $(DESTDIR)/usr/bin
+
+ uninstall:
+- rm -f /usr/bin/aescrypt
+- rm -f /usr/bin/aescrypt_keygen
++ rm -f $(DESTDIR)/usr/bin/aescrypt
++ rm -f $(DESTDIR)/usr/bin/aescrypt_keygen
+
+ clean:
+ rm -f *.o aescrypt aescrypt_keygen test* *test
+--
+1.7.12.4
+
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
new file mode 100644
index 000000000000..616e87e38d61
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
@@ -0,0 +1,40 @@
+From 337cc9367a3cb4450eee245c6ceb615d0f05499d Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:18:08 +0200
+Subject: [PATCH 2/2] build: support disable iconv for static build
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ password.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/password.c b/password.c
+index 9a2c1f8..dee79da 100644
+--- a/password.c
++++ b/password.c
+@@ -232,6 +232,15 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ size_t ic_inbytesleft,
+ ic_outbytesleft;
+
++#ifdef DISABLE_ICONV
++ /* support only latin */
++ int i;
++ for (i=0;i<length+1;i++) {
++ out_passwd[i*2] = in_passwd[i];
++ out_passwd[i*2+1] = 0;
++ }
++ return length*2;
++#else
+ /* Max length is specified in character, but this function deals
+ * with bytes. So, multiply by two since we are going to create a
+ * UTF-16 string.
+@@ -273,5 +282,6 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ }
+ iconv_close(condesc);
+ return (max_length - ic_outbytesleft);
++#endif
+ }
+
+--
+1.7.12.4
+
diff --git a/app-crypt/aescrypt/metadata.xml b/app-crypt/aescrypt/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/app-crypt/aescrypt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>